summaryrefslogtreecommitdiff
path: root/app-emulation/cadvisor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /app-emulation/cadvisor
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'app-emulation/cadvisor')
-rw-r--r--app-emulation/cadvisor/Manifest4
-rw-r--r--app-emulation/cadvisor/cadvisor-0.28.2.ebuild26
-rw-r--r--app-emulation/cadvisor/files/cadvisor.initd18
-rw-r--r--app-emulation/cadvisor/metadata.xml11
4 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/cadvisor/Manifest b/app-emulation/cadvisor/Manifest
new file mode 100644
index 000000000000..8ea7fcba95d9
--- /dev/null
+++ b/app-emulation/cadvisor/Manifest
@@ -0,0 +1,4 @@
+AUX cadvisor.initd 555 BLAKE2B eaea61c2f974f9cfd97244243581d20da2f0312b4772f732193a2e3cededa3807ddfebcb417086c4d6d61257ce209019766b01f11b68eb0225cd131c90d4bf34 SHA512 c38d258b2416070076a51354f0b78be42809c571064a2b4098482137130b63c731fe8c97f9d8295170302b04d6bd5b5313c682594a36787f66193dc3d4f67429
+DIST cadvisor-0.28.2.tar.gz 4109967 BLAKE2B c55268a0768adeea75ecc2baa1093d5d5360d1e0be56cea467fe759278c7047060c4b78179a3a35801afbcf6415ffbeb7e0649c92e79878e5615c73a37eeabeb SHA512 e682b8e062ba373e5726a8076d5be75322e7c592bd751aa32da9a99e5d380a77fc4b376aa478b0beff18bae2bc8432d3a70542605681410d5e1e0b1919a6c252
+EBUILD cadvisor-0.28.2.ebuild 564 BLAKE2B 7e048727b92b8e24f69d67804f73b292806a0d60252a548796d2ba8a2f7d96f2e4da31c88cbc1c10d2fc796b6da7f079ab39e0cf2f0ce394210a16f7b298d053 SHA512 3673e73cbe50d3383d12580b7e1dad55e02c2aa229b27b3dd1e03299a8bbae3b8defc0661e369a68245a3fc4eb5ae0ca23384d36b4d1b33cccf99dcc70e0fe99
+MISC metadata.xml 325 BLAKE2B 3a83be7d0ee504a5ef4b25d8826101878da8bac2228afbe0598ec0aef7435d69ed6d754b88453336fd84a1ef38ab1646eb890bfbff1e8549836aa12c7d497f4b SHA512 d083dae5366eaea34ba9697c49a4399e822000a19b11cffffe82e08f4a331eb0f4672c8271ac342cebb79a66c1a245e41a17ff1d40ecbad2354940bfa14c1b06
diff --git a/app-emulation/cadvisor/cadvisor-0.28.2.ebuild b/app-emulation/cadvisor/cadvisor-0.28.2.ebuild
new file mode 100644
index 000000000000..25f12f419338
--- /dev/null
+++ b/app-emulation/cadvisor/cadvisor-0.28.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/google/cadvisor"
+
+inherit user golang-build golang-vcs-snapshot
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Analyzes resource usage and performance characteristics of running containers"
+
+HOMEPAGE="https://github.com/google/cadvisor"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+}
diff --git a/app-emulation/cadvisor/files/cadvisor.initd b/app-emulation/cadvisor/files/cadvisor.initd
new file mode 100644
index 000000000000..19e36b2c81a5
--- /dev/null
+++ b/app-emulation/cadvisor/files/cadvisor.initd
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+# Copyright 2016-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="cAdvisor - Analyzes resource usage and performance characteristics of running containers"
+pidfile=${pidfile:-"/run/${SVCNAME}.pid"}
+user=${user:-${SVCNAME}}
+group=${group:-${SVCNAME}}
+
+command="/usr/bin/cadvisor"
+command_background="true"
+start_stop_daemon_args="--user ${user} --group ${group} \
+ --stdout /var/log/${SVCNAME}/${SVCNAME}.log \
+ --stderr /var/log/${SVCNAME}/${SVCNAME}.log"
+
+depend() {
+ after net
+}
diff --git a/app-emulation/cadvisor/metadata.xml b/app-emulation/cadvisor/metadata.xml
new file mode 100644
index 000000000000..9685b121c378
--- /dev/null
+++ b/app-emulation/cadvisor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/cadvisor</remote-id>
+ </upstream>
+</pkgmetadata>