summaryrefslogtreecommitdiff
path: root/app-emulation/crun
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /app-emulation/crun
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'app-emulation/crun')
-rw-r--r--app-emulation/crun/Manifest5
-rw-r--r--app-emulation/crun/crun-0.13.ebuild (renamed from app-emulation/crun/crun-0.10.6.ebuild)35
-rw-r--r--app-emulation/crun/files/libocispec-deduplicate-json_common-in-makefile-am.patch31
3 files changed, 52 insertions, 19 deletions
diff --git a/app-emulation/crun/Manifest b/app-emulation/crun/Manifest
index 860f6fa71ebf..0106984da6b2 100644
--- a/app-emulation/crun/Manifest
+++ b/app-emulation/crun/Manifest
@@ -1,3 +1,4 @@
-DIST crun-0.10.6.tar.gz 1242736 BLAKE2B 840699c6a07ddaef3f6ab4ce226fa6c4ebf0e32641012b6467a2a622d575a48286555b84140d5a1c947b5ef00a691045b0618533fb246bfb6d605baa262febe4 SHA512 b7db09d0c7d2d6e8b1ea239ead5a2ca2b97f188a74f08f0d5ac787e0a698fddf596e7cfdde482c6bc8790d06a7705613e877344a44691c0be7388e6d046c4b15
-EBUILD crun-0.10.6.ebuild 1650 BLAKE2B 35568e68e2ca72d932d51ac50dc2c48c260ee75e82250253c725936a0a99cd49961e4f94f1f2bb38f519b244edab34a6ae3e99f378ff59f1b2ea6d9202723c21 SHA512 fff73b11a9e505ae218c974e028a15bfe7c222d9ca3a999d1e45895d8f99af37895885d02edd3fed8e9102a67dffd8323bdb71cb268b6c5f8f4f24ad7246ba26
+AUX libocispec-deduplicate-json_common-in-makefile-am.patch 1038 BLAKE2B 38f49d55ad043a94ecbf977adec35e0ef3627b018c572e5190fc7dc08748cd7aff5035e43d5256b69d497eb39e9bf17501be5084f8e19b81594c14a3a449b0d9 SHA512 4044d46cd3f0de139536b54876f68da5e1d18ace6e052dde1fadb5158ebb1e615714e86ca145ae2b804b1956d804e6c2bfff0796cdffe8bdb5f730ee3710f9d2
+DIST crun-0.13.tar.gz 1305048 BLAKE2B fbffabf4cfc744522147b47c5e2bf2bc48e074866108ec4ec8ab94e7ebdc39451851696fabde268b5853e1c3fafb0ac93527e08fdb766acebdd7cf952a9e1a9e SHA512 314612eaf3097160e9369b3400ac8a83e173ef1a53295191c925e96212ba00d032883db1e4615b8ba42ddb08f1e31ca5e5088ea583a469835ac3c27087a88d6e
+EBUILD crun-0.13.ebuild 1571 BLAKE2B 539926e2cbee09ab60f03e80f362cc77b3338877531521b7d1047efc5a61784e40e97ef506223ab35224f04672149141094b6f0959b3cb910289fb6bb407cf76 SHA512 19e336c04e4eb9d3299ecf9c9dc6c06a5cf967d11fdc156bb6a1d7c8d5ae88a559d5b5c069c8b7122754056f4a088b97da650a66e3a97f5f45fa5d0345f504f8
MISC metadata.xml 1031 BLAKE2B e0351ab86fa999bd962aa4b793df9dedc431885033d759590dcd4f3abb47436b7f83832138fe78c413898a04af97326d806b96b5f41b25b1ef1da0e10f947a53 SHA512 34e3e9fd8819f5fcf698a0f80acd99465b6fefb2aa33ddef9a302ced25a0eee4e522768a65e09ec3c1f9f7042f98b603978d502ef3dcea24a39bde4ded42c7d3
diff --git a/app-emulation/crun/crun-0.10.6.ebuild b/app-emulation/crun/crun-0.13.ebuild
index a644095e871b..5b014ac1198d 100644
--- a/app-emulation/crun/crun-0.10.6.ebuild
+++ b/app-emulation/crun/crun-0.13.ebuild
@@ -5,20 +5,19 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit python-any-r1
+inherit autotools python-any-r1
DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
HOMEPAGE="https://github.com/containers/crun"
SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
-LICENSE="GPL-3 LGPL-3+"
+LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="bpf +caps doc seccomp systemd static-libs"
DEPEND="
dev-libs/yajl
- sys-libs/libseccomp
caps? ( sys-libs/libcap )
seccomp? ( sys-libs/libseccomp )
systemd? ( sys-apps/systemd:= )
@@ -30,14 +29,25 @@ BDEPEND="
"
# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the priveledges
-# required to create linux "containers."
+# within a sandbox environment, due to the nature of the privileges
+# required to create linux "containers".
RESTRICT="test"
-DOCS=README.md
+DOCS=( README.md )
+
+PATCHES=(
+ # see https://709982.bugs.gentoo.org/attachment.cgi?id=614208
+ "${FILESDIR}/libocispec-deduplicate-json_common-in-makefile-am.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
econf \
+ --disable-criu \
$(use_enable bpf) \
$(use_enable caps) \
$(use_enable seccomp) \
@@ -46,27 +56,18 @@ src_configure() {
}
src_compile() {
- pushd libocispec || die
- emake
- popd || die
+ emake -C libocispec
emake crun
if use doc ; then
- emake crun.1
+ emake generate-man
fi
}
src_install() {
- pushd libocispec || die
- emake "DESTDIR=${D}" install-exec
- popd || die
emake "DESTDIR=${D}" install-exec
if use doc ; then
emake "DESTDIR=${D}" install-man
fi
- # there is currently a bug in upstream autotooling that continues to build static libraries despite
- # explicit configure options
- use static-libs || find "${ED}"/usr -name '*.la' -delete
-
einstalldocs
}
diff --git a/app-emulation/crun/files/libocispec-deduplicate-json_common-in-makefile-am.patch b/app-emulation/crun/files/libocispec-deduplicate-json_common-in-makefile-am.patch
new file mode 100644
index 000000000000..234ac20ad8d2
--- /dev/null
+++ b/app-emulation/crun/files/libocispec-deduplicate-json_common-in-makefile-am.patch
@@ -0,0 +1,31 @@
+From 9d58891c058efa55c7b95cb90597d4cadc5c66d8 Mon Sep 17 00:00:00 2001
+From: Bruce Guenter <bruce@untroubled.org>
+Date: Mon, 17 Feb 2020 13:54:14 -0600
+Subject: [PATCH] De-duplicate json_common in Makefile.am
+
+The source file src/json_common.c is listed twice in Makefile.am,
+leading libtool to produce an archive with duplicated symbols. This
+change removes the duplicate source.
+
+This was introduced in commit 2e318803a2c49521ea448e3ae010b1564a7e95ed
+
+Signed-off-by: Bruce Guenter <bruce@untroubled.org>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 65bed45..c7ede83 100644
+--- a/libocispec/Makefile.am
++++ b/libocispec/Makefile.am
+@@ -7,7 +7,7 @@ GITIGNOREFILES = build-aux/ gtk-doc.make config.h.in aclocal.m4
+ noinst_LTLIBRARIES = libocispec.la
+ noinst_LIBRARIES = libocispec.a
+
+-SOURCE_FILES = src/json_common.c \
++SOURCE_FILES = \
+ src/image_spec_schema_config_schema.c \
+ src/image_spec_schema_content_descriptor.c \
+ src/image_spec_schema_defs.c \
+--
+2.24.1