summaryrefslogtreecommitdiff
path: root/app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild')
-rw-r--r--app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild b/app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild
new file mode 100644
index 000000000000..b9a0908fcb3c
--- /dev/null
+++ b/app-emulation/docker-machine-kvm/docker-machine-kvm-0.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/dhiltgen/${PN}"
+EGO_VENDOR=(
+ "github.com/docker/machine v${PV}"
+ "github.com/libvirt/libvirt-go c3209e4ba8b8dda65c85ca0ac04302e55895caf7"
+)
+
+inherit golang-build golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+DESCRIPTION="KVM driver for docker-machine"
+
+HOMEPAGE="https://github.com/dhiltgen/docker-machine-kvm"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+COMMON_DEPEND="app-emulation/libvirt:=[qemu,virt-network]"
+DEPEND=">=dev-lang/go-1.6:=
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_VENDOR_URI}"
+
+src_compile() {
+ export GOPATH=${S}
+ cd "${S}"/src/${EGO_PN}/cmd/${PN/kvm/driver-kvm} || die
+ emake build || die
+}
+
+src_install() {
+ dobin "${S}/src/${EGO_PN}/cmd/${PN/kvm/driver-kvm}/${PN/kvm/driver-kvm}"
+ dodoc "${S}/src/${EGO_PN}/README.md"
+}