summaryrefslogtreecommitdiff
path: root/app-emulation/fs-uae/fs-uae-2.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /app-emulation/fs-uae/fs-uae-2.8.3.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'app-emulation/fs-uae/fs-uae-2.8.3.ebuild')
-rw-r--r--app-emulation/fs-uae/fs-uae-2.8.3.ebuild116
1 files changed, 116 insertions, 0 deletions
diff --git a/app-emulation/fs-uae/fs-uae-2.8.3.ebuild b/app-emulation/fs-uae/fs-uae-2.8.3.ebuild
new file mode 100644
index 000000000000..698c12210c57
--- /dev/null
+++ b/app-emulation/fs-uae/fs-uae-2.8.3.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg-utils
+
+DESCRIPTION="Integrates the most accurate Amiga emulation code available from WinUAE"
+HOMEPAGE="https://fs-uae.net/"
+SRC_URI="https://fs-uae.net/stable/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="fmv glew"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/libpng:0=
+ media-libs/libsdl2[opengl]
+ media-libs/openal
+ virtual/opengl
+ x11-libs/libdrm
+ x11-libs/libX11
+ fmv? ( media-libs/libmpeg2 )
+ glew? ( media-libs/glew:0= )
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.8.3-libmpeg2.patch
+)
+
+src_prepare() {
+ default
+ AT_NO_RECURSIVE=1 eautoreconf
+
+ # Ensure bundled libraries are not used. GLee and Udis86 are unused
+ # regardless. Only FLAC headers are bundled and the library is never
+ # used? Lua is bundled but differs from upstream. We keep the
+ # default of disabling the Lua feature anyway as it is unfinished.
+ rm -r glee/ libmpeg2/ libudis86/ || die
+}
+
+src_configure() {
+ # Qt and Udis86 are unused.
+ econf \
+ --enable-a2065 \
+ --enable-action-replay \
+ --enable-aga \
+ --enable-arcadia \
+ --enable-bsdsocket \
+ --enable-caps \
+ --enable-cd32 \
+ --enable-cdtv \
+ --enable-codegen \
+ --enable-dms \
+ --enable-drivesound \
+ --enable-fdi2raw \
+ --enable-gfxboard \
+ --enable-jit \
+ --enable-jit-fpu \
+ --enable-ncr9x \
+ --enable-ncr \
+ --enable-netplay \
+ --enable-parallel-port \
+ --enable-prowizard \
+ --enable-qemu-cpu \
+ --enable-qemu-slirp \
+ --enable-savestate \
+ --enable-scp \
+ --enable-serial-port \
+ --enable-slirp \
+ --enable-softfloat \
+ --enable-uaenative \
+ --enable-uaenet \
+ --enable-uaescsi \
+ --enable-uaeserial \
+ --disable-udis86 \
+ --enable-vpar \
+ --enable-xml-shader \
+ --enable-zip \
+ --with-glad \
+ --without-qt \
+ $(use_with fmv libmpeg2) \
+ $(use_with glew)
+}
+
+src_install() {
+ default
+
+ # Needed for QEMU-UAE.
+ insinto /usr/include/uae
+ doins src/include/uae/{api,attributes,log,ppc,qemu,types}.h
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+
+ elog "Install app-emulation/fs-uae-launcher for a better graphical interface."
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}