summaryrefslogtreecommitdiff
path: root/app-emulation/libcacard/libcacard-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /app-emulation/libcacard/libcacard-2.6.0.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'app-emulation/libcacard/libcacard-2.6.0.ebuild')
-rw-r--r--app-emulation/libcacard/libcacard-2.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/libcacard/libcacard-2.6.0.ebuild b/app-emulation/libcacard/libcacard-2.6.0.ebuild
new file mode 100644
index 000000000000..e54815fe8095
--- /dev/null
+++ b/app-emulation/libcacard/libcacard-2.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="virtual Common Access Card (CAC) library emulator"
+HOMEPAGE="https://www.spice-space.org/"
+SRC_URI="https://www.spice-space.org/download/libcacard/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+passthrough static-libs"
+
+RDEPEND=">=dev-libs/nss-3.13
+ >=dev-libs/glib-2.22
+ passthrough? ( >=sys-apps/pcsc-lite-1.8 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable passthrough pcsc) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc docs/*.txt
+ use static-libs || find "${ED}"/usr/ -name 'lib*.la' -delete
+}