summaryrefslogtreecommitdiff
path: root/app-emulation/libguestfs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emulation/libguestfs
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emulation/libguestfs')
-rw-r--r--app-emulation/libguestfs/Manifest2
-rw-r--r--app-emulation/libguestfs/libguestfs-1.48.3.ebuild218
2 files changed, 220 insertions, 0 deletions
diff --git a/app-emulation/libguestfs/Manifest b/app-emulation/libguestfs/Manifest
index e0a4b99e3476..3d6d40c5c529 100644
--- a/app-emulation/libguestfs/Manifest
+++ b/app-emulation/libguestfs/Manifest
@@ -1,4 +1,6 @@
AUX 1.44/0001-Check-for-caml_alloc_initialized_string-existence-ev.patch 991 BLAKE2B 213bea03f22a03f6cd7a82d310fcd106c1b06493e744a7bfb95b7820fe7813208e343170cf9d4322180528ea9e05ab94d54b1ba601bd0550388a33b1bf222211 SHA512 344729229c35e66d21911ae040b4a15ce9a5b37de0f1965272de1c85f21d3293182bbb7953cdd99bb8fe7909754ae462c5d7e973d369ff6d0b64c590fc1d2ee8
DIST libguestfs-1.48.0.tar.gz 18426132 BLAKE2B a0ace19998e6eb368fa8ad73242b7c35c72244e9b9881f3adb76dcc8ed6e9a77691012e5786a26680a944d0876091bbb1d0f9ac63c0f5046538acf4402f840ac SHA512 b2486f32a3958c2b3e68d3f547dcd192dc7f8c59e0efd8660cd27cae9c218ce4fc2a60480dcb6bb0d10d8abbc2d2f4796075aea1cfab5e3c7cd12c38d4352fe2
+DIST libguestfs-1.48.3.tar.gz 19185249 BLAKE2B 1de07920c731a64ece9f1541752672a0251af73e455a3bd74fff6d512e96ef3a1b8182728080571fbf0f49ef072ed17029c6a5bd12f8171a1d2079bff0c22df2 SHA512 d88b7869e6098af1f7748dc2e8163b245ea251fcdf962a71e3735f5a1748c9e87a17be259802da3e0bb13569d7f7233b2c5a554b20a2a7758e1974a30a70b786
EBUILD libguestfs-1.48.0.ebuild 5283 BLAKE2B 6ee79999c8f08b9049465794eba05b8032b3882e824ab62233bb02d4392c5afcbc8de44f6064ec08ec350022b1663c558d78d30743868472149ca22ad832b844 SHA512 1b87f8e4842279feb6a01255fab33273138a4f9355cae0aa22ce9b601dc8854995b4eae6134a7a0d64d2d7b1ada02cc513da8d8d4f0adbb98c0633d0c3481c59
+EBUILD libguestfs-1.48.3.ebuild 5389 BLAKE2B 9005f8111fc6bf561feb5ac7bb0e4087a3b9e45b2cfb1b24760c0900a56dfc92c64687dea75d912dee3da06b37efdef77ad20726a8487b9ba2dc4316fca228aa SHA512 efd9cf5f32661a0057aa3f384ac47a90a4a1f719482606ca6dc9011b599b1b12e80209eb1b031b865e316896d330d660c201714e6fd1ce0af119be1505e22528
MISC metadata.xml 612 BLAKE2B 434f61bf6376288a782f4d2781938b6d647b7c1fab5d598a8fdd96c380ecef5947bd326a2c4f0d09fa40b6d00b1d59b86b27bea92cef311d9eae411d31465c3c SHA512 3dc1ae8480b6d1c1e2a800d8f8bb0f4171f645c69a47c9319b6d7ccefc2434c2d57fbcd0b47d48008196d1d1835693ccef984219bf7a2b10c444ffd04ef55672
diff --git a/app-emulation/libguestfs/libguestfs-1.48.3.ebuild b/app-emulation/libguestfs/libguestfs-1.48.3.ebuild
new file mode 100644
index 000000000000..c1141e2e9a88
--- /dev/null
+++ b/app-emulation/libguestfs/libguestfs-1.48.3.ebuild
@@ -0,0 +1,218 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Bump with app-emulation/guestfs-tools and app-emulation/libguestfs-appliance (if any new release there)
+
+LUA_COMPAT=( lua5-1 )
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit autotools flag-o-matic linux-info lua-single perl-functions python-single-r1 strip-linguas toolchain-funcs
+
+MY_PV_1="$(ver_cut 1-2)"
+MY_PV_2="$(ver_cut 2)"
+[[ $(( ${MY_PV_2} % 2 )) -eq 0 ]] && SD="stable" || SD="development"
+
+DESCRIPTION="Tools for accessing, inspecting, and modifying virtual machine (VM) disk images"
+HOMEPAGE="https://libguestfs.org/"
+SRC_URI="https://libguestfs.org/download/${MY_PV_1}-${SD}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/${MY_PV_1}"
+KEYWORDS="~amd64"
+IUSE="doc erlang +fuse gtk inspect-icons introspection libvirt lua +ocaml +perl python ruby selinux static-libs systemtap test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Failures - doc
+COMMON_DEPEND="
+ >=app-admin/augeas-1.8.0
+ app-arch/cpio
+ app-arch/lzma
+ app-arch/rpm
+ app-arch/unzip[natspec]
+ app-arch/xz-utils
+ app-forensics/yara
+ app-cdr/cdrtools
+ app-crypt/gnupg
+ >=app-emulation/qemu-2.0[qemu_softmmu_targets_x86_64,systemtap?,selinux?,filecaps]
+ >=app-misc/hivex-1.3.1
+ dev-lang/perl:=
+ dev-libs/libconfig:=
+ dev-libs/libpcre2
+ dev-libs/libxml2:2=
+ dev-libs/jansson:=
+ >=dev-libs/yajl-2.0.4
+ net-libs/libtirpc:=
+ sys-libs/ncurses:0=
+ >=sys-apps/fakechroot-2.8
+ sys-apps/fakeroot
+ sys-apps/file
+ sys-devel/gettext
+ sys-fs/squashfs-tools:*
+ sys-libs/libcap
+ sys-libs/readline:=
+ virtual/acl
+ virtual/libcrypt:=
+ erlang? ( dev-lang/erlang )
+ perl? (
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Sys-Virt-0.2.4
+ virtual/perl-Getopt-Long
+ virtual/perl-Data-Dumper
+ dev-perl/libintl-perl
+ >=app-misc/hivex-1.3.1[perl?]
+ dev-perl/String-ShellQuote
+ )
+ python? ( ${PYTHON_DEPS} )
+ fuse? ( sys-fs/fuse:= )
+ gtk? (
+ sys-apps/dbus
+ x11-libs/gtk+:3
+ )
+ introspection? (
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/gobject-introspection-1.30.0:=
+ )
+ inspect-icons? (
+ media-libs/netpbm
+ media-gfx/icoutils
+ )
+ libvirt? ( app-emulation/libvirt )
+ lua? ( ${LUA_DEPS} )
+ ocaml? ( >=dev-lang/ocaml-4.03:=[ocamlopt] )
+ selinux? (
+ sys-libs/libselinux:=
+ sys-libs/libsemanage
+ )
+ systemtap? ( dev-util/systemtap )
+"
+# Some OCaml is always required
+# bug #729674
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/ocaml-4.03:=[ocamlopt]
+ dev-util/gperf
+ dev-ml/findlib[ocamlopt]
+ doc? ( app-text/po4a )
+ ocaml? (
+ dev-ml/ounit2[ocamlopt]
+ || (
+ <dev-ml/ocaml-gettext-0.4.2
+ dev-ml/ocaml-gettext-stub[ocamlopt]
+ )
+ )
+ ruby? ( dev-lang/ruby virtual/rubygems dev-ruby/rake )
+ test? ( introspection? ( dev-libs/gjs ) )
+"
+BDEPEND="virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ app-emulation/libguestfs-appliance
+ acct-group/kvm
+"
+# Upstream build scripts compile and install Lua bindings for the ABI version
+# obtained by running 'lua' on the build host
+BDEPEND="lua? ( ${LUA_DEPS} )"
+
+DOCS=( AUTHORS BUGS ChangeLog HACKING README TODO )
+
+PATCHES=(
+ #"${FILESDIR}"/${MY_PV_1}/
+ "${FILESDIR}"/1.44/
+)
+
+pkg_setup() {
+ CONFIG_CHECK="~KVM ~VIRTIO"
+ [[ -n "${CONFIG_CHECK}" ]] && check_extra_config
+
+ use lua && lua-single_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # bug #794877
+ tc-export AR
+
+ # Skip Bash test
+ # (See 13-test-suite.log in linked bug)
+ # bug #794874
+ export SKIP_TEST_COMPLETE_IN_SCRIPT_SH=1
+
+ # Disable feature test for kvm for more reason
+ # i.e: not loaded module in __build__ time,
+ # build server not supported kvm, etc. ...
+ #
+ # In fact, this feature is virtio support and requires
+ # configured kernel.
+ export vmchannel_test=no
+
+ # Give a nudge to help find libxcrypt[-system]
+ # We have a := dep on virtual/libcrypt to ensure this doesn't become stale.
+ # bug #703118, bug #789354
+ if ! has_version 'sys-libs/libxcrypt[system]' ; then
+ append-ldflags "-L${ESYSROOT}/usr/$(get_libdir)/xcrypt"
+ append-ldflags "-Wl,-R${ESYSROOT}/usr/$(get_libdir)/xcrypt"
+ fi
+
+ # Avoid automagic SELinux dependency
+ export ac_cv_header_selinux_selinux_h=$(usex selinux)
+
+ # Test suite at least has a bunch of bashisms
+ SHELL="${BROOT}"/bin/bash CONFIG_SHELL="${BROOT}"/bin/bash econf \
+ --disable-appliance \
+ --disable-daemon \
+ --disable-haskell \
+ --disable-golang \
+ --disable-rust \
+ --disable-php \
+ --without-java \
+ --with-extra="-gentoo" \
+ --with-readline \
+ $(usex doc '' PO4A=no) \
+ $(use_enable ocaml) \
+ $(use_enable erlang) \
+ $(use_enable fuse) \
+ $(use_enable introspection gobject) \
+ $(use_enable introspection) \
+ $(use_with libvirt) \
+ $(use_enable lua) \
+ $(use_enable python) \
+ $(use_enable perl) \
+ $(use_enable ruby) \
+ $(use_enable static-libs static) \
+ $(use_enable systemtap probes)
+}
+
+src_install() {
+ strip-linguas -i po
+
+ emake DESTDIR="${D}" install "LINGUAS=""${LINGUAS}"""
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use perl ; then
+ perl_delete_localpod
+
+ # Workaround Build.PL for now
+ doman "${ED}"/usr/man/man3/Sys::Guestfs.3pm
+ rm -rf "${ED}"/usr/man || die
+ fi
+}
+
+pkg_postinst() {
+ einfo "Please ensure you are in the 'kvm' group for decent performance!"
+
+ if ! use gtk ; then
+ einfo "virt-p2v NOT installed"
+ fi
+
+ einfo "Note that common tools like virt-resize are now part of app-emulation/guestfs-tools"
+}