summaryrefslogtreecommitdiff
path: root/app-emulation/lxc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /app-emulation/lxc/files
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'app-emulation/lxc/files')
-rw-r--r--app-emulation/lxc/files/lxc-1.0.11-bash-completion.patch27
-rw-r--r--app-emulation/lxc/files/lxc-1.0.11-major.patch64
-rw-r--r--app-emulation/lxc/files/lxc-2.0.3-bash-completion.patch31
-rw-r--r--app-emulation/lxc/files/lxc-2.0.3-omit-sysconfig.patch5
-rw-r--r--app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch31
-rw-r--r--app-emulation/lxc/files/lxc-2.0.4-omit-sysconfig.patch5
-rw-r--r--app-emulation/lxc/files/lxc-2.0.5-bash-completion.patch31
7 files changed, 91 insertions, 103 deletions
diff --git a/app-emulation/lxc/files/lxc-1.0.11-bash-completion.patch b/app-emulation/lxc/files/lxc-1.0.11-bash-completion.patch
new file mode 100644
index 000000000000..d8d0bac55a76
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-1.0.11-bash-completion.patch
@@ -0,0 +1,27 @@
+diff --git a/config/bash/lxc.in b/config/bash/lxc.in
+index 344d5cb2..f051eaae 100644
+--- a/config/bash/lxc.in
++++ b/config/bash/lxc.in
+@@ -1,4 +1,3 @@
+-_have lxc-start && {
+ _lxc_names() {
+ COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
+ }
+@@ -100,4 +99,3 @@ _have lxc-start && {
+
+ complete -o default -F _lxc_generic_o lxc-clone
+ complete -o default -F _lxc_generic_o lxc-start-ephemeral
+-}
+diff --git a/configure.ac b/configure.ac
+index 2ea88c19..f52d772a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -429,7 +429,7 @@ AM_CONDITIONAL([ENABLE_BASH], [test "x$enable_bash" = "xyes"])
+ AM_COND_IF([ENABLE_BASH],
+ [AC_MSG_CHECKING([bash completion directory])
+ PKG_CHECK_VAR(bashcompdir, [bash-completion], [completionsdir], ,
+- bashcompdir="${sysconfdir}/bash_completion.d")
++ bashcompdir="$datadir/bash-completion/completions")
+ AC_MSG_RESULT([$bashcompdir])
+ AC_SUBST(bashcompdir)
+ ])
diff --git a/app-emulation/lxc/files/lxc-1.0.11-major.patch b/app-emulation/lxc/files/lxc-1.0.11-major.patch
new file mode 100644
index 000000000000..8a3c2b2bd6d3
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-1.0.11-major.patch
@@ -0,0 +1,64 @@
+diff --git a/src/lxc/bdev.c b/src/lxc/bdev.c
+index 59eda7e4..44b71d4c 100644
+--- a/src/lxc/bdev.c
++++ b/src/lxc/bdev.c
+@@ -41,6 +41,7 @@
+ #include <libgen.h>
+ #include <linux/loop.h>
+ #include <dirent.h>
++#include <sys/sysmacros.h>
+
+ #include "lxc.h"
+ #include "config.h"
+@@ -58,9 +59,6 @@
+ #ifdef MAJOR_IN_MKDEV
+ # include <sys/mkdev.h>
+ #endif
+-#ifdef MAJOR_IN_SYSMACROS
+-# include <sys/sysmacros.h>
+-#endif
+
+ #ifndef BLKGETSIZE64
+ #define BLKGETSIZE64 _IOR(0x12,114,size_t)
+diff --git a/src/lxc/conf.c b/src/lxc/conf.c
+index 5d583d5f..d4217c27 100644
+--- a/src/lxc/conf.c
++++ b/src/lxc/conf.c
+@@ -36,14 +36,12 @@
+ #include <pwd.h>
+ #include <grp.h>
+ #include <time.h>
++#include <sys/sysmacros.h>
+
+ /* makedev() */
+ #ifdef MAJOR_IN_MKDEV
+ # include <sys/mkdev.h>
+ #endif
+-#ifdef MAJOR_IN_SYSMACROS
+-# include <sys/sysmacros.h>
+-#endif
+
+ #ifdef HAVE_STATVFS
+ #include <sys/statvfs.h>
+diff --git a/src/lxc/lxccontainer.c b/src/lxc/lxccontainer.c
+index 3963a3ee..30ac6733 100644
+--- a/src/lxc/lxccontainer.c
++++ b/src/lxc/lxccontainer.c
+@@ -36,6 +36,7 @@
+ #include <stdint.h>
+ #include <grp.h>
+ #include <sys/syscall.h>
++#include <sys/sysmacros.h>
+
+ #include <lxc/lxccontainer.h>
+ #include <lxc/version.h>
+@@ -60,9 +61,6 @@
+ #ifdef MAJOR_IN_MKDEV
+ # include <sys/mkdev.h>
+ #endif
+-#ifdef MAJOR_IN_SYSMACROS
+-# include <sys/sysmacros.h>
+-#endif
+
+ #if HAVE_IFADDRS_H
+ #include <ifaddrs.h>
diff --git a/app-emulation/lxc/files/lxc-2.0.3-bash-completion.patch b/app-emulation/lxc/files/lxc-2.0.3-bash-completion.patch
deleted file mode 100644
index 9ef6013e5b6f..000000000000
--- a/app-emulation/lxc/files/lxc-2.0.3-bash-completion.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- lxc-lxc-2.0.1/config/bash/Makefile.am.orig 2016-05-18 20:40:42.238487678 +0000
-+++ lxc-lxc-2.0.1/config/bash/Makefile.am 2016-05-18 20:43:02.163497779 +0000
-@@ -2,12 +2,12 @@
-
- if ENABLE_BASH
- install-bash:
-- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/
-- $(INSTALL_DATA) lxc $(DESTDIR)$(sysconfdir)/bash_completion.d/
-+ $(MKDIR_P) $(DESTDIR)$(datarootdir)/bash-completion/completions/
-+ $(INSTALL_DATA) lxc $(DESTDIR)$(datarootdir)/bash-completion/completions/
-
- uninstall-bash:
-- rm -f $(DESTDIR)$(sysconfdir)/bash_completion.d/lxc
-- rmdir $(DESTDIR)$(sysconfdir)/bash_completion.d/ || :
-+ rm -f $(DESTDIR)$(datarootdir)/bash-completion/completions/lxc
-+ rmdir $(DESTDIR)$(datarootdir)/bash-completion/completions/ || :
-
- install-data-local: install-bash
- uninstall-local: uninstall-bash
---- lxc-lxc-2.0.1/config/bash/lxc.in.orig 2016-05-18 20:40:51.079488316 +0000
-+++ lxc-lxc-2.0.1/config/bash/lxc.in 2016-05-18 20:45:03.506506538 +0000
-@@ -1,4 +1,3 @@
--_have lxc-start && {
- _lxc_names() {
- COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
- }
-@@ -100,4 +99,3 @@
-
- complete -o default -F _lxc_generic_o lxc-copy
- complete -o default -F _lxc_generic_o lxc-start-ephemeral
--}
diff --git a/app-emulation/lxc/files/lxc-2.0.3-omit-sysconfig.patch b/app-emulation/lxc/files/lxc-2.0.3-omit-sysconfig.patch
deleted file mode 100644
index 9b83a3b2687c..000000000000
--- a/app-emulation/lxc/files/lxc-2.0.3-omit-sysconfig.patch
+++ /dev/null
@@ -1,5 +0,0 @@
---- lxc-lxc-2.0.1/config/Makefile.am.orig 2016-05-19 02:56:11.891113982 +0000
-+++ lxc-lxc-2.0.1/config/Makefile.am 2016-05-19 02:56:32.596115476 +0000
-@@ -1 +1 @@
--SUBDIRS = apparmor bash etc init selinux templates yum sysconfig
-+SUBDIRS = apparmor bash etc init selinux templates yum
diff --git a/app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch b/app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch
deleted file mode 100644
index 6feb4c2bb01c..000000000000
--- a/app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- /config/bash/Makefile.am.orig 2016-05-18 20:40:42.238487678 +0000
-+++ /config/bash/Makefile.am 2016-05-18 20:43:02.163497779 +0000
-@@ -2,12 +2,12 @@
-
- if ENABLE_BASH
- install-bash:
-- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/
-- $(INSTALL_DATA) lxc $(DESTDIR)$(sysconfdir)/bash_completion.d/
-+ $(MKDIR_P) $(DESTDIR)$(datarootdir)/bash-completion/completions/
-+ $(INSTALL_DATA) lxc $(DESTDIR)$(datarootdir)/bash-completion/completions/
-
- uninstall-bash:
-- rm -f $(DESTDIR)$(sysconfdir)/bash_completion.d/lxc
-- rmdir $(DESTDIR)$(sysconfdir)/bash_completion.d/ || :
-+ rm -f $(DESTDIR)$(datarootdir)/bash-completion/completions/lxc
-+ rmdir $(DESTDIR)$(datarootdir)/bash-completion/completions/ || :
-
- install-data-local: install-bash
- uninstall-local: uninstall-bash
---- /config/bash/lxc.in.orig 2016-05-18 20:40:51.079488316 +0000
-+++ /config/bash/lxc.in 2016-05-18 20:45:03.506506538 +0000
-@@ -1,4 +1,3 @@
--_have lxc-start && {
- _lxc_names() {
- COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
- }
-@@ -100,4 +99,3 @@
-
- complete -o default -F _lxc_generic_o lxc-copy
- complete -o default -F _lxc_generic_o lxc-start-ephemeral
--}
diff --git a/app-emulation/lxc/files/lxc-2.0.4-omit-sysconfig.patch b/app-emulation/lxc/files/lxc-2.0.4-omit-sysconfig.patch
deleted file mode 100644
index 3ec81356499e..000000000000
--- a/app-emulation/lxc/files/lxc-2.0.4-omit-sysconfig.patch
+++ /dev/null
@@ -1,5 +0,0 @@
---- /config/Makefile.am.orig 2016-05-19 02:56:11.891113982 +0000
-+++ /config/Makefile.am 2016-05-19 02:56:32.596115476 +0000
-@@ -1 +1 @@
--SUBDIRS = apparmor bash etc init selinux templates yum sysconfig
-+SUBDIRS = apparmor bash etc init selinux templates yum
diff --git a/app-emulation/lxc/files/lxc-2.0.5-bash-completion.patch b/app-emulation/lxc/files/lxc-2.0.5-bash-completion.patch
deleted file mode 100644
index 6feb4c2bb01c..000000000000
--- a/app-emulation/lxc/files/lxc-2.0.5-bash-completion.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- /config/bash/Makefile.am.orig 2016-05-18 20:40:42.238487678 +0000
-+++ /config/bash/Makefile.am 2016-05-18 20:43:02.163497779 +0000
-@@ -2,12 +2,12 @@
-
- if ENABLE_BASH
- install-bash:
-- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/
-- $(INSTALL_DATA) lxc $(DESTDIR)$(sysconfdir)/bash_completion.d/
-+ $(MKDIR_P) $(DESTDIR)$(datarootdir)/bash-completion/completions/
-+ $(INSTALL_DATA) lxc $(DESTDIR)$(datarootdir)/bash-completion/completions/
-
- uninstall-bash:
-- rm -f $(DESTDIR)$(sysconfdir)/bash_completion.d/lxc
-- rmdir $(DESTDIR)$(sysconfdir)/bash_completion.d/ || :
-+ rm -f $(DESTDIR)$(datarootdir)/bash-completion/completions/lxc
-+ rmdir $(DESTDIR)$(datarootdir)/bash-completion/completions/ || :
-
- install-data-local: install-bash
- uninstall-local: uninstall-bash
---- /config/bash/lxc.in.orig 2016-05-18 20:40:51.079488316 +0000
-+++ /config/bash/lxc.in 2016-05-18 20:45:03.506506538 +0000
-@@ -1,4 +1,3 @@
--_have lxc-start && {
- _lxc_names() {
- COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
- }
-@@ -100,4 +99,3 @@
-
- complete -o default -F _lxc_generic_o lxc-copy
- complete -o default -F _lxc_generic_o lxc-start-ephemeral
--}