summaryrefslogtreecommitdiff
path: root/app-emulation/lxd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emulation/lxd/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emulation/lxd/files')
-rw-r--r--app-emulation/lxd/files/lxd-2.14-dont-go-get.patch16
-rw-r--r--app-emulation/lxd/files/lxd-2.14-fix-fr-po.patch11
-rw-r--r--app-emulation/lxd/files/lxd-2.14.confd27
-rw-r--r--app-emulation/lxd/files/lxd-2.14.initd46
-rw-r--r--app-emulation/lxd/files/lxd-2.14.service10
-rw-r--r--app-emulation/lxd/files/lxd-2.17-dont-go-get.patch16
-rw-r--r--app-emulation/lxd/files/lxd-2.17.confd27
-rw-r--r--app-emulation/lxd/files/lxd-2.17.initd46
-rw-r--r--app-emulation/lxd/files/lxd-2.17.service10
-rw-r--r--app-emulation/lxd/files/lxd-2.18-dont-go-get.patch16
-rw-r--r--app-emulation/lxd/files/lxd-2.18.confd27
-rw-r--r--app-emulation/lxd/files/lxd-2.18.initd46
-rw-r--r--app-emulation/lxd/files/lxd-2.18.service10
13 files changed, 308 insertions, 0 deletions
diff --git a/app-emulation/lxd/files/lxd-2.14-dont-go-get.patch b/app-emulation/lxd/files/lxd-2.14-dont-go-get.patch
new file mode 100644
index 000000000000..a6e25e325b95
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.14-dont-go-get.patch
@@ -0,0 +1,16 @@
+--- /src/github.com/lxc/lxd/Makefile.orig 2016-07-11 23:34:40.299664675 +0000
++++ /src/github.com/lxc/lxd/Makefile 2016-07-11 23:37:00.816018727 +0000
+@@ -13,13 +13,11 @@
+
+ .PHONY: default
+ default:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./...
+ @echo "LXD built successfully"
+
+ .PHONY: client
+ client:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./lxc
+ @echo "LXD client built successfully"
+
diff --git a/app-emulation/lxd/files/lxd-2.14-fix-fr-po.patch b/app-emulation/lxd/files/lxd-2.14-fix-fr-po.patch
new file mode 100644
index 000000000000..410efd9987e8
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.14-fix-fr-po.patch
@@ -0,0 +1,11 @@
+--- /src/github.com/lxc/lxd/po/fr.po
++++ /src/github.com/lxc/lxd/po/fr.po
+@@ -1110,7 +1110,7 @@ msgstr ""
+ "Toutes les fonctionnalités de LXD peuvent être utilisées à l'aide des "
+ "commandes ci-dessous.\n"
+ "Pour de l'aide avec l'une des commandes, simplement les utiliser avec --"
+-"help.\n"
++"help."
+
+ #: lxc/action.go:45
+ msgid "Time to wait for the container before killing it"
diff --git a/app-emulation/lxd/files/lxd-2.14.confd b/app-emulation/lxd/files/lxd-2.14.confd
new file mode 100644
index 000000000000..3d553276a5e3
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.14.confd
@@ -0,0 +1,27 @@
+# Group which owns the shared socket
+LXD_OPTIONS+=" --group lxd"
+
+
+
+# Enable cpu profiling into the specified file
+#LXD_OPTIONS+=" --cpuprofile /tmp/lxc_cpu_profile"
+
+# Enable memory profiling into the specified file
+#LXD_OPTIONS+=" --memprofile /tmp/lxc_mem_profile"
+
+
+
+# Enables debug mode
+#LXD_OPTIONS+=" --debug"
+
+# For debugging, print a complete stack trace every n seconds
+#LXD_OPTIONS+=" --print-goroutines-every 5"
+
+# Enables verbose mode
+#LXD_OPTIONS+=" -v"
+
+# Logfile to log to
+#LXD_OPTIONS+=" --logfile /var/log/lxd/lxd.log"
+
+# Enables syslog logging
+#LXD_OPTIONS+=" --syslog"
diff --git a/app-emulation/lxd/files/lxd-2.14.initd b/app-emulation/lxd/files/lxd-2.14.initd
new file mode 100644
index 000000000000..51c8e7e06553
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.14.initd
@@ -0,0 +1,46 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DAEMON=/usr/sbin/lxd
+PIDFILE=/run/lxd.pid
+
+extra_commands="stopall"
+
+depend() {
+ need net
+ use lxcfs
+}
+
+start() {
+ ebegin "Starting lxd server"
+
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ ${LXD_OPTIONS}
+
+ eend $?
+}
+
+stop() {
+ if [ "$RC_GOINGDOWN" = "YES" ] || [ "$RC_REBOOT" = "YES" ]; then
+ stopall
+ else
+ ebegin "Stopping lxd service (but not containers)"
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend $?
+ fi
+}
+
+stopall() {
+ ebegin "Stopping lxd service and containers"
+ if "${DAEMON}" shutdown; then
+ /etc/init.d/lxd zap
+ rm -f ${PIDFILE}
+ fi
+ eend $?
+}
diff --git a/app-emulation/lxd/files/lxd-2.14.service b/app-emulation/lxd/files/lxd-2.14.service
new file mode 100644
index 000000000000..d00635fbcdd9
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.14.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Container hypervisor based on LXC
+
+[Service]
+ExecStart=/usr/sbin/lxd --group lxd
+KillMode=process
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-emulation/lxd/files/lxd-2.17-dont-go-get.patch b/app-emulation/lxd/files/lxd-2.17-dont-go-get.patch
new file mode 100644
index 000000000000..a6e25e325b95
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.17-dont-go-get.patch
@@ -0,0 +1,16 @@
+--- /src/github.com/lxc/lxd/Makefile.orig 2016-07-11 23:34:40.299664675 +0000
++++ /src/github.com/lxc/lxd/Makefile 2016-07-11 23:37:00.816018727 +0000
+@@ -13,13 +13,11 @@
+
+ .PHONY: default
+ default:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./...
+ @echo "LXD built successfully"
+
+ .PHONY: client
+ client:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./lxc
+ @echo "LXD client built successfully"
+
diff --git a/app-emulation/lxd/files/lxd-2.17.confd b/app-emulation/lxd/files/lxd-2.17.confd
new file mode 100644
index 000000000000..3d553276a5e3
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.17.confd
@@ -0,0 +1,27 @@
+# Group which owns the shared socket
+LXD_OPTIONS+=" --group lxd"
+
+
+
+# Enable cpu profiling into the specified file
+#LXD_OPTIONS+=" --cpuprofile /tmp/lxc_cpu_profile"
+
+# Enable memory profiling into the specified file
+#LXD_OPTIONS+=" --memprofile /tmp/lxc_mem_profile"
+
+
+
+# Enables debug mode
+#LXD_OPTIONS+=" --debug"
+
+# For debugging, print a complete stack trace every n seconds
+#LXD_OPTIONS+=" --print-goroutines-every 5"
+
+# Enables verbose mode
+#LXD_OPTIONS+=" -v"
+
+# Logfile to log to
+#LXD_OPTIONS+=" --logfile /var/log/lxd/lxd.log"
+
+# Enables syslog logging
+#LXD_OPTIONS+=" --syslog"
diff --git a/app-emulation/lxd/files/lxd-2.17.initd b/app-emulation/lxd/files/lxd-2.17.initd
new file mode 100644
index 000000000000..b1fa7caac546
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.17.initd
@@ -0,0 +1,46 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DAEMON=/usr/sbin/lxd
+PIDFILE=/run/lxd.pid
+
+extra_commands="stopall"
+
+depend() {
+ need net
+ use lxcfs
+}
+
+start() {
+ ebegin "Starting lxd service"
+
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ ${LXD_OPTIONS}
+
+ eend $?
+}
+
+stop() {
+ if [ "$RC_GOINGDOWN" = "YES" ] || [ "$RC_REBOOT" = "YES" ]; then
+ stopall
+ else
+ ebegin "Stopping lxd service (but not containers)"
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend $?
+ fi
+}
+
+stopall() {
+ ebegin "Stopping lxd service and containers"
+ if "${DAEMON}" shutdown; then
+ /etc/init.d/lxd zap
+ rm -f ${PIDFILE}
+ fi
+ eend $?
+}
diff --git a/app-emulation/lxd/files/lxd-2.17.service b/app-emulation/lxd/files/lxd-2.17.service
new file mode 100644
index 000000000000..d00635fbcdd9
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.17.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Container hypervisor based on LXC
+
+[Service]
+ExecStart=/usr/sbin/lxd --group lxd
+KillMode=process
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-emulation/lxd/files/lxd-2.18-dont-go-get.patch b/app-emulation/lxd/files/lxd-2.18-dont-go-get.patch
new file mode 100644
index 000000000000..a6e25e325b95
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.18-dont-go-get.patch
@@ -0,0 +1,16 @@
+--- /src/github.com/lxc/lxd/Makefile.orig 2016-07-11 23:34:40.299664675 +0000
++++ /src/github.com/lxc/lxd/Makefile 2016-07-11 23:37:00.816018727 +0000
+@@ -13,13 +13,11 @@
+
+ .PHONY: default
+ default:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./...
+ @echo "LXD built successfully"
+
+ .PHONY: client
+ client:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./lxc
+ @echo "LXD client built successfully"
+
diff --git a/app-emulation/lxd/files/lxd-2.18.confd b/app-emulation/lxd/files/lxd-2.18.confd
new file mode 100644
index 000000000000..3d553276a5e3
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.18.confd
@@ -0,0 +1,27 @@
+# Group which owns the shared socket
+LXD_OPTIONS+=" --group lxd"
+
+
+
+# Enable cpu profiling into the specified file
+#LXD_OPTIONS+=" --cpuprofile /tmp/lxc_cpu_profile"
+
+# Enable memory profiling into the specified file
+#LXD_OPTIONS+=" --memprofile /tmp/lxc_mem_profile"
+
+
+
+# Enables debug mode
+#LXD_OPTIONS+=" --debug"
+
+# For debugging, print a complete stack trace every n seconds
+#LXD_OPTIONS+=" --print-goroutines-every 5"
+
+# Enables verbose mode
+#LXD_OPTIONS+=" -v"
+
+# Logfile to log to
+#LXD_OPTIONS+=" --logfile /var/log/lxd/lxd.log"
+
+# Enables syslog logging
+#LXD_OPTIONS+=" --syslog"
diff --git a/app-emulation/lxd/files/lxd-2.18.initd b/app-emulation/lxd/files/lxd-2.18.initd
new file mode 100644
index 000000000000..b1fa7caac546
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.18.initd
@@ -0,0 +1,46 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DAEMON=/usr/sbin/lxd
+PIDFILE=/run/lxd.pid
+
+extra_commands="stopall"
+
+depend() {
+ need net
+ use lxcfs
+}
+
+start() {
+ ebegin "Starting lxd service"
+
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ ${LXD_OPTIONS}
+
+ eend $?
+}
+
+stop() {
+ if [ "$RC_GOINGDOWN" = "YES" ] || [ "$RC_REBOOT" = "YES" ]; then
+ stopall
+ else
+ ebegin "Stopping lxd service (but not containers)"
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend $?
+ fi
+}
+
+stopall() {
+ ebegin "Stopping lxd service and containers"
+ if "${DAEMON}" shutdown; then
+ /etc/init.d/lxd zap
+ rm -f ${PIDFILE}
+ fi
+ eend $?
+}
diff --git a/app-emulation/lxd/files/lxd-2.18.service b/app-emulation/lxd/files/lxd-2.18.service
new file mode 100644
index 000000000000..d00635fbcdd9
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.18.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Container hypervisor based on LXC
+
+[Service]
+ExecStart=/usr/sbin/lxd --group lxd
+KillMode=process
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target