summaryrefslogtreecommitdiff
path: root/app-emulation/pcem
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-emulation/pcem
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-emulation/pcem')
-rw-r--r--app-emulation/pcem/Manifest4
-rw-r--r--app-emulation/pcem/files/pcem-15-respect-cflags.patch13
-rw-r--r--app-emulation/pcem/metadata.xml23
-rw-r--r--app-emulation/pcem/pcem-15.ebuild71
4 files changed, 111 insertions, 0 deletions
diff --git a/app-emulation/pcem/Manifest b/app-emulation/pcem/Manifest
new file mode 100644
index 000000000000..64e997f814c4
--- /dev/null
+++ b/app-emulation/pcem/Manifest
@@ -0,0 +1,4 @@
+AUX pcem-15-respect-cflags.patch 300 BLAKE2B 4531829e43d43501fe889b34381fc056ffa2734ca499686558cf39ef245f3808e6488c32d6938487d018175ab8a370a28e491cc957406ea6e430a9afff44dae2 SHA512 7800d9056fc1ab4b38f97a6021da7288b990ab9c562846be1ae4ec6636c888fd444c635076f070c50f39681202995a41575823a225c77017d389638feaf1a93c
+DIST PCemV15Linux.tar.gz 1741312 BLAKE2B fa8de8c98a57ac79be11921190960eaa1e5d53896db0749a7f53704362b6415544632a6f918a8f1ce57d2f75f28af52715856346421cc0a8355236a01bb7dcac SHA512 c2501827689acc0f3381d785dc3b008866e82d242bea3fa5af7e786fc58fdf72f76eafda98d12ce88c59ff338bc7dc441484af9c1bc9357c7cc75d94bbe0a7b6
+EBUILD pcem-15.ebuild 1474 BLAKE2B 313b607cffbb48c996e985679de5704a97e84a552f8a25cb3877e9c7c66993dd9ae4b68382be6e50aa8d96a5307469edae71692d9c7e8ae2261a2f7e7f1e3e9b SHA512 c350f1cf59b9fefa787853840b5655434fdf52b28137ddb40f4e5b061f1013329c2112b25585a079388beb8962b572a4f0a0df2b2f63e8c7be22173a6d7094af
+MISC metadata.xml 856 BLAKE2B 628963f0f0d30b7d95b5f7b9f23907fa37129397a5470bde252df40d4c40e57f6657db0d02c935414707537bbe995386c158d5ada56c32e4dd6f53b13a1e2fbb SHA512 e1bb08b4e216ab48ad0d52a59b38dba0db566104ffbb73c2e6cb5d12eee66f78bfaf32caa564aecbcce9ecab21d98d5514ff828dde734671b2c34523137a356e
diff --git a/app-emulation/pcem/files/pcem-15-respect-cflags.patch b/app-emulation/pcem/files/pcem-15-respect-cflags.patch
new file mode 100644
index 000000000000..734812a69daa
--- /dev/null
+++ b/app-emulation/pcem/files/pcem-15-respect-cflags.patch
@@ -0,0 +1,13 @@
+--- a/configure.ac 2019-05-19 18:40:05.000000000 +0200
++++ b/configure.ac 2019-09-21 17:34:53.499993726 +0200
+@@ -31,8 +31,8 @@
+ CXXFLAGS="-Wall -O0 -g -D_DEBUG"
+ AC_MSG_RESULT([yes])
+ else
+- CFLAGS="-O3"
+- CXXFLAGS="-O3"
++ CFLAGS?="-O3"
++ CXXFLAGS?="-O3"
+ AC_MSG_RESULT([no])
+ fi
+
diff --git a/app-emulation/pcem/metadata.xml b/app-emulation/pcem/metadata.xml
new file mode 100644
index 000000000000..d949dbdb3e6e
--- /dev/null
+++ b/app-emulation/pcem/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ PCem (an acronym for Personal Computer emulator) is an open-source,
+ low-level PC emulator developed for Windows and Linux by Sarah Walker.
+
+ It focuses on PC hardware from the 1980's and 1990's.
+ A variety of operating systems can be installed in the emulator,
+ which can then be used to launch programs.
+ </longdescription>
+ <use>
+ <flag name="networking">Enable support for emulation of network cards.</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://pcem-emulator.co.uk/phpBB3/viewforum.php?f=2</bugs-to>
+ <remote-id type="bitbucket">pcem_emulator/pcem</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/pcem/pcem-15.ebuild b/app-emulation/pcem/pcem-15.ebuild
new file mode 100644
index 000000000000..cf76b44d1f9c
--- /dev/null
+++ b/app-emulation/pcem/pcem-15.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop wxwidgets
+
+WX_GTK_VER="3.0"
+
+DESCRIPTION="A PC emulator that specializes in running old operating systems and software"
+HOMEPAGE="
+ https://pcem-emulator.co.uk/
+ https://bitbucket.org/pcem_emulator/pcem/
+"
+SRC_URI="https://pcem-emulator.co.uk/files/PCemV${PV}Linux.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="alsa networking"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ media-libs/libsdl2
+ media-libs/openal
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+
+DEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-respect-cflags.patch" )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-release-build
+ $(use_enable alsa)
+ $(use_enable networking)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/pcem
+ doins -r configs nvr roms
+
+ newicon src/icons/32x32/motherboard.png pcem.png
+ make_desktop_entry "pcem" "PCem" pcem "Development;Utility"
+
+ dodoc readme.txt
+}
+
+pkg_postinst() {
+ elog "In order to use PCem, you will need some roms for various emulated systems."
+ elog "You can either install globally for all users or locally for yourself."
+ elog ""
+ elog "To install globally, put your ROM file into '${ROOT}/usr/share/pcem/roms/<system>'."
+ elog "To install locally, put your ROM file into '~/.pcem/roms/<system>'."
+}