summaryrefslogtreecommitdiff
path: root/app-emulation/plus42/plus42-1.0.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 00:49:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 00:49:44 +0000
commit4828c25c25aacf399de429d381288982fd7e0d0e (patch)
treea265b5f79cf1b578c4e54483be1466f657f4baba /app-emulation/plus42/plus42-1.0.13.ebuild
parentf8d671851faf1ca201cec0490ead4642c8987bae (diff)
gentoo auto-resync : 14:11:2022 - 00:49:44
Diffstat (limited to 'app-emulation/plus42/plus42-1.0.13.ebuild')
-rw-r--r--app-emulation/plus42/plus42-1.0.13.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-emulation/plus42/plus42-1.0.13.ebuild b/app-emulation/plus42/plus42-1.0.13.ebuild
new file mode 100644
index 000000000000..3812fdade255
--- /dev/null
+++ b/app-emulation/plus42/plus42-1.0.13.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PV="${PN}-upstream-${PV}"
+
+DESCRIPTION="An Enhanced HP-42S Calculator Simulator"
+HOMEPAGE="https://thomasokken.com/plus42/"
+SRC_URI="https://thomasokken.com/plus42/upstream/${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa"
+
+DEPEND="app-accessibility/at-spi2-core
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( CREDITS HISTORY README )
+S="${WORKDIR}/${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.9-fix-makefile.patch"
+ "${FILESDIR}/${PN}-1.0.12-fix-build-intel-lib.patch"
+)
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
+ emake -C gtk clean
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
+}
+
+src_install() {
+ default
+ dobin gtk/plus42bin gtk/plus42dec
+}