summaryrefslogtreecommitdiff
path: root/app-emulation/protontricks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 03:28:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 03:28:58 +0000
commitc73b611d606bc14760bad8592f5bfec28c9b1079 (patch)
tree6da7421d10ecff1c38c3774f9a9eed715711fd7c /app-emulation/protontricks
parentb9d995791a762215ef1ced2cc1a47b8d3c2cff1a (diff)
gentoo auto-resync : 14:12:2022 - 03:28:57
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest2
-rw-r--r--app-emulation/protontricks/protontricks-1.10.1.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 80a27bdfaa2c..51588456e0b1 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,3 +1,5 @@
+DIST protontricks-1.10.1.tar.gz 160943 BLAKE2B 12361ce009a62bdba8c420069f87879bf22e047df8bd6d843fb8672222fe6ab04d61f03a44c43a147729461a2f872e2239ee97d737aba28ffdbb273e797be218 SHA512 0b6e3277ea8a106d2bc52cc805b0c3a023733f0a6554fabfe9f32ff27d1bdf04058a419a719c7ca81dc45759a803a83b03408806e4b9328664e572655a3c4df0
DIST protontricks-1.9.2.tar.gz 158505 BLAKE2B ea4bc39d835d28c3f1ba50fa64d9a646ec9ef535b7369517b77bccaceb62cb922bed8844a8a4ea1d4561e248e302628379326a4760b25ac24411e679d018cee0 SHA512 75158c5a8a86edaafcb5be1b01053db91e45754488db0febe026ef0cbfbbb67fa6f3f17d60fec997c6dd19a73245ee408bd2220e09a3983ccd253e6e4c10457d
+EBUILD protontricks-1.10.1.ebuild 1401 BLAKE2B db3405b031b5154c161584a07d35a1c584029e608d1c1b4a96d4972ff5071af4f3169a66199237aa752ddbd479f6ff92ea48b2f07dfa73a83a3e64b3e87e046a SHA512 a14ebea4005bf8953c5e8f7daa1c9f78868783777672f8321dec821cb2718c3c07776099c4a8862713508d5930ea5e7f803d22f3f85c9229d7a10258f3af900e
EBUILD protontricks-1.9.2.ebuild 1561 BLAKE2B 8e363eb3c10b00c76e33654b1435d0e94d27941d53f17666dfa8450e9bf9a40f913fa9c66bd7d1f9d8f35e625c46ab0c50b20953734c370dfd770004c7a2c4d8 SHA512 dc3a8f17876d26da53bb9a8018aa6b754e503782bdde6b464e3353ba67ea51c9405f1b93c3d3f63f9aaa91cb7bf6542318ed3eba7bd111cd54ea58108d88882e
MISC metadata.xml 809 BLAKE2B dc0506e6f3224adc867438699359c4eafc389041846c644818732036e04bcb9c789e358a08effdb4b9ff4430521f7fe8ff6800b75aa93d6313e3d85395467741 SHA512 351bb79dc7921e6c62100b3354546185d31578b044393ea5e5b5fea089eb47164882ff4ede30d8a575dea31ec9d0927793f8109d9e63ca4ad6954c1affdbe6f4
diff --git a/app-emulation/protontricks/protontricks-1.10.1.ebuild b/app-emulation/protontricks/protontricks-1.10.1.ebuild
new file mode 100644
index 000000000000..f71d6217d58d
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.10.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}