summaryrefslogtreecommitdiff
path: root/app-emulation/protontricks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /app-emulation/protontricks
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest2
-rw-r--r--app-emulation/protontricks/protontricks-1.4.1.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 263e40a928b0..1118f3405fe2 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,3 +1,5 @@
DIST protontricks-1.3.1.tar.gz 57784 BLAKE2B ed013367a2cc2384e4340379e2c23999a556ed26920ad59dfd7a8f773e490ee76e253a5fe3216e651cdcdb3e225a2e394255500c611d24f6bf9029582d55bb1f SHA512 4e33334e219db2e6679b430ee42408529478834c80c7da3b9bece4756eb27b9331d49a6a884de8a7ced5ec29d78ce831fee4cfbf6d5adcd750666b7e7a1e5607
+DIST protontricks-1.4.1.tar.gz 31838 BLAKE2B b8c94a1b96fa7df14eaf1cc6d11cb96e43ae4e8c7bd232687a50cae9c79cf2d0e7864b1af0e1dc4cc20086952e1fcefeb16cb71a9c3a977f6feafad1b17d6857 SHA512 7635c9830afa3c64617514cd86edc7d7f9f33e6e81a1da995ec8bee70adc1cf8b5d9de92036c372134e408d735615b267b46a9afc9246f14ff161cb2ee1fc8f9
EBUILD protontricks-1.3.1-r1.ebuild 1201 BLAKE2B 46996c07e30d7ecac4887ef23478f665e1e450497448cc4ee082ff88516260fcb4ec5a43bac5c8bfa3a2eb8600d90589837a44387f739bc29fd52bbc3e6ee758 SHA512 f7f6903a34e1ffdb6633fa156b1efadd7f18e7c50fdaf484a80f36d1b512804c797c11371e83213d0bd191764317ecc3fb463c39bc6d628b8a7a1e215c2562af
+EBUILD protontricks-1.4.1.ebuild 1382 BLAKE2B 24e2b8329ce804f6ad8ae72aa3eddec70c0a2f935efb9925d607a7d6fd5186a3fe52dcb493338f75cdebea3edca2cb24611df8a61b51a770bc2d2917d8c35423 SHA512 5fea56aa3d51cdc84f8d6a99f34f960bc0bc2d73b51076a12e9b11a01693ac13058c066191080585a8ce2206bffb93a46d4a61521b9e7f50250eb8ea38f255ba
MISC metadata.xml 784 BLAKE2B 37e795944e32ef3f17022efa4ad352e3ee2d1819f3e7ee4ccf02f2366156c999290b4b309c924f54dfde4a5ffc017628c36ead987da2101d2eb38c1eaa767e3e SHA512 6bccb95acbe4cf3b64b4734f98dc4495bd20df294efa0b628f08f4c2ee6bb6c5d103bd323ac29dddb02d2a7ff4ac88ccccdce8a8c01b856aef051eaae6cdb0ae
diff --git a/app-emulation/protontricks/protontricks-1.4.1.ebuild b/app-emulation/protontricks/protontricks-1.4.1.ebuild
new file mode 100644
index 000000000000..82293afad32a
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+BDEPEND="${PYTHON_DEPS}
+ dev-python/setuptools_scm"
+RDEPEND="${PYTHON_DEPS}
+ app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/vdf[${PYTHON_MULTI_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+
+# Tarballs from PyPI do not contain tests, and we cannot use GitHub releases
+# any more because they are incompatible with setuptools_scm.
+RESTRICT="test"
+
+DOCS=(CHANGELOG.md README.md)
+
+pkg_postinst() {
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}