summaryrefslogtreecommitdiff
path: root/app-emulation/qemu/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-12 06:11:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-12 06:11:51 +0000
commited29ea7e5783aeccaddc89856f6fe75fb78179e5 (patch)
treea99cfbbe9bfaab43efba21c6d77c39216d73118f /app-emulation/qemu/files
parent8fa69fdd0836c0b856dd0f9ef77d5fb25df844ec (diff)
gentoo auto-resync : 12:03:2023 - 06:11:51
Diffstat (limited to 'app-emulation/qemu/files')
-rw-r--r--app-emulation/qemu/files/qemu-8.0.0-disable-keymap.patch27
-rw-r--r--app-emulation/qemu/files/qemu-8.0.0-make.patch12
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emulation/qemu/files/qemu-8.0.0-disable-keymap.patch b/app-emulation/qemu/files/qemu-8.0.0-disable-keymap.patch
new file mode 100644
index 000000000000..aab5dde5fbd9
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-8.0.0-disable-keymap.patch
@@ -0,0 +1,27 @@
+diff -ruN qemu-9999.orig/meson.build qemu-9999/meson.build
+--- qemu-9999.orig/meson.build 2023-03-12 01:17:38.273756012 +0100
++++ qemu-9999/meson.build 2023-03-12 01:18:44.854716789 +0100
+@@ -667,6 +667,8 @@
+
+ if get_option('xkbcommon').auto() and not have_system and not have_tools
+ xkbcommon = not_found
++elif get_option('xkbcommon').disabled()
++ xkbcommon = not_found
+ else
+ xkbcommon = dependency('xkbcommon', required: get_option('xkbcommon'),
+ method: 'pkg-config', kwargs: static_kwargs)
+diff -ruN qemu-9999.orig/pc-bios/keymaps/meson.build qemu-9999/pc-bios/keymaps/meson.build
+--- qemu-9999.orig/pc-bios/keymaps/meson.build 2023-03-12 01:17:38.321756706 +0100
++++ qemu-9999/pc-bios/keymaps/meson.build 2023-03-12 01:20:22.015111600 +0100
+@@ -33,8 +33,10 @@
+ 'tr': '-l tr',
+ }
+
+-if meson.is_cross_build() or not xkbcommon.found()
++if meson.is_cross_build()
+ native_qemu_keymap = find_program('qemu-keymap', required: false, disabler: true)
++elif get_option('xkbcommon').disabled()
++ native_qemu_keymap = not_found
+ else
+ native_qemu_keymap = qemu_keymap
+ endif
diff --git a/app-emulation/qemu/files/qemu-8.0.0-make.patch b/app-emulation/qemu/files/qemu-8.0.0-make.patch
new file mode 100644
index 000000000000..4bf3f7157713
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-8.0.0-make.patch
@@ -0,0 +1,12 @@
+diff -ruN qemu-9999.orig/configure qemu-9999/configure
+--- qemu-9999.orig/configure 2023-03-12 01:26:15.488133462 +0100
++++ qemu-9999/configure 2023-03-12 01:29:19.355724020 +0100
+@@ -1068,7 +1068,7 @@
+ fi
+ fi
+
+-if ! has "$make"
++if ! has $make
+ then
+ error_exit "GNU make ($make) not found"
+ fi