summaryrefslogtreecommitdiff
path: root/app-emulation/qemu/qemu-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-28 05:33:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-28 05:33:44 +0100
commite2e0b35b67db51e544167a2ba1941004d04a54fd (patch)
tree625af275739774e77d6ea6a93fae3b752da35be2 /app-emulation/qemu/qemu-9999.ebuild
parent881ed853a610750628d101d50410e9f3bf370d87 (diff)
gentoo auto-resync : 28:09:2023 - 05:33:43
Diffstat (limited to 'app-emulation/qemu/qemu-9999.ebuild')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild29
1 files changed, 24 insertions, 5 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 6bc1056cfd1c..3da439a4b7b4 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -28,6 +28,16 @@ if [[ ${PV} == *9999* ]]; then
EGIT_SUBMODULES=()
inherit git-r3
SRC_URI=""
+ declare -A SUBPROJECTS=(
+ [keycodemapdb]="f5772a62ec52591ff6870b7e8ef32482371f22c6"
+ [berkeley-softfloat-3]="b64af41c3276f97f0e181920400ee056b9c88037"
+ [berkeley-testfloat-3]="40619cbb3bf32872df8c53cc457039229428a263"
+ )
+
+ for proj in "${!SUBPROJECTS[@]}"; do
+ c=${SUBPROJECTS[${proj}]}
+ SRC_URI+=" https://gitlab.com/qemu-project/${proj}/-/archive/${c}/${proj}-${c}.tar.bz2"
+ done
else
MY_P="${PN}-${PV/_rc/-rc}"
SRC_URI="https://download.qemu.org/${MY_P}.tar.xz"
@@ -436,13 +446,22 @@ check_targets() {
popd >/dev/null
}
-if [[ ${PV} == 9999 ]]; then
src_unpack() {
- git-r3_src_unpack
- cd "${P}" || die
- meson subprojects download keycodemapdb berkeley-softfloat-3 berkeley-testfloat-3 || die
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ for file in ${A}; do
+ unpack "${file}"
+ done
+ cd "${WORKDIR}" || die
+ for proj in "${!SUBPROJECTS[@]}"; do
+ mv "${proj}-${SUBPROJECTS[${proj}]}" "${S}/subprojects/${proj}" || die
+ done
+ cd "${S}" || die
+ meson subprojects packagefiles --apply || die
+ else
+ default
+ fi
}
-fi
src_prepare() {
check_targets IUSE_SOFTMMU_TARGETS softmmu