summaryrefslogtreecommitdiff
path: root/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'app-emulation/runc/runc-1.0.0_rc10-r1.ebuild')
-rw-r--r--app-emulation/runc/runc-1.0.0_rc10-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild b/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
new file mode 100644
index 000000000000..71ec6fbe3a47
--- /dev/null
+++ b/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-vcs-snapshot linux-info
+
+# update on bump, look for https://github.com/docker\
+# docker-ce/blob/<docker ver OR branch>/components/engine/hack/dockerfile/install/runc.installer
+RUNC_COMMIT="dc9208a3303feef5b3839f4323d9beb36df0a9dd"
+CONFIG_CHECK="~USER_NS"
+EGO_PN="github.com/opencontainers/${PN}"
+
+DESCRIPTION="runc container cli tools"
+HOMEPAGE="http://runc.io"
+SRC_URI="https://github.com/opencontainers/${PN}/archive/v${RUNC_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="apparmor +ambient hardened +kmem +seccomp selinux test"
+
+DEPEND="seccomp? ( sys-libs/libseccomp )"
+
+RDEPEND="
+ ${DEPEND}
+ !app-emulation/docker-runc
+ apparmor? ( sys-libs/libapparmor )
+"
+
+BDEPEND="
+ dev-go/go-md2man
+ test? ( "${RDEPEND}" )
+"
+
+# tests need busybox binary, and portage namespace
+# sandboxing disabled: mount-sandbox pid-sandbox ipc-sandbox
+# majority of tests pass
+RESTRICT+=" test"
+
+src_compile() {
+ # Taken from app-emulation/docker-1.7.0-r1
+ export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+ -L${ROOT}/usr/$(get_libdir)"
+
+ # build up optional flags
+ local options=(
+ $(usev ambient)
+ $(usev apparmor)
+ $(usev seccomp)
+ $(usev selinux)
+ $(usex kmem '' 'nokmem')
+ )
+
+ myemakeargs=(
+ BINDIR="${ED}/usr/bin"
+ BUILDTAGS="${options[*]}"
+ COMMIT=${RUNC_COMMIT}
+ DESTDIR="${ED}"
+ PREFIX="${ED}/usr"
+ GOPATH="${S}"
+ -C "src/${EGO_PN}"
+ )
+
+ emake "${myemakeargs[@]}" runc man
+}
+
+src_install() {
+ emake "${myemakeargs[@]}" install install-man install-bash
+
+ local DOCS=( src/"${EGO_PN}"/{README.md,PRINCIPLES.md,docs/.} )
+ einstalldocs
+}
+
+src_test() {
+ emake "${myemakeargs[@]}" localunittest
+}