summaryrefslogtreecommitdiff
path: root/app-emulation/slirp4netns/slirp4netns-0.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-emulation/slirp4netns/slirp4netns-0.4.2.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-emulation/slirp4netns/slirp4netns-0.4.2.ebuild')
-rw-r--r--app-emulation/slirp4netns/slirp4netns-0.4.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emulation/slirp4netns/slirp4netns-0.4.2.ebuild b/app-emulation/slirp4netns/slirp4netns-0.4.2.ebuild
new file mode 100644
index 000000000000..e12c5cc91bc5
--- /dev/null
+++ b/app-emulation/slirp4netns/slirp4netns-0.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="User-mode networking for unprivileged network namespaces"
+HOMEPAGE="https://github.com/rootless-containers/slirp4netns"
+SRC_URI="https://github.com/rootless-containers/slirp4netns/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/glib:2=
+ dev-libs/libpcre:=
+ sys-libs/libseccomp:=
+ sys-libs/libcap:="
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RESTRICT="test"
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You need to have the tun kernel module loaded in order to have"
+ elog "slirp4netns working"
+ fi
+}