summaryrefslogtreecommitdiff
path: root/app-emulation/uxn/uxn-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-23 01:23:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-23 01:23:10 +0100
commit7828eef5de9e45f50282e2b1eaf348f1ac7af477 (patch)
treeea872a4f1afc4b28699120de310c5d87b75ea5d0 /app-emulation/uxn/uxn-9999.ebuild
parentcd18653acd5ce929bb0ec77dde842439db6f060c (diff)
gentoo auto-resync : 23:06:2023 - 01:23:10
Diffstat (limited to 'app-emulation/uxn/uxn-9999.ebuild')
-rw-r--r--app-emulation/uxn/uxn-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/app-emulation/uxn/uxn-9999.ebuild b/app-emulation/uxn/uxn-9999.ebuild
index 1b6c4a1a5ff4..55a5c6f70c66 100644
--- a/app-emulation/uxn/uxn-9999.ebuild
+++ b/app-emulation/uxn/uxn-9999.ebuild
@@ -6,19 +6,20 @@ EAPI=8
inherit toolchain-funcs
DESCRIPTION="An assembler and emulator for the Uxn stack-machine, written in ANSI C"
-HOMEPAGE="
- https://wiki.xxiivv.com/site/uxn.html
- https://git.sr.ht/~rabbits/uxn/
-"
+HOMEPAGE="https://wiki.xxiivv.com/site/uxn.html
+ https://git.sr.ht/~rabbits/uxn/"
if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://git.sr.ht/~rabbits/uxn.git"
-else
+elif [[ ${PV} == *_p20230609 ]] ; then
+ COMMIT=f3674b2562e6c5557fc008edbac71d9fcfde64ff
SRC_URI="https://git.sr.ht/~rabbits/uxn/archive/${COMMIT}.tar.gz
-> ${P}.tar.gz"
- S="${WORKDIR}"/${PN}-${COMMIT}
+ S="${WORKDIR}"/uxn-${COMMIT}
KEYWORDS="~amd64 ~x86"
+else
+ die "wrong package version (PV), given: ${PV}"
fi
LICENSE="MIT"
@@ -27,16 +28,19 @@ SLOT="0"
RDEPEND="media-libs/libsdl2:="
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/uxn-build.sh.patch )
+PATCHES=( "${FILESDIR}"/uxn-0_p20230609-build.sh.patch )
src_compile() {
CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" ./build.sh --no-run ||
die "build failed"
local f
+ local f_base
for f in ./projects/{examples/*,software,utils}/*.tal ; do
- ./bin/uxnasm "${f}" "$(dirname "${f}")"/"$(basename "${f}" .tal)".rom ||
- die "failed to assemble ${f}"
+ f_base="$(basename "${f}" .tal)"
+ ebegin "Assembling ROM ${f_base}"
+ ./bin/uxnasm "${f}" "$(dirname "${f}")"/"${f_base}".rom
+ eend ${?} || die "failed to assemble ${f}"
done
}