summaryrefslogtreecommitdiff
path: root/app-emulation/uxn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-14 03:02:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-14 03:02:32 +0000
commitd3c7d3e5f9607edef1a795ccc502ab3eb3121165 (patch)
treed36ccc4ef4aa53927a8cd66bc5d3ab06fe1bdd24 /app-emulation/uxn
parent4dc2f97ed84159736ecfb5dea5485e83b27810d1 (diff)
gentoo auto-resync : 14:11:2024 - 03:02:32
Diffstat (limited to 'app-emulation/uxn')
-rw-r--r--app-emulation/uxn/Manifest2
-rw-r--r--app-emulation/uxn/uxn-0_p20241112.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/app-emulation/uxn/Manifest b/app-emulation/uxn/Manifest
index 9f6fef88b425..62f9185e7bd9 100644
--- a/app-emulation/uxn/Manifest
+++ b/app-emulation/uxn/Manifest
@@ -1,5 +1,7 @@
AUX uxn-0_p20230609-build.sh.patch 626 BLAKE2B 08b58d26f892354e5a6b6e19bfd11584ed62ae4b4640fee99f5baf636eb42a3c9e28d073d95e30e6fcba2ef17b3ad59ae9d06568e0883c244233b42f60b284f9 SHA512 b95e1026abbb28dc152cc5ecb176921d7ff3db9356c2dce95220ab0d360b9535bfc5996839ad19b77a9346304c51e430b9f69747b7dd39a6621f86330e382cb3
DIST uxn-0_p20240304.tar.gz 307083 BLAKE2B 2b3a556c5094fd777d82d75c87f721d1a9ea136334cdbc8553662281ae498beb79514e9e567e79b84a625b2fe60b486aa7f6892594cbd08abbbfeb4c9a50b2e9 SHA512 048e24e33de04913e03fbf1b242837dd1ad190f52ede16c302cf436399f0ee478afca545236dd438e03d8dfc29252478c2d79c9b6d3e8d34bb83c99f1930d026
+DIST uxn-0_p20241112.tar.gz 303651 BLAKE2B d632d59bb6b271b8dd9e03ff9efc6e4cf822793b06c3f95278d9e9b0be2242c615611ba87560b5ce9c6cde549752b6f4f578ad4872682665b3c019fcf07efeb5 SHA512 66b3c8ccdd6a79f507f6672161660b3d2f491ac1a186bff963f156e322cdf11494269e73d4bb08b22bb1fe7c7bacb59cb5ba850fef6cb4fe183777fdd8cba2ac
EBUILD uxn-0_p20240304.ebuild 1669 BLAKE2B 410fb64ce1243a3e9bdb69b74d39619a192eb659fe3dcef41871f6aa7de9d26b85942e210b14f6126aeec319b416acc2b0d8af86323eb8cd6afd2f584c141012 SHA512 141da08a86754a498e6f9827a90ba82c6114ec5d04d74ff4019ab4c23cd4b51992dfa83f705a0982348846163f9abccb68b157426fd7223ff6273c5bf419ef1e
+EBUILD uxn-0_p20241112.ebuild 1675 BLAKE2B eb8e612a87de88fd9244b65d52df0c2b2c2959e83f36e35a568d7935c74ee1769588b7a7ec7e2f08bf22219afd5a2e78b0e235d00e11ef228195a75b9989c793 SHA512 1364a65ef0d6ebb28df30357f8b96350b51fa430197c9d3e5eade63ab024a79c165d155dfb81fa3eeeff5ee27f6b26bd9bd51c9f40de50bb75cb253545ca0d4e
EBUILD uxn-9999.ebuild 1646 BLAKE2B 434f20522a3389e650c334d4ddcd1590d698ce1668aaf686278e6a2c50520315b91af7aa534cb29ea6622c2fe2fe4ef4b86a0f78e4c75d9bec48ebfa6a39c8e9 SHA512 528ebaae0b341070543c66fdc7cf836c4b9a16bae08fbaf1b7bd98513f0ffc35354c570969f17564756ab6d25e98e4a99f139c8eeaf8b171257ec5d3e9587975
MISC metadata.xml 643 BLAKE2B 11f4437dbab961e620e204294cb8b18e1ef43c2c79411f8b1224a36276c6a4781e3cb5e854040c979eaa27dc145eb606576ba20076d16a301e33aea6bdcd0df4 SHA512 b5bf43fdcafed44459ac77576f631105175691078b8094d505657fdacc0519856ca063890d432051aa5bff8853ca55f7b10d3b8f680230605de63f69b0acf997
diff --git a/app-emulation/uxn/uxn-0_p20241112.ebuild b/app-emulation/uxn/uxn-0_p20241112.ebuild
new file mode 100644
index 000000000000..a9ad05873add
--- /dev/null
+++ b/app-emulation/uxn/uxn-0_p20241112.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An assembler and emulator for the Uxn stack-machine, written in ANSI C"
+HOMEPAGE="https://wiki.xxiivv.com/site/uxn.html
+ https://git.sr.ht/~rabbits/uxn/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://git.sr.ht/~rabbits/${PN}"
+elif [[ "${PV}" == *_p20241112 ]] ; then
+ COMMIT="1538b1bf7255b975dbd87e813d0cca491810fbba"
+
+ SRC_URI="https://git.sr.ht/~rabbits/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/uxn-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+else
+ die "Wrong package version, please update the ebuild, given: ${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ media-libs/libsdl2:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/uxn-0_p20230609-build.sh.patch"
+)
+
+src_compile() {
+ env CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ ./build.sh --no-run \
+ || die "building with \"build.sh\" failed"
+
+ # Fails to assemble via following loop.
+ # Possibly not mean to be assembled by hand.
+ rm -rf ./projects/library ./projects/software/{asma,launcher}.tal || die
+
+ local tal_file=""
+ local tal_file_base=""
+
+ while read -r tal_file ; do
+ tal_file_base="$(basename "${tal_file}" .tal)"
+
+ ebegin "Assembling ROM ${tal_file_base}"
+ bin/uxnasm "${tal_file}" "$(dirname "${tal_file}")/${tal_file_base}.rom"
+ eend ${?} || die "failed to assemble ${tal_file}"
+ done \
+ < <(find projects -type f -name "*.tal")
+}
+
+src_install() {
+ insinto /usr/bin
+ doins bin/uxn{asm,cli,emu}
+ fperms 0755 /usr/bin/uxn{asm,cli,emu}
+
+ insinto /usr/share/uxn
+ doins -r projects
+
+ einstalldocs
+}