summaryrefslogtreecommitdiff
path: root/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-24 02:00:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-24 02:00:51 +0000
commit4583148f2657a7a66fd68b25c9fab02be110c989 (patch)
treebd7f7afcfa312044a00e9f1207eecdd9802055bc /app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild
parentedb8ee6f86e56d25f82a4f088a4504c903aede08 (diff)
gentoo auto-resync : 24:12:2022 - 02:00:50
Diffstat (limited to 'app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild')
-rw-r--r--app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild b/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild
index ceaaa99a4a5f..68ee284aa9d7 100644
--- a/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild
+++ b/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-mod
+inherit linux-mod toolchain-funcs
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/gnif/vendor-reset.git"
@@ -24,26 +24,17 @@ DEPEND=""
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
-PATCHES=( "${FILESDIR}/Respect-eselect-kernel.patch" )
+MODULE_NAMES="vendor-reset(extra)"
pkg_setup() {
local CONFIG_CHECK="FTRACE KPROBES PCI_QUIRKS KALLSYMS FUNCTION_TRACER"
linux-mod_pkg_setup
- export KV_FULL=${KV_FULL}
- export KERNEL_DIR=${KERNEL_DIR}
-}
-
-src_compile() {
- set_arch_to_kernel
- default
+ BUILD_TARGETS="build"
+ BUILD_PARAMS="CC=\"$(tc-getBUILD_CC)\" KDIR=${KERNEL_DIR}"
}
src_install() {
- set_arch_to_kernel
- emake \
- DESTDIR="${ED}" \
- INSTALL_MOD_PATH="${ED}" \
- install
+ linux-mod_src_install
insinto /etc/modules-load.d/
newins "${FILESDIR}"/modload.conf vendor-reset.conf