summaryrefslogtreecommitdiff
path: root/app-emulation/virt-manager
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-16 14:53:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-16 14:53:46 +0000
commitf5588424e3182e3006f725536eebd7dc7b5bbfd4 (patch)
tree2c2ccb3df6c5e1039da984d110f02d0c2ec12cf1 /app-emulation/virt-manager
parentd969fd257186a9d8083279276697f827331f0e46 (diff)
gentoo auto-resync : 16:12:2023 - 14:53:46
Diffstat (limited to 'app-emulation/virt-manager')
-rw-r--r--app-emulation/virt-manager/Manifest3
-rw-r--r--app-emulation/virt-manager/virt-manager-4.1.0-r1.ebuild106
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild2
3 files changed, 109 insertions, 2 deletions
diff --git a/app-emulation/virt-manager/Manifest b/app-emulation/virt-manager/Manifest
index cae717195e27..69457e4b75e4 100644
--- a/app-emulation/virt-manager/Manifest
+++ b/app-emulation/virt-manager/Manifest
@@ -1,4 +1,5 @@
DIST virt-manager-4.1.0.tar.gz 3151412 BLAKE2B 1b4203be81bd7b82251225d691a4d9068f268e610f049bcadb96de5b539e964ca0b001f22f06ddd8266b58b079f60046f6d11942a1e4eadbc43f0607c46bbddd SHA512 725cb5bcbaebaafae417f95deffb4243ccdad769668cba6e1235f4607e2b29dbd099d2a9a3885981158f53ea854dd71cc29ed9d7557b2791161c13d34f2ef883
+EBUILD virt-manager-4.1.0-r1.ebuild 2738 BLAKE2B 00205084307690bfe35cf9ece9e1aaab476a7341c9b36bbc21dcd3c1538efb004fed67c26d9e0b8f8496288c63e2b779b811d2fcb6f9fde08680226ea9a7bc20 SHA512 a344694a57f4051fb8d4ad8dace3f4ab8c47497e1ff649b1a465412c509e459034a269866dbcc6005a281bbc1dfb2b322ecdb5c910e1074dd32fd88a4ba9eca1
EBUILD virt-manager-4.1.0.ebuild 2709 BLAKE2B 478d46f17fc422d65b2899a83fd4c62a38d767fe352797adbbdee4f70cef893c8da4cfc5e7910423cc06e0946d8b45639f8ba48ef8015f5a7350d3e5bad9e3ec SHA512 6f42c8419a2d9fd4acdb185a936259b3a02bf57ca3d7639fed920d165642bbb552d07bd77fa2e32d8bfed95e2c900446928d0ad8a8b865ea4bcc6ee1ccd1ab95
-EBUILD virt-manager-9999.ebuild 2641 BLAKE2B e730f860e4764b37a80c9084bfd22976c4e9594ac2eb8bd86fd7b2a6ba6a4f708e1338e592e1e1c60b14c741730d5a3d9b656ddb75aa5b88eb72e22c75b5c324 SHA512 fafb31f1f9370b2550a2c1b3019ff6e31c8075ecc88688c0116a5f1cd59ddcae9fa66899aeab226cec904a8644284c0b59c98f85dc4921f5dbc5553c5c924a40
+EBUILD virt-manager-9999.ebuild 2668 BLAKE2B 4264b37368ce0bb0aad00f4888ea92b93bd74b3feeeb93b8057301f72c9d8be253c992f53ea6413f8a53bc0dc914559024cce1cef0deb0ea080aef9b28e64f5c SHA512 daf87dbb28e9494e1cc09c8ecdceaf47ac3b92b930481f412db2f380e880a9886227684ca311d232b6552a973a9a63688f59abd96754f5e032c3864465ef4a06
MISC metadata.xml 717 BLAKE2B 931cc0f16850272e3d61e4c3421768bd01fd98891d1049d540c36dfcc1cd3872c158796edf33479005fdf07fe449d251ef55562a832db8827e757202ed1b046e SHA512 e40d93e6febcbb48ea6178986736721a5c45bc92073a9108179fd437bb303ba1b6bf0adb6053e36f877b660c413404ef877aefe4d3ef2ec124d6b6cc808a411d
diff --git a/app-emulation/virt-manager/virt-manager-4.1.0-r1.ebuild b/app-emulation/virt-manager/virt-manager-4.1.0-r1.ebuild
new file mode 100644
index 000000000000..f2ea44f9a428
--- /dev/null
+++ b/app-emulation/virt-manager/virt-manager-4.1.0-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+inherit gnome2 distutils-r1 optfeature
+
+DESCRIPTION="A graphical tool for administering virtual machines"
+HOMEPAGE="https://virt-manager.org https://github.com/virt-manager/virt-manager"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/virt-manager/virt-manager.git"
+ EGIT_BRANCH="main"
+ SRC_URI=""
+ inherit git-r3
+else
+ SRC_URI="https://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gui policykit sasl"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || ( dev-libs/libisoburn app-cdr/cdrtools )
+ >=app-emulation/libvirt-glib-1.0.0[introspection]
+ >=sys-libs/libosinfo-0.2.10[introspection]
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/libvirt-python-6.10.0[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ gui? (
+ gnome-base/dconf
+ >=net-libs/gtk-vnc-0.3.8[gtk3(+),introspection]
+ net-misc/spice-gtk[usbredir,gtk3,introspection,sasl?]
+ sys-apps/dbus[X]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gtksourceview:4[introspection]
+ x11-libs/vte:2.91[introspection]
+ policykit? ( sys-auth/polkit[introspection] )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/docutils"
+
+DOCS=( README.md NEWS.md )
+
+DISTUTILS_ARGS=(
+ --no-update-icon-cache
+ --no-compile-schemas
+)
+
+EPYTEST_IGNORE=(
+ # Wants to use /tmp osinfo config?
+ tests/test_cli.py
+
+ # These seem to be essentially coverage tests
+ tests/test_checkprops.py
+)
+
+distutils_enable_tests pytest
+
+python_configure() {
+ esetup.py configure --default-graphics=spice
+}
+
+python_test() {
+ export VIRTINST_TEST_SUITE_FORCE_LIBOSINFO=0
+
+ epytest
+}
+
+python_install() {
+ esetup.py install
+}
+
+pkg_preinst() {
+ if use gui ; then
+ gnome2_pkg_preinst
+
+ cd "${ED}" || die
+ export GNOME2_ECLASS_ICONS=$(find 'usr/share/virt-manager/icons' -maxdepth 1 -mindepth 1 -type d 2> /dev/null || die)
+ else
+ rm -r "${ED}/usr/share/virt-manager/ui/" || die
+ rm -r "${ED}/usr/share/virt-manager/icons/" || die
+ rm -r "${ED}/usr/share/icons/" || die
+ rm -r "${ED}/usr/share/applications/virt-manager.desktop" || die
+ rm -r "${ED}/usr/bin/virt-manager" || die
+ fi
+}
+
+pkg_postinst() {
+ use gui && gnome2_pkg_postinst
+
+ optfeature "SSH_ASKPASS program implementation" lxqt-base/lxqt-openssh-askpass net-misc/ssh-askpass-fullscreen net-misc/x11-ssh-askpass
+ optfeature "QEMU host support" app-emulation/qemu[usbredir,spice]
+ optfeature "virt-install --location ISO support" dev-libs/libisoburn
+}
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index d5fd49307e4c..a7e83d3bf708 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -27,7 +27,7 @@ IUSE="gui policykit sasl"
RDEPEND="
${PYTHON_DEPS}
- app-cdr/cdrtools
+ || ( dev-libs/libisoburn app-cdr/cdrtools )
>=app-emulation/libvirt-glib-1.0.0[introspection]
>=sys-libs/libosinfo-0.2.10[introspection]
$(python_gen_cond_dep '