summaryrefslogtreecommitdiff
path: root/app-emulation/virt-v2v
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-04 01:46:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-04 01:46:23 +0000
commitd13006cca857323814c09f5123b87c1a005bba74 (patch)
treeca4a24c0b40356fb7efce3e245882a9e87b5db3c /app-emulation/virt-v2v
parenteab7afdf0fe1454220af1a74c5556855a937a819 (diff)
gentoo auto-resync : 04:03:2025 - 01:46:22HEADmaster
Diffstat (limited to 'app-emulation/virt-v2v')
-rw-r--r--app-emulation/virt-v2v/Manifest5
-rw-r--r--app-emulation/virt-v2v/metadata.xml19
-rw-r--r--app-emulation/virt-v2v/virt-v2v-2.6.0.ebuild64
-rw-r--r--app-emulation/virt-v2v/virt-v2v-2.7.7.ebuild70
4 files changed, 158 insertions, 0 deletions
diff --git a/app-emulation/virt-v2v/Manifest b/app-emulation/virt-v2v/Manifest
new file mode 100644
index 000000000000..8912b5d3e8f2
--- /dev/null
+++ b/app-emulation/virt-v2v/Manifest
@@ -0,0 +1,5 @@
+DIST virt-v2v-2.6.0.tar.gz 7441540 BLAKE2B 60524a23e4f54ff4027863c2684cde66ca679d76dead971fa492ed90fdf16a6a75c7a6ebc047b1a38cf273bf29f1392f61cce33bc2c2137e710816f510d38062 SHA512 bc7ecf99e66bae057eaf5d7c82ca38ded4aa6ef8732544bc7079f2894c9c79542a415fede02cf8c2cb7e83756683457c705f816b1da57e5ca9565350b9376a73
+DIST virt-v2v-2.7.7.tar.gz 7713427 BLAKE2B 58a723ecf0cd1c42c090af2809d7c1010b37f69b67faf61eb674293b837896fa7520e3ef332d23db5d6d1e5a4c6ce1304086cfc16885bf716ba0bf09cd8612f8 SHA512 05f4cedb45c6a3596b4ec4922f018497a4852a1a20b14161068e556003d19ee5cf2737ce408515a9e701df88551008b1a674ecfe37ba547a16dfe6a91b139d7e
+EBUILD virt-v2v-2.6.0.ebuild 1581 BLAKE2B 5e565d88e1f9772e875c38889bd6418a6cd2a659c7711d5245e202eebc8b7413ea394040913c7ba48009702a9e0ffe77e22fb8bcdebd15790c74cb3b9002a4b7 SHA512 124e1e03657c0d398bda47dabb322219da7a68c75b21ba9ee5024ff3e8295d92d273e23e480b0d99dee004adb49bafff27f5800510c8c292d277552975643ec8
+EBUILD virt-v2v-2.7.7.ebuild 1959 BLAKE2B bdca38a4585cd2c2efa88d224d260e926eecb79e9e55de5601c9fdd754e2b8e2d09cf181afd32a5f30fbc950aab7d6cf780d74c426e106295fe5a5a359eb209d SHA512 4f8691597e06256a542bf72fecd4b1078367b07d2efe8898bc742857e271d390dba66cacee2dc73bd50e9ba09a350d29a1fc70be03932b29a0134305326c04c2
+MISC metadata.xml 642 BLAKE2B daa0b39ce19dcbf9d4ae57de244316c775016da1f4426890d9380f3bacb87e8147100c230bb77efecb3e4d3af008c9e66b9ff9166e18e491cdd923499a785381 SHA512 63101dfdbb5deafd54bb7f4280ce781b75f51217fb811e46cbc3aeaa174592cd21ac16221183a9be34df2d2d0159ed740cbb2e977c55fea2f2ff01e88083eb2b
diff --git a/app-emulation/virt-v2v/metadata.xml b/app-emulation/virt-v2v/metadata.xml
new file mode 100644
index 000000000000..acaa218a6658
--- /dev/null
+++ b/app-emulation/virt-v2v/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>salah.coronya@gmail.com</email>
+ <name>Christopher Byrne</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>virtualization@gentoo.org</email>
+ <name>Gentoo Virtualization Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">libguestfs/virt-v2v</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/virt-v2v/virt-v2v-2.6.0.ebuild b/app-emulation/virt-v2v/virt-v2v-2.6.0.ebuild
new file mode 100644
index 000000000000..5f3118b0df92
--- /dev/null
+++ b/app-emulation/virt-v2v/virt-v2v-2.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+MY_PV_1="$(ver_cut 1-2)"
+MY_PV_2="$(ver_cut 2)"
+[[ $(( ${MY_PV_2} % 2 )) -eq 0 ]] && SD="stable" || SD="development"
+
+DESCRIPTION="Tool to convert guests from foreign hypervisors to run on KVM"
+HOMEPAGE="https://libguestfs.org/"
+SRC_URI="https://download.libguestfs.org/${PN}/${MY_PV_1}-${SD}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+if [ "${SD}" == "stable" ]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="app-emulation/libguestfs[ocaml]
+ dev-libs/jansson
+ dev-libs/libpcre2
+ dev-ml/libvirt-ocaml
+ >sys-libs/libnbd-1.14.1-r1[ocaml]
+ sys-libs/libosinfo
+ >=sys-block/nbdkit-1.42.0[curl,libssh,nbd,python]
+ virtual/libcrypt:="
+RDEPEND="${DEPEND}
+ app-arch/unzip
+ app-emulation/qemu"
+BDEPEND="dev-ml/findlib[ocamlopt]
+ sys-devel/gettext
+ dev-ml/ocaml-gettext[ocamlopt]
+ dev-ml/ocaml-gettext-stub[ocamlopt]
+ virtual/pkgconfig
+ test? ( dev-ml/ounit2[ocamlopt] )"
+
+src_test() {
+ # libguestfs tests won't work until the new environment is sourced
+ # Automatic testers (tinderboxes) probably won't do this, so do it ourselves if needed
+ if [[ -z "${LIBGUESTFS_PATH}" ]]; then
+ local -x $(<${BROOT}/etc/env.d/99libguestfs-appliance) || die
+ fi
+
+ # Can't reach libvirt from the sandbox
+ local -x SKIP_TEST_V2V_O_LIBVIRT_SH=1
+
+ # Must be called explicilty even without above variable because
+ # emake check -n fails due to missing Windows headers.
+ emake check
+}
+
+src_install() {
+ default
+
+ dobashcomp bash/virt-v2v
+}
diff --git a/app-emulation/virt-v2v/virt-v2v-2.7.7.ebuild b/app-emulation/virt-v2v/virt-v2v-2.7.7.ebuild
new file mode 100644
index 000000000000..51a01ec514a0
--- /dev/null
+++ b/app-emulation/virt-v2v/virt-v2v-2.7.7.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+MY_PV_1="$(ver_cut 1-2)"
+MY_PV_2="$(ver_cut 2)"
+[[ $(( ${MY_PV_2} % 2 )) -eq 0 ]] && SD="stable" || SD="development"
+
+DESCRIPTION="Tool to convert guests from foreign hypervisors to run on KVM"
+HOMEPAGE="https://libguestfs.org/"
+SRC_URI="https://download.libguestfs.org/${PN}/${MY_PV_1}-${SD}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+if [ "${SD}" == "stable" ]; then
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=app-emulation/libguestfs-1.55.6[ocaml]
+ dev-libs/json-c
+ dev-libs/libpcre2
+ dev-ml/libvirt-ocaml
+ >sys-libs/libnbd-1.14.1-r1[ocaml]
+ sys-libs/libosinfo
+ >=sys-block/nbdkit-1.42.0[curl,libssh,nbd,python]
+ virtual/libcrypt:="
+RDEPEND="${DEPEND}
+ app-arch/unzip
+ app-emulation/qemu"
+BDEPEND="dev-ml/findlib[ocamlopt]
+ sys-devel/gettext
+ dev-ml/ocaml-gettext[ocamlopt]
+ dev-ml/ocaml-gettext-stub[ocamlopt]
+ virtual/pkgconfig
+ test? ( dev-ml/ounit2[ocamlopt] )"
+
+src_test() {
+ # libguestfs tests won't work until the new environment is sourced
+ # Automatic testers (tinderboxes) probably won't do this, so do it ourselves if needed
+ if [[ -z "${LIBGUESTFS_PATH}" ]]; then
+ local -x $(<${BROOT}/etc/env.d/99libguestfs-appliance) || die
+ fi
+
+ # Can't reach libvirt from the sandbox
+ local -x SKIP_TEST_O_LIBVIRT_SH=1
+ # Needs appliance built with >=libguestfs-1.55.6
+ local -x SKIP_TEST_CUSTOMIZE_SH=1
+ local -x SKIP_TEST_FEDORA_BTRFS_CONVERSION_SH=1
+ local -x SKIP_TEST_FEDORA_CONVERSION_SH=1
+ local -x SKIP_TEST_FEDORA_LUKS_ON_LVM_CONVERSION_SH=1
+ local -x SKIP_TEST_FEDORA_LVM_ON_LUKS_CONVERSION_SH=1
+ local -x SKIP_TEST_FEDORA_MD_CONVERSION_SH=1
+ local -x SKIP_TEST_O_KUBEVIRT_FEDORA_SH=1
+ # Must be called explicilty even without above variable because
+ # emake check -n fails due to missing Windows headers.
+ emake check
+}
+
+src_install() {
+ default
+
+ dobashcomp bash/virt-v2v
+}