summaryrefslogtreecommitdiff
path: root/app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-28 16:02:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-28 16:02:54 +0100
commita5509b9be1fe380ed210b8279d996e1f1b03017a (patch)
tree919df4b099c0e64e330833ddb01b17216b9cfc40 /app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch
parent9967860c0cd26c0940ee4b9ab6698e00e5b1260a (diff)
gentoo auto-resync : 28:08:2023 - 16:02:54
Diffstat (limited to 'app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch')
-rw-r--r--app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch b/app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch
new file mode 100644
index 000000000000..1a5f85f89ff8
--- /dev/null
+++ b/app-emulation/virtualbox/files/virtualbox-7.0.10-fix-binutils-hardened.patch
@@ -0,0 +1,35 @@
+Fix building with sys-devel/binutils-2.41-r1[hardened]: read-only segment has dynamic relocations.
+https://bugs.gentoo.org/913109
+
+--- a/src/VBox/Runtime/Makefile.kmk
++++ b/src/VBox/Runtime/Makefile.kmk
+@@ -3238,6 +3238,7 @@
+ endif
+ endif
+ RuntimeR0_INCS = include
++RuntimeR0_LDFLAGS.linux = -z notext
+ RuntimeR0_SOURCES := \
+ $(if $(VBOX_ONLY_VALIDATIONKIT),,../VMM/VBoxVMM.d) \
+ common/checksum/crc32c.cpp \
+--- a/src/VBox/VMM/Makefile.kmk
++++ b/src/VBox/VMM/Makefile.kmk
+@@ -603,6 +603,8 @@
+ VMMR0_DEFS.darwin.amd64 += VBOX_WITH_NATIVE_NEM VBOX_WITH_NEM_R0
+ endif
+
++ VMMR0_LDFLAGS.linux += -z notext
++
+ $(call VBOX_SET_VER_INFO_R0,VMMR0,VirtualBox VMM - ring-0 context parts) # Version info / description.
+
+ if "$(USERNAME)" == "bird" && "$(KBUILD_TARGET)" == "win"
+--- a/src/VBox/ExtPacks/VBoxDTrace/Makefile.kmk
++++ b/src/VBox/ExtPacks/VBoxDTrace/Makefile.kmk
+@@ -258,7 +258,7 @@
+ VBoxDTraceR0_TEMPLATE = VBoxR0ExtPackDTrace
+ VBoxDTraceR0_DEFS = IN_VBOXDTRACE_R0 IN_RT_R0
+ ifeq ($(VBOX_LDR_FMT),elf)
+- VBoxDTraceR0_LDFLAGS = -e ModuleInit
++ VBoxDTraceR0_LDFLAGS = -e ModuleInit -z notext
+ endif
+ VBoxDTraceR0_INCS = \
+ include \