summaryrefslogtreecommitdiff
path: root/app-emulation/vkd3d
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-25 03:02:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-25 03:02:44 +0000
commit7f0b7329b3aa78ea82792fdf68ab48415fe4cc35 (patch)
tree5c9f3c3f65f2be496e4d9778fdeb4d0da2207c29 /app-emulation/vkd3d
parent530a5a826feeb71085fb8a01927f4d775a0b131b (diff)
gentoo auto-resync : 25:11:2024 - 03:02:44
Diffstat (limited to 'app-emulation/vkd3d')
-rw-r--r--app-emulation/vkd3d/Manifest2
-rw-r--r--app-emulation/vkd3d/vkd3d-1.14.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
index 780073820236..47192694a9e6 100644
--- a/app-emulation/vkd3d/Manifest
+++ b/app-emulation/vkd3d/Manifest
@@ -1,3 +1,5 @@
DIST vkd3d-1.13.tar.xz 1123980 BLAKE2B 1b144ce9bd4351b59f1fc36f342d40f448ae45e8293968c1326ad74ec2a065a45ca543f7837fb0ab905caeaff2b38e54b76d81174839655465ed8a5cc3d024d5 SHA512 a2cb339aa68c01d961a67236fb3f5d247f359fce73aabe948933a02102a63029fb697ea8577e3086458c5fd59b787f74957b7a79534394960df8b6052fd0f993
+DIST vkd3d-1.14.tar.xz 1185324 BLAKE2B 17f719f6b28cb4b795ebfde5923dc36e97dfb0f7ba8687818c31a7b8c9c55e29eaee29504772a1c917ff90c38d77dceb76973bdc5b102978942810a930904b6e SHA512 db4429b591aa4a129361e9225241b6e5ec703f6877cafba235cbbf5d5dfc31eb37a80470f8d1295c46f68b99db715c8a54dced0d287fcea1c9174aa19ac4577d
EBUILD vkd3d-1.13.ebuild 1535 BLAKE2B 68cd617843ca3aa7f68baa17d32ff702701efb90dbfe85d7e339544a1c430791c4de013b84369ef895bad7039b69f3e012d8a9d543256527beaf5daa889449fb SHA512 3af8072ac657237db0fd6a765d06af632fb112cf6ab073fe42ac8b293690843e252ef5228b5d11b95d9d130ee8268505b676c66481bdfd85e093c08ab5df661d
+EBUILD vkd3d-1.14.ebuild 1537 BLAKE2B 2a243d2a41fb1a8d717c2b4e2a3cf9bb42009e0fc316330899a749a0eb90d7de13dbafcdf17f7909074bf06fedd7a1d70e653c4ea290da6d64441a536f6f9fad SHA512 047cff2ed8b7d6e527242968c87db09c0b63be28b43d7d14d05985ba18383e56e9c43f355cb39f058395ed9e27fe04dec2c3a5b9e53ac806fa506e528bf854c0
MISC metadata.xml 563 BLAKE2B c976a16a495bdb5863811acda56b2cc628683a63fc2a22c18d2a09775d3a38c845e00f83b97b318d9a0e5267bb470dd56d334dc9f43e3716784254802b8db60b SHA512 3d5afb7890b3b10ad424fcfe3fa2b42a9227ba0b82be8ab85308126966f476798818ee0ecc88c53105b218f465a72b213efe00968112431169884a4a6f48c6a8
diff --git a/app-emulation/vkd3d/vkd3d-1.14.ebuild b/app-emulation/vkd3d/vkd3d-1.14.ebuild
new file mode 100644
index 000000000000..92d9d092e4bf
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.14.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Note: This package is only needed by old wine-7 given >=8 builds a
+# bundled PE vkd3d using mingw rather than use the shared ELF library.
+#
+# Also unclear if bumping is safe, newer vkd3d is hardly tested with
+# old Wine and its old vulkan support. Quite possibly already unusable
+# but there is very few users of wine-7+d3d12 to report issues.
+#
+# Either way can be last-rited whenever wine-{vanilla,proton}-7 are gone,
+# or alternatively USE=vkd3d could be masked/removed if broken.
+
+inherit multilib-minimal
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://gitlab.winehq.org/wine/vkd3d/"
+SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses spirv-tools"
+RESTRICT="test" #838655
+
+RDEPEND="
+ media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+ ncurses? ( sys-libs/ncurses:= )
+ spirv-tools? ( dev-util/spirv-tools[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers
+"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local conf=(
+ $(multilib_native_use_with ncurses)
+ $(use_with spirv-tools)
+ --disable-doxygen-pdf
+ --without-xcb
+ # let users' flags control lto (bug #933178)
+ vkd3d_cv_cflags__flto_auto=
+ )
+
+ ECONF_SOURCE=${S} econf "${conf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}