summaryrefslogtreecommitdiff
path: root/app-emulation/vkd3d
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-22 11:16:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-22 11:16:57 +0100
commit92a9a3adda432ad2b7af58e08f5493ed6dc81196 (patch)
tree875f2d54382fdb68add8e3a92e44e49447be4a4b /app-emulation/vkd3d
parent67ff4e881df5f5a1482662d6aba4680f82d12197 (diff)
gentoo auto-resync : 22:09:2023 - 11:16:57
Diffstat (limited to 'app-emulation/vkd3d')
-rw-r--r--app-emulation/vkd3d/Manifest3
-rw-r--r--app-emulation/vkd3d/files/vkd3d-1.9-implicit-gettid.patch8
-rw-r--r--app-emulation/vkd3d/vkd3d-1.9.ebuild51
3 files changed, 62 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
index 3a70ead8c2dd..abc93c3a1b60 100644
--- a/app-emulation/vkd3d/Manifest
+++ b/app-emulation/vkd3d/Manifest
@@ -1,3 +1,6 @@
+AUX vkd3d-1.9-implicit-gettid.patch 257 BLAKE2B 94d8506c692c3869898d6eafc6bdad6eeca144631f8a551358cdeed64c874e6fbb57adcb8e3bec48df53fabeed660a558813aa0a1945b4b19e1677776972697b SHA512 772c5bf2a53869e0be3da60e2cd92fa5d9640f74a7fd5536db582bc4be2290dc0cf4342087ae9b3a6364b8c9dcebaafa5c6cee6f4c14f96a549db224fbd02153
DIST vkd3d-1.8.tar.xz 829648 BLAKE2B 0e7bb53e3eb9003ea76ee523dfa317b6ab95fd1c2decb453d650f0cf046d5b802a32e40c4e6f6464748903143ef9352e70fdf8ca7fa8e9b9909e0f15235d2b01 SHA512 43d65bf4aa60750e08653226197f40c97bc88d56dc5513b70182b5fe289ab56a225682c96400776cd625ad5a8f76644bf4b46bd3ed54aa8496f538f6854d680a
+DIST vkd3d-1.9.tar.xz 902300 BLAKE2B 62c71b98912e66d86a2d2d934f6bd4c252cced68d3ad96c23b7404dbe346e7a11e43affb1959b389cfc90b53f32b2011ceeca6d066bcae876d24ff0822719d2b SHA512 7fe931fca4bc2e13bd59f2068d758581797aa15530fb811d71323e3cd83a0f12ec3a00e2951f38033fccf8eabfca45e06dad79d80ccc164e047e13cbfc960d0e
EBUILD vkd3d-1.8.ebuild 953 BLAKE2B 0e57f0cdb2b971e06df97e10df11d18d00ec517d809a72eb77352f621322767b69fb4601f4c9a22d326a0557cb6bc5c78ee9cd59dcdb130acf37e2b86820c207 SHA512 48082c3b522bbca92debe3121731623e8c5fbd8e302e23394250a4af77ddc1cdd917a72a3d732efe64fcaeb169930f755e632a4b2a2cefbd4f9112faa471bda6
+EBUILD vkd3d-1.9.ebuild 1018 BLAKE2B aac849afbc641d967a636d47147ac36a634f641546b1093621f969e439a037aae4409db9a907579d782f66400831ad018bb2da6ffd461f48a1d41fc2e26a4e9d SHA512 4c50d2d1ab3ff03ada43f9ba4268df044bedd266ed996e38c9f80cae3a50b16e4e27365268fde7c92856f565585551cc909b1fa1f6540d5adaa746d7bf48ac17
MISC metadata.xml 563 BLAKE2B c976a16a495bdb5863811acda56b2cc628683a63fc2a22c18d2a09775d3a38c845e00f83b97b318d9a0e5267bb470dd56d334dc9f43e3716784254802b8db60b SHA512 3d5afb7890b3b10ad424fcfe3fa2b42a9227ba0b82be8ab85308126966f476798818ee0ecc88c53105b218f465a72b213efe00968112431169884a4a6f48c6a8
diff --git a/app-emulation/vkd3d/files/vkd3d-1.9-implicit-gettid.patch b/app-emulation/vkd3d/files/vkd3d-1.9-implicit-gettid.patch
new file mode 100644
index 000000000000..5aea3171c2de
--- /dev/null
+++ b/app-emulation/vkd3d/files/vkd3d-1.9-implicit-gettid.patch
@@ -0,0 +1,8 @@
+Dirty quick fix for implicit function check, VKD3D_CHECK_FUNC ideally
+needs to be adjusted to be able to pass headers.
+--- a/configure
++++ b/configure
+@@ -18656,2 +18656,3 @@
+ /* end confdefs.h. */
++#include <unistd.h>
+ int main(void) { return gettid(); }
diff --git a/app-emulation/vkd3d/vkd3d-1.9.ebuild b/app-emulation/vkd3d/vkd3d-1.9.ebuild
new file mode 100644
index 000000000000..2056245ceba0
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://gitlab.winehq.org/wine/vkd3d/"
+SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses spirv-tools"
+RESTRICT="test" #838655
+
+RDEPEND="
+ media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+ ncurses? ( sys-libs/ncurses:= )
+ spirv-tools? ( dev-util/spirv-tools[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers
+"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9-implicit-gettid.patch
+)
+
+multilib_src_configure() {
+ local conf=(
+ $(multilib_native_use_with ncurses)
+ $(use_with spirv-tools)
+ --disable-doxygen-pdf
+ --without-xcb
+ )
+
+ ECONF_SOURCE=${S} econf "${conf[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+}