summaryrefslogtreecommitdiff
path: root/app-emulation/vkd3d
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-08 09:15:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-08 09:15:15 +0000
commite37a045a0092ca878b980ed5e9f8bf09d38581c8 (patch)
treeab1c8558aa182073c63de5893345e1bfd4f8df4c /app-emulation/vkd3d
parent15478b615783e9a29c10a1d488af5498e5b3c3d6 (diff)
gentoo auto-resync : 08:12:2022 - 09:15:15
Diffstat (limited to 'app-emulation/vkd3d')
-rw-r--r--app-emulation/vkd3d/Manifest2
-rw-r--r--app-emulation/vkd3d/vkd3d-1.6.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
index 790c949bdddc..4ca5d80f7836 100644
--- a/app-emulation/vkd3d/Manifest
+++ b/app-emulation/vkd3d/Manifest
@@ -1,3 +1,5 @@
DIST vkd3d-1.5.tar.xz 776260 BLAKE2B c021dd03b120f3ad8da61147a12f9d581a85aaf458f34308f06a648167562adedd670444473cbc5ca66c1ff6242b2add21396bbc5cce308c39482451aa5b45e5 SHA512 69ec33bef28334a9a55da34621c71623843995279fb5267cc56228cd343c8cf292deb848596e6f850dfee6d07cc35206fc034fc4ce2a911652a9c42c032cdc08
+DIST vkd3d-1.6.tar.xz 785844 BLAKE2B 6dff7aaad966b378809c87969a54568b943c52bec072fa03becdb40c4ff098168924c363e642aa42049f4468ff75013175fb847cc213278a4e10ea54e906a288 SHA512 0f640c1b139f5ccce8e6d1986d1439c2b0d14e7ac533216d2408dbeee07172eee51549311db22464c2ae89070ca15191aaffd967749676586984561ce1d4b38f
EBUILD vkd3d-1.5.ebuild 953 BLAKE2B 7bc70de3a18044a97ad4323df4d2bba852109e968425c9cae9c4b0250f3977eaef933d64b6eac1d0a603868ab4a798370b73b151403454a61ce29bc626593b95 SHA512 62e5827659163f08fcc1cb247202a5e8e303a4e018ba9220ce171a9d40c4e66926baf8abec9d9b020004b996357ee21fe1772bf295c356c358d003040c2089ee
+EBUILD vkd3d-1.6.ebuild 955 BLAKE2B 2f9862129e5e4f2539b79acb710252dbd0783653398fa70695e94552f9f79c5c0c5923d65315e21a4b11794ac25c3517cdbb1cfbdea9ed6bd329c12c1a9a3e9e SHA512 f823bc9178fbc3334fac28fa4dc37ac1c1163d5b14a22e1fdd1b0deab4980bc3c625a776669bc25e047c45e8c3d84691ff975b7aae1d1dfab14fd252960f7388
MISC metadata.xml 563 BLAKE2B c976a16a495bdb5863811acda56b2cc628683a63fc2a22c18d2a09775d3a38c845e00f83b97b318d9a0e5267bb470dd56d334dc9f43e3716784254802b8db60b SHA512 3d5afb7890b3b10ad424fcfe3fa2b42a9227ba0b82be8ab85308126966f476798818ee0ecc88c53105b218f465a72b213efe00968112431169884a4a6f48c6a8
diff --git a/app-emulation/vkd3d/vkd3d-1.6.ebuild b/app-emulation/vkd3d/vkd3d-1.6.ebuild
new file mode 100644
index 000000000000..f0e863b89b11
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://gitlab.winehq.org/wine/vkd3d/"
+SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses spirv-tools"
+RESTRICT="test" #838655
+
+RDEPEND="
+ media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+ ncurses? ( sys-libs/ncurses:= )
+ spirv-tools? ( dev-util/spirv-tools[${MULTILIB_USEDEP}] )"
+DEPEND="
+ ${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig"
+
+multilib_src_configure() {
+ local conf=(
+ $(multilib_native_use_with ncurses)
+ $(use_with spirv-tools)
+ --disable-doxygen-pdf
+ --without-xcb
+ )
+
+ ECONF_SOURCE=${S} econf "${conf[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+}