summaryrefslogtreecommitdiff
path: root/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild')
-rw-r--r--app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild b/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
new file mode 100644
index 000000000000..66ba3caad5c5
--- /dev/null
+++ b/app-emulation/wine-desktop-common/wine-desktop-common-20150204.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit gnome2-utils
+
+DESCRIPTION="Various desktop menu items and icons for wine"
+HOMEPAGE="https://github.com/NP-Hardass/wine-desktop-common
+ https://dev.gentoo.org/~tetromino/distfiles/wine
+ https://bazaar.launchpad.net/~ubuntu-wine/wine/ubuntu-debian-dir/files/head:/debian/"
+SRC_URI="https://github.com/NP-Hardass/${PN}/archive/${PV//./}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* amd64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!!app-emulation/wine:0"
+PDEPEND="app-eselect/eselect-wine"
+
+# These use a non-standard "Wine" category, which is provided by
+# /etc/xdg/applications-merged/wine.menu
+QA_DESKTOP_FILE="usr/share/applications/wine-browsedrive.desktop
+usr/share/applications/wine-notepad.desktop
+usr/share/applications/wine-uninstaller.desktop
+usr/share/applications/wine-winecfg.desktop"
+
+S=${WORKDIR}/${PN}-${PV//./}
+
+src_install() {
+ emake install DESTDIR="${D}" EPREFIX="${EPREFIX}"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}