summaryrefslogtreecommitdiff
path: root/app-emulation/wine-vanilla
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-11 12:30:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-11 12:30:55 +0100
commit65a36438d5b824f80023c282dadc3fcd5736b526 (patch)
tree12aedb23736e7cceba662d217cdd7f0f2a2662ba /app-emulation/wine-vanilla
parentadd278b9601ff9e4af091c91c851ee46a185be8f (diff)
gentoo auto-resync : 11:09:2024 - 12:30:54
Diffstat (limited to 'app-emulation/wine-vanilla')
-rw-r--r--app-emulation/wine-vanilla/Manifest2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild13
2 files changed, 9 insertions, 6 deletions
diff --git a/app-emulation/wine-vanilla/Manifest b/app-emulation/wine-vanilla/Manifest
index f59efe2df57a..b5db8a6c1fe1 100644
--- a/app-emulation/wine-vanilla/Manifest
+++ b/app-emulation/wine-vanilla/Manifest
@@ -14,5 +14,5 @@ EBUILD wine-vanilla-9.0.ebuild 14161 BLAKE2B b37f13bf578900bda3eeffaf29d6fa03232
EBUILD wine-vanilla-9.15.ebuild 14282 BLAKE2B 40ea5b4e9471c95b87a50ec9e29ebe97f37546269d2377276832818d765fe7971931da26c69bafe81c338c380db30a3a6aac189c0e33a63fe1ec50e477025485 SHA512 79e81e4e9bb223a009ff86125efcbd26eebe854d37ff65f06dd78564f5e6ce339829ac483561f166f8c4a9358077d06f9c29ce59748104b64fdc90829438d6ec
EBUILD wine-vanilla-9.16.ebuild 14282 BLAKE2B 40ea5b4e9471c95b87a50ec9e29ebe97f37546269d2377276832818d765fe7971931da26c69bafe81c338c380db30a3a6aac189c0e33a63fe1ec50e477025485 SHA512 79e81e4e9bb223a009ff86125efcbd26eebe854d37ff65f06dd78564f5e6ce339829ac483561f166f8c4a9358077d06f9c29ce59748104b64fdc90829438d6ec
EBUILD wine-vanilla-9.17.ebuild 14302 BLAKE2B 3db8d94ebdc50596c0de79d4153e9b13c5ef1445de3eab2b3eb02f2cf10fa2bd05efbab5c15437906edb84fead774996a11a01c6f3d75aea385d395626381c31 SHA512 4174a3c7957015f002e914bf9e78397c7104de70594c034b997a8ceb17d9c65894c8a2dccd568f50fb12f6e59616b671b1f67c7eec209de127b687b6a857a551
-EBUILD wine-vanilla-9999.ebuild 14302 BLAKE2B 3db8d94ebdc50596c0de79d4153e9b13c5ef1445de3eab2b3eb02f2cf10fa2bd05efbab5c15437906edb84fead774996a11a01c6f3d75aea385d395626381c31 SHA512 4174a3c7957015f002e914bf9e78397c7104de70594c034b997a8ceb17d9c65894c8a2dccd568f50fb12f6e59616b671b1f67c7eec209de127b687b6a857a551
+EBUILD wine-vanilla-9999.ebuild 14385 BLAKE2B c0f7f7429a4b9006c1c58642a9b80ef1325dfdce9f7f109abce82b41fb606e8f1f917ce57b4597484ba978e27ffec1fd56837fbb70eb9c06b01d68c53fe9237e SHA512 c5f7f9d438a6457136b49f0dba4b8b1c524ac6567cd038bbc72608c1475a7bc001833c7ac29309bb679818f6df26188de5cd9cd757aaeb0b44f2661132170ece
MISC metadata.xml 2726 BLAKE2B 7dc7490fabcda06a27061726225890ee203fe7d22209697c3997f0ccdb4699bfaa09f983c22c4919ce75d2eab6ebdb1add9d9af04f24aee63bae81116fc04094 SHA512 5cdbb062462ae791ff9727d184935af3af147c0bd1e49846731941513301b720313b3356f56a8295780ab822e3117146c9a669d2d96efba6f072d84adba770e6
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 22b468368b77..838210bfb98a 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -30,11 +30,12 @@ LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
IUSE="
+X +abi_x86_32 +abi_x86_64 +alsa capi crossdev-mingw cups dos
- llvm-libunwind custom-cflags +fontconfig +gecko gphoto2 +gstreamer
- kerberos +mingw +mono netapi nls odbc opencl +opengl osmesa pcap
- perl pulseaudio samba scanner +sdl selinux smartcard +ssl +strip
- +truetype udev udisks +unwind usb v4l +vulkan wayland wow64
- +xcomposite xinerama"
+ llvm-libunwind custom-cflags ffmpeg +fontconfig +gecko gphoto2
+ +gstreamer kerberos +mingw +mono netapi nls odbc opencl +opengl
+ osmesa pcap perl pulseaudio samba scanner +sdl selinux smartcard
+ +ssl +strip +truetype udev udisks +unwind usb v4l +vulkan wayland
+ wow64 +xcomposite xinerama
+"
# bug #551124 for truetype
# TODO?: wow64 can be done without mingw if using clang (needs bug #912237)
REQUIRED_USE="
@@ -83,6 +84,7 @@ WINE_COMMON_DEPEND="
)
alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
capi? ( net-libs/libcapi:=[${MULTILIB_USEDEP}] )
+ ffmpeg? ( media-video/ffmpeg:=[${MULTILIB_USEDEP}] )
gphoto2? ( media-libs/libgphoto2:=[${MULTILIB_USEDEP}] )
gstreamer? (
dev-libs/glib:2[${MULTILIB_USEDEP}]
@@ -246,6 +248,7 @@ src_configure() {
$(use_with alsa)
$(use_with capi)
$(use_with cups)
+ $(use_with ffmpeg)
$(use_with fontconfig)
$(use_with gphoto2 gphoto)
$(use_with gstreamer)