summaryrefslogtreecommitdiff
path: root/app-emulation/wine-vanilla
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-02 09:28:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-02 09:28:30 +0100
commitbc3875d3a71ac3fdb07c0fcf863843b4fdfcf0c0 (patch)
treee255548891f2188ab2594eedde60d6f426ef24ed /app-emulation/wine-vanilla
parentdef28ad1de5a6853465d7ff8f626cda6a774cd9e (diff)
gentoo auto-resync : 02:06:2023 - 09:28:30
Diffstat (limited to 'app-emulation/wine-vanilla')
-rw-r--r--app-emulation/wine-vanilla/Manifest2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild22
2 files changed, 14 insertions, 10 deletions
diff --git a/app-emulation/wine-vanilla/Manifest b/app-emulation/wine-vanilla/Manifest
index 2cae345e483b..380673257b5e 100644
--- a/app-emulation/wine-vanilla/Manifest
+++ b/app-emulation/wine-vanilla/Manifest
@@ -11,5 +11,5 @@ EBUILD wine-vanilla-8.0.1.ebuild 10531 BLAKE2B c0f7101f6ea462bb6107b9c655a3c08f8
EBUILD wine-vanilla-8.7.ebuild 10752 BLAKE2B fd8ed4c4bb537108cffb5bbb9edf5bbc942d289eaa02cda12237c4dc6df849161b7d8b426717732ff49ad4d826f97e32ea7107c182bbcb50e3752698ecfa5351 SHA512 7ce00cfcb1f65c0a72acc1d3adbb4157b75d8853a31f580f4eb29701c9ee54f804078174b43cb1552bab488381f5716ac035ae7092629ae06ec4f8ddef7998f7
EBUILD wine-vanilla-8.8.ebuild 10752 BLAKE2B fd8ed4c4bb537108cffb5bbb9edf5bbc942d289eaa02cda12237c4dc6df849161b7d8b426717732ff49ad4d826f97e32ea7107c182bbcb50e3752698ecfa5351 SHA512 7ce00cfcb1f65c0a72acc1d3adbb4157b75d8853a31f580f4eb29701c9ee54f804078174b43cb1552bab488381f5716ac035ae7092629ae06ec4f8ddef7998f7
EBUILD wine-vanilla-8.9.ebuild 10752 BLAKE2B 15bd7b4d854611973e0e263f74e5c95c2cd97e2c77733b14e7ad8c7e1f5b2692014f5d6afdeca04db12637ea140a0ce9c66de3e474a6fe29ea8f6b7df36eaa7d SHA512 598118bc03ff48deeb43e8a9eb26e03587243221af9b1b0db7aa93831b91348ef4f413ab4a08b9144e6795a2175d899c3088536a296c6dc4b45427cb33986de8
-EBUILD wine-vanilla-9999.ebuild 10752 BLAKE2B 15bd7b4d854611973e0e263f74e5c95c2cd97e2c77733b14e7ad8c7e1f5b2692014f5d6afdeca04db12637ea140a0ce9c66de3e474a6fe29ea8f6b7df36eaa7d SHA512 598118bc03ff48deeb43e8a9eb26e03587243221af9b1b0db7aa93831b91348ef4f413ab4a08b9144e6795a2175d899c3088536a296c6dc4b45427cb33986de8
+EBUILD wine-vanilla-9999.ebuild 10824 BLAKE2B 5d1497f380646885b9be680687f4d76d6e282c2daae17cef7810c5639793cbd882ca931e4bf833d8dd7b454a9f27991036aa76ba70ddab9fa08ee7aed8cad2af SHA512 f1b688cffa4212c0603eea8e9c1e2f127208888077f85cf962a64405bd75707ef013a2eb74807e3efd8ee9885b283df0f90eaf8c49dd13648fc85d113ad1a6ce
MISC metadata.xml 2406 BLAKE2B 3632339181cdc1fa339771f8d98fcd871930704a15acd4d91fff21964ce31f6892bf980c563851efda257503930adecaf6c8311c81ac16de66908127d2d5a1e7 SHA512 94f9ee47e3dd04f0908f6a0fa934ed64b74b906b89010717aa3180078edc2391fac54987fd4ab12aa25fa5891399a205c5ccd7b852ab7bb3814f16851b25ab38
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index a513b26e07bb..fa578d8607db 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -28,11 +28,11 @@ LICENSE="LGPL-2.1+ BSD-2 IJG MIT OPENLDAP ZLIB gsm libpng2 libtiff"
SLOT="${PV}"
IUSE="
+X +abi_x86_32 +abi_x86_64 +alsa capi crossdev-mingw cups dos
- llvm-libunwind debug custom-cflags +fontconfig +gecko gphoto2
- +gstreamer kerberos +mingw +mono netapi nls odbc opencl +opengl
- osmesa pcap perl pulseaudio samba scanner +sdl selinux smartcard
- +ssl +truetype udev udisks +unwind usb v4l +vulkan wayland
- +xcomposite xinerama"
+ llvm-libunwind custom-cflags +fontconfig +gecko gphoto2 +gstreamer
+ kerberos +mingw +mono netapi nls odbc opencl +opengl osmesa pcap
+ perl pulseaudio samba scanner +sdl selinux smartcard +ssl +strip
+ +truetype udev udisks +unwind usb v4l +vulkan wayland +xcomposite
+ xinerama"
REQUIRED_USE="
X? ( truetype )
crossdev-mingw? ( mingw )" # bug #551124 for truetype
@@ -318,13 +318,17 @@ src_install() {
make_wrapper "${bin##*/}-${P#wine-}" "${bin#"${ED}"}"
done
- # don't let portage try to strip PE files with the wrong
- # strip executable and instead handle it here (saves ~120MB)
if use mingw; then
+ # don't let portage try to strip PE files with the wrong
+ # strip executable and instead handle it here (saves ~120MB)
dostrip -x ${WINE_PREFIX}/wine/{i386,x86_64}-windows
- use debug ||
+
+ if use strip; then
+ ebegin "Stripping Windows (PE) binaries"
find "${ED}"${WINE_PREFIX}/wine/*-windows -regex '.*\.\(a\|dll\|exe\)' \
- -exec $(usex abi_x86_64 x86_64 i686)-w64-mingw32-strip --strip-unneeded {} + || die
+ -exec $(usex abi_x86_64 x86_64 i686)-w64-mingw32-strip --strip-unneeded {} +
+ eend ${?} || die
+ fi
fi
dodoc ANNOUNCE AUTHORS README* documentation/README*