summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 02:30:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 02:30:06 +0100
commita6266c63b23ed0ee16865627ca53e4f5353f0a5c (patch)
tree6ed71ecc485e9c4903818db305f6ebee454a38db /app-emulation
parent1fd4e372381e1318aae1b7d3338c04156e5da974 (diff)
gentoo auto-resync : 17:07:2022 - 02:30:06
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/86Box/86Box-3.6.ebuild7
-rw-r--r--app-emulation/86Box/Manifest2
-rw-r--r--app-emulation/Manifest.gzbin14820 -> 14820 bytes
-rw-r--r--app-emulation/pcem/Manifest4
-rw-r--r--app-emulation/pcem/files/pcem-17-respect-cflags.patch4
-rw-r--r--app-emulation/pcem/pcem-17-r1.ebuild5
6 files changed, 15 insertions, 7 deletions
diff --git a/app-emulation/86Box/86Box-3.6.ebuild b/app-emulation/86Box/86Box-3.6.ebuild
index 83e0de773c6f..ab0476394bfd 100644
--- a/app-emulation/86Box/86Box-3.6.ebuild
+++ b/app-emulation/86Box/86Box-3.6.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Emulator of x86-based machines based on PCem"
HOMEPAGE="https://github.com/86Box/86Box"
@@ -45,6 +45,11 @@ RDEPEND="
BDEPEND="virtual/pkgconfig"
src_configure() {
+ # LTO needs to be filtered
+ # See https://bugs.gentoo.org/854507
+ filter-lto
+ append-flags -fno-strict-aliasing
+
local mycmakeargs=(
-DCPPTHREADS="$(usex threads)"
-DDEV_BRANCH="$(usex experimental)"
diff --git a/app-emulation/86Box/Manifest b/app-emulation/86Box/Manifest
index c825adf8788b..9db3227c3eae 100644
--- a/app-emulation/86Box/Manifest
+++ b/app-emulation/86Box/Manifest
@@ -1,3 +1,3 @@
DIST 86Box-3.6.tar.gz 5158884 BLAKE2B 7483b39ac377dba0f65680d40c88944bec5a77b64abeb859da586e6fecf2706f0803bbd18f443e4b6bdb3cfb03e50f3bdc264a586f629d3db62c5c965eb76ed5 SHA512 08f281f70afce47f8e483c0b16dc99b3704beb89c8ad007a6d1814f8cd3716d5bedc4ca4444cbd61c79960e89152b24cfa34c53d51a10f99c811ca3d3290225d
-EBUILD 86Box-3.6.ebuild 1531 BLAKE2B ab2dbd5177a1e03b3cc6dc674cdb2926e8d6a8b710f0ad0b78843fcd399f8cac5c268b6fea894526e601602ed7e822175437cb2bda64606719555eb1359bc3a5 SHA512 adc8e79d5f31ccc9b660e3dfcab4ff7e60eb998f88cb7a3e6b493c5a913ba046bb5aac69c6244ab2b2e2b23b4bed5a6e7786422ac47e1e3f31072ec4fcbb6689
+EBUILD 86Box-3.6.ebuild 1658 BLAKE2B c664e8736650505fce7ecd7976850bcaa802c5bfc512a17769ff39a08967d1b6f4a2e66428bb717fbd23c90fe2b34e61aa44d98a33888b6c9392431076d66bf8 SHA512 bfa17c09a8d370d3cbf860edd28e9c9ccebfb3cf6feea248a5ec8e19ab956186e2e1155b67925d83ce38567463b22c788b1a74da45aec3eef48cdc56604c5195
MISC metadata.xml 1266 BLAKE2B 45b789d3b456cf4fd28ab8ef5ab32bd8ef02c2da36f157a405ca2a90154d882f8c37a28dfa16cd6ea1e3d45d30ebd4130b37699792e0b1d0daf7ae32592e99a3 SHA512 8da4ab4b5d57caf7adc895d186ab3086857f196d2bc66513266305ace183f26f3b3304bbc861b7a31a95046d67bc7f008aa14d28c9848db9e09fae25724636f2
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index 7a1e1a5c2f7c..72e42e0a3db2 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/pcem/Manifest b/app-emulation/pcem/Manifest
index d3589cabd1a9..9d3a755c335c 100644
--- a/app-emulation/pcem/Manifest
+++ b/app-emulation/pcem/Manifest
@@ -1,4 +1,4 @@
-AUX pcem-17-respect-cflags.patch 273 BLAKE2B 5c6bb6335677a1784b7fe99de3ebfc47351ab1c849d03f656e5428fd309256c46736ce6faf709aa379279c52ebdc7b46ea2e15ab1aa60a43dbdfc91fa09581af SHA512 4b83837f623971ccb91f525cee9bace2b9fd6b3a776a7d6907ec8e8796a021d8d68e665fc0dff7db083c7e068d6e07d3d61049ee2d9209c5b3d59a0fca388064
+AUX pcem-17-respect-cflags.patch 217 BLAKE2B a41bebda7404d036daa7e3b07148d1488946ab5e0744dd43724aeab3aea0a53a5ee727e3e25ce6f221b3f4d0861029c1ff25db77da44c755005c39df436c21c1 SHA512 799539c89a662e2b71db734a2b5fc2354535e7a9783f09dac975ad23628cd57b08eafa9cbfd79aa2443945cb0e5e3ce77ef05a6af4da646b5f5c0095de43a362
DIST PCemV17Linux.tar.gz 1880868 BLAKE2B 64068f0f98e8fe3e9bfe42a04f462375a7ee0cb8259b103237f3b0542f54ad13ed625a55c8379e2c54a87348ed504496a6b163419855ceeda8e4f18e1ea5dcd9 SHA512 6d84c8cbe9b6116f6439f542ac08139cfc5652a34b615a1ed841a6f8c227e77f1d26573ec35d57511b9a69e7472fbe51f2abb9307f8f8c1207c74fbe8107cadd
-EBUILD pcem-17-r1.ebuild 1712 BLAKE2B d1069332baa4fc7c33f945f580f991276e9264295e1efeeca51dabbd06db9493d6de3afb0027ed1a6d19d9c6eed40fba552800511fc5d06080857344be0a0551 SHA512 bccde8e24ed08d430a85d742d6c60ec54a71b1c1c36f4bcbcc4d223801a3aa9d6d13705e55ebc6861914940b5e92d13bfdb316939073d6b22583ce12a6bd69af
+EBUILD pcem-17-r1.ebuild 1826 BLAKE2B 9c4b099dff3ca76d27be0eae6c2be1e160806e66e71dbaf9fc4ab352a65e9c93bf1b3303205e8491fc9991dddfe88abc3cf1600d512ad78551b0193152d61215 SHA512 1e40ffdf6a279a3f9f29a0e17fa135fdba3f2beeb425b88b4ecb79f5a75c2df97ccdf8230a68075b3f01e7ba6f218f84866ff772407074a8f7c7dde0d50787f7
MISC metadata.xml 858 BLAKE2B 693055e24ab86b6b74207c4b29b61ee27b2c845610c9ce2f8543c103ad919c1d4515598a7663749df3c0fa0d7fa2616521d45a6502ffa44238d0b9c17eda5491 SHA512 00de5b7bb6c28179cb9f1892b1b9fc053b6ee46123d0cfcb0ae50b32a918680ceb6e8626608de0c5872f1f8ad07ab961de5d906c37ad8617860cb3c0ab88d386
diff --git a/app-emulation/pcem/files/pcem-17-respect-cflags.patch b/app-emulation/pcem/files/pcem-17-respect-cflags.patch
index 73cac4541bf1..0e9d28885595 100644
--- a/app-emulation/pcem/files/pcem-17-respect-cflags.patch
+++ b/app-emulation/pcem/files/pcem-17-respect-cflags.patch
@@ -1,13 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -31,8 +31,8 @@
+@@ -31,8 +31,6 @@
CXXFLAGS="-Wall -O0 -g -D_DEBUG -fcommon"
AC_MSG_RESULT([yes])
else
- CFLAGS="-O3 -fcommon"
- CXXFLAGS="-O3 -fcommon"
-+ CFLAGS?="-O3 -fcommon"
-+ CXXFLAGS?="-O3 -fcommon"
AC_MSG_RESULT([no])
fi
diff --git a/app-emulation/pcem/pcem-17-r1.ebuild b/app-emulation/pcem/pcem-17-r1.ebuild
index bad0762a6e55..413ef572d024 100644
--- a/app-emulation/pcem/pcem-17-r1.ebuild
+++ b/app-emulation/pcem/pcem-17-r1.ebuild
@@ -45,6 +45,11 @@ src_configure() {
# See https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=3&t=3443
append-cflags -fcommon
+ # LTO needs to be filtered
+ # See https://bugs.gentoo.org/854528
+ filter-lto
+ append-flags -fno-strict-aliasing
+
local myeconfargs=(
--enable-release-build
$(use_enable alsa)