summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 02:47:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 02:47:53 +0100
commitc3a905eafd0ea87d50767fa3d24a6b565a41faa9 (patch)
tree8fcd60c2f36e3da5e4d545f47ddf14680f0d51e5 /app-emulation
parent159ec3f090554ee5d7f61b2da553833fb7566f99 (diff)
gentoo auto-resync : 26:10:2023 - 02:47:53
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/Manifest.gzbin15149 -> 15151 bytes
-rw-r--r--app-emulation/protontricks/Manifest2
-rw-r--r--app-emulation/protontricks/protontricks-1.10.5.ebuild58
3 files changed, 60 insertions, 0 deletions
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index 24bb8da7b9ef..2283dafd6ba1 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index d829c860c4d3..c7332ce1e011 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,3 +1,5 @@
DIST protontricks-1.10.3.tar.gz 162698 BLAKE2B 7e3f696f3589a4a92d2cc6132132546bc0c38a5110d688cd486c2d52bd37275b8df4085edc38d4876583aa0d5ec0a9de599ca05616bf92812decf624e2259406 SHA512 c389a712bcbb9dace8e6b3fa10ddb9db0a67abbd3b8d000d312fd59bb682aa68c10d5411b10b31948967536418e56116ac435054ff6d6999bc471ba2a97ca6ba
+DIST protontricks-1.10.5.tar.gz 163931 BLAKE2B 299fd6c77460de3d2fa1b585a1ad3dae857e4b78898c753007b358cc25b82918d33cb31c2028a4b1b562ee6c20b95ebafc532d97e2bc1fa5358464c6a4c1da5c SHA512 305b27ceaf428946a0ed09994173c861da1097c0bd21eebcc8b255bed3c4c50a920f0cc422601fbd44e0af373b71e928096fdd6f4cc2aa05c88126212fb4401f
EBUILD protontricks-1.10.3.ebuild 1353 BLAKE2B 5425ca792df9caa7dfc57d2422edf2c1b0697d8339f00896d0b077f1f1fc9ab139fd75bfe0e3f1bdb02644db4fd7ae05a38d4b14579337d37331095988f6cf66 SHA512 d3f84d7097d011390ebc553fcba9579fd88fd0991eb5dcdd2f99a46f3be086ec07e9b477a0908890833bb73d3219b3653420803ed059574b251202a63de7eb70
+EBUILD protontricks-1.10.5.ebuild 1392 BLAKE2B c0a5e546d6f62c0ba9ca6c02e27e1e564e7ca3708d3086d92c0ea7c8fa4f3f3c3d0090ce66511df7a7743e77e0a8d9a7f278c38e2606f5e741f1637ddb22ed12 SHA512 feba53bd9e021638c649be003cf01b68d1e5bac03715bee2c6683f379108031b4c0dc8016e4f10d2d21bc7cf621c4f9a89b3ec1221937ccb0a0a0b05b3545556
MISC metadata.xml 809 BLAKE2B dc0506e6f3224adc867438699359c4eafc389041846c644818732036e04bcb9c789e358a08effdb4b9ff4430521f7fe8ff6800b75aa93d6313e3d85395467741 SHA512 351bb79dc7921e6c62100b3354546185d31578b044393ea5e5b5fea089eb47164882ff4ede30d8a575dea31ec9d0927793f8109d9e63ca4ad6954c1affdbe6f4
diff --git a/app-emulation/protontricks/protontricks-1.10.5.ebuild b/app-emulation/protontricks/protontricks-1.10.5.ebuild
new file mode 100644
index 000000000000..cbecf711b3cf
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.10.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}