summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-eselect/eselect-python
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-eselect/eselect-python')
-rw-r--r--app-eselect/eselect-python/Manifest4
-rw-r--r--app-eselect/eselect-python/eselect-python-20200719.ebuild41
-rw-r--r--app-eselect/eselect-python/eselect-python-99999999.ebuild11
3 files changed, 50 insertions, 6 deletions
diff --git a/app-eselect/eselect-python/Manifest b/app-eselect/eselect-python/Manifest
index 50e0bacfe047..a99b6350566f 100644
--- a/app-eselect/eselect-python/Manifest
+++ b/app-eselect/eselect-python/Manifest
@@ -1,4 +1,6 @@
DIST eselect-python-20190417.tar.bz2 46698 BLAKE2B 6f0acad0abb21d8e4768cbeb12f7e871c316a940ebae4c02bdb1336095991cb6b6bf05661ab659115a67f29a09f2a9b57cfb0868019606ed550b5aa1863f6f71 SHA512 a461263a50a29f0493127ee4a027e49ca4d7631e9c8d16cffc8bdb98cc7e75b0796e45e70951d5559fb86f0db14141a3ea6a53bd4cf1e0cc83ed5c7f24173695
+DIST eselect-python-20200719.tar.bz2 47313 BLAKE2B 37270b1f5ad3dfcd4e19c71ae74da585e803afe89c43f8b912bccf0fbdb936916cf58fc780b654692bb9e6ab44310514bae5f10d19dcde6a0e63042f76abe81d SHA512 4b205a099ad079e5e28d3fdbe774c22f54b7c16bff2d28b54d0e20ee36be2339e928d4050eed74ef969d5815bf4bb691bf5ed6e98023b28972da6d5c7d8a2545
EBUILD eselect-python-20190417.ebuild 1084 BLAKE2B 8ee22b070bcd50d555ef896d49e25e9590c973e3f36e433116176d085221f04f340713c613572e53f5dd7cd2857f2ece56ca543d83568a59a33f331d6928e574 SHA512 2e5ed3e5315ad862d8b43f1278dad4d56daef65e3a5b103e3f0981e28b7f0fef1df4b3a3a45a4c5db93696c7a85e081ef8452e4df8234b4920792e4af54bdc2a
-EBUILD eselect-python-99999999.ebuild 1094 BLAKE2B a07607d61e97ef3c29dcf22a5aa05c1028cfab576e88451af88d5955b21f0b281d01a0b2a8fd806786708701679b72147c509f638d95c7052b4e6ce36d688d5d SHA512 fb293c5d9c1f1beea28bfd8a2bfa696be40cbe5c7b651545ffcd17047dadb40c28c6f648da33db93f67cd5a789b64aa600dfdf114cd0f3ba9e332dcb76f4625d
+EBUILD eselect-python-20200719.ebuild 1095 BLAKE2B d7cbdeabdabff6889cb3ccb8d80472413f97b94fba5a68501172bb4f874108c99177a3ac2f499758bf73c4a3510819c602448bcb1909fa50a4907f38f503e30f SHA512 f63dc03a54d8b7bee0eb4bc161992e9cebb4c3b83929651f2dd5cb1a802c6aaa7e0c97138ae8fd7f9ec0e6dc3b3f78577ee79cbd6a4d6f2cecf7e374b925d49b
+EBUILD eselect-python-99999999.ebuild 1095 BLAKE2B d7cbdeabdabff6889cb3ccb8d80472413f97b94fba5a68501172bb4f874108c99177a3ac2f499758bf73c4a3510819c602448bcb1909fa50a4907f38f503e30f SHA512 f63dc03a54d8b7bee0eb4bc161992e9cebb4c3b83929651f2dd5cb1a802c6aaa7e0c97138ae8fd7f9ec0e6dc3b3f78577ee79cbd6a4d6f2cecf7e374b925d49b
MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/app-eselect/eselect-python/eselect-python-20200719.ebuild b/app-eselect/eselect-python/eselect-python-20200719.ebuild
new file mode 100644
index 000000000000..745d4e05cb20
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20200719.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~chutzpah/dist/misc/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# python-exec-2.4.2 for working -l option
+RDEPEND="
+ >=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}
diff --git a/app-eselect/eselect-python/eselect-python-99999999.ebuild b/app-eselect/eselect-python/eselect-python-99999999.ebuild
index 8e05fb549b51..745d4e05cb20 100644
--- a/app-eselect/eselect-python/eselect-python-99999999.ebuild
+++ b/app-eselect/eselect-python/eselect-python-99999999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} == "99999999" ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
else
- SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ SRC_URI="https://dev.gentoo.org/~chutzpah/dist/misc/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
@@ -16,11 +16,12 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
# python-exec-2.4.2 for working -l option
-RDEPEND=">=app-admin/eselect-1.2.3
- >=dev-lang/python-exec-2.4.2"
+RDEPEND="
+ >=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2
+"
src_prepare() {
default