summaryrefslogtreecommitdiff
path: root/app-forensics/aflplusplus/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-31 10:50:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-31 10:50:20 +0100
commitc3b55a6be7da027d97d8aef00ef88c3011121a42 (patch)
tree3931524f7f6f9958aa6427f6a11a0df28ff99a30 /app-forensics/aflplusplus/files
parentc8f83ad526fb6b554daf375e0ad65eb2d56e669b (diff)
gentoo auto-resync : 31:08:2022 - 10:50:20
Diffstat (limited to 'app-forensics/aflplusplus/files')
-rw-r--r--app-forensics/aflplusplus/files/aflplusplus-4.00c-respect-flags.patch122
-rw-r--r--app-forensics/aflplusplus/files/aflplusplus-4.02c-no-ignore-errors-makefile.patch (renamed from app-forensics/aflplusplus/files/aflplusplus-4.00c-no-ignore-errors-makefile.patch)90
-rw-r--r--app-forensics/aflplusplus/files/aflplusplus-4.02c-respect-flags.patch200
3 files changed, 259 insertions, 153 deletions
diff --git a/app-forensics/aflplusplus/files/aflplusplus-4.00c-respect-flags.patch b/app-forensics/aflplusplus/files/aflplusplus-4.00c-respect-flags.patch
deleted file mode 100644
index 47ccbe008c89..000000000000
--- a/app-forensics/aflplusplus/files/aflplusplus-4.00c-respect-flags.patch
+++ /dev/null
@@ -1,122 +0,0 @@
---- a/GNUmakefile
-+++ b/GNUmakefile
-@@ -420,7 +420,7 @@ afl-as: src/afl-as.c include/afl-as.h $(COMM_HDR) | test_x86
- @ln -sf afl-as as
-
- src/afl-performance.o : $(COMM_HDR) src/afl-performance.c include/hash.h
-- $(CC) $(CFLAGS) -Iinclude $(SPECIAL_PERFORMANCE) -O3 -fno-unroll-loops -c src/afl-performance.c -o src/afl-performance.o
-+ $(CC) $(CFLAGS) -Iinclude $(SPECIAL_PERFORMANCE) -fno-unroll-loops -c src/afl-performance.c -o src/afl-performance.o
-
- src/afl-common.o : $(COMM_HDR) src/afl-common.c include/common.h
- $(CC) $(CFLAGS) $(CFLAGS_FLTO) -c src/afl-common.c -o src/afl-common.o
---- a/GNUmakefile.gcc_plugin
-+++ b/GNUmakefile.gcc_plugin
-@@ -131,18 +131,18 @@ afl-common.o: ./src/afl-common.c
- $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@ $(LDFLAGS)
-
- ./afl-compiler-rt.o: instrumentation/afl-compiler-rt.o.c
-- $(CC) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -fPIC -c $< -o $@
-+ $(CC) $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -fPIC -c $< -o $@
-
- ./afl-compiler-rt-32.o: instrumentation/afl-compiler-rt.o.c
- @printf "[*] Building 32-bit variant of the runtime (-m32)... "
-- @$(CC) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -m32 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-32.o afl-llvm-rt-32.o; else echo "failed (that's fine)"; fi
-+ @$(CC) $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -m32 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-32.o afl-llvm-rt-32.o; else echo "failed (that's fine)"; fi
-
- ./afl-compiler-rt-64.o: instrumentation/afl-compiler-rt.o.c
- @printf "[*] Building 64-bit variant of the runtime (-m64)... "
-- @$(CC) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -m64 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-64.o afl-llvm-rt-64.o; else echo "failed (that's fine)"; fi
-+ @$(CC) $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -m64 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-64.o afl-llvm-rt-64.o; else echo "failed (that's fine)"; fi
-
- ./afl-gcc-pass.so: instrumentation/afl-gcc-pass.so.cc | test_deps
-- $(CXX) $(CXXEFLAGS) $(PLUGIN_FLAGS) -shared $< -o $@
-+ $(CXX) $(CXXEFLAGS) $(PLUGIN_FLAGS) -shared $< -o $@ $(LDFLAGS)
- ln -sf afl-cc afl-gcc-fast
- ln -sf afl-cc afl-g++-fast
- ln -sf afl-cc.8 afl-gcc-fast.8
---- a/GNUmakefile.llvm
-+++ b/GNUmakefile.llvm
-@@ -438,20 +438,20 @@ afl-llvm-dict2file.so: instrumentation/afl-llvm-dict2file.so.cc instrumentation/
-
- .PHONY: document
- document:
-- $(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -O3 -Wno-unused-result -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt.o
-- @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -O3 -Wno-unused-result -m32 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-32.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
-- @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -O3 -Wno-unused-result -m64 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-64.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
-+ $(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -Wno-unused-result -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt.o
-+ @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -Wno-unused-result -m32 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-32.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
-+ @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -Wno-unused-result -m64 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-64.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
-
- ./afl-compiler-rt.o: instrumentation/afl-compiler-rt.o.c
-- $(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -fPIC -c $< -o $@
-+ $(CC) $(CFLAGS) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -fPIC -c $< -o $@
-
- ./afl-compiler-rt-32.o: instrumentation/afl-compiler-rt.o.c
- @printf "[*] Building 32-bit variant of the runtime (-m32)... "
-- @$(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -m32 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-32.o afl-llvm-rt-32.o; else echo "failed (that's fine)"; fi
-+ @$(CC) $(CFLAGS) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -m32 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-32.o afl-llvm-rt-32.o; else echo "failed (that's fine)"; fi
-
- ./afl-compiler-rt-64.o: instrumentation/afl-compiler-rt.o.c
- @printf "[*] Building 64-bit variant of the runtime (-m64)... "
-- @$(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -m64 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-64.o afl-llvm-rt-64.o; else echo "failed (that's fine)"; fi
-+ @$(CC) $(CFLAGS) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -m64 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; ln -sf afl-compiler-rt-64.o afl-llvm-rt-64.o; else echo "failed (that's fine)"; fi
-
- .PHONY: test_build
- test_build: $(PROGS)
---- a/custom_mutators/honggfuzz/Makefile
-+++ b/custom_mutators/honggfuzz/Makefile
-@@ -1,5 +1,6 @@
-
--CFLAGS = -O3 -funroll-loops -fPIC -Wl,-Bsymbolic
-+CFLAGS ?= -O3
-+CFLAGS += -funroll-loops -fPIC -Wl,-Bsymbolic
-
- all: honggfuzz-mutator.so
-
---- a/custom_mutators/libfuzzer/Makefile
-+++ b/custom_mutators/libfuzzer/Makefile
-@@ -1,5 +1,6 @@
-
--CFLAGS = -g -O3 -funroll-loops -fPIC -fpermissive -std=c++11
-+CFLAGS ?= -g -O3
-+CFLAGS += -funroll-loops -fpermissive -std=c++11 -fPIC
- #CFLAGS = -g -O0 -fPIC -fpermissive -std=c++11
- CXX ?= clang++
-
---- a/frida_mode/GNUmakefile
-+++ b/frida_mode/GNUmakefile
-@@ -17,7 +17,6 @@ CFLAGS+=-fPIC \
- -D_GNU_SOURCE \
- -D_FORTIFY_SOURCE=2 \
- -g \
-- -O3 \
- -funroll-loops \
- -ffunction-sections \
-
---- a/frida_mode/test/png/persistent/hook/GNUmakefile
-+++ b/frida_mode/test/png/persistent/hook/GNUmakefile
-@@ -5,11 +5,9 @@ BUILD_DIR:=$(PWD)build/
- AFLPP_FRIDA_DRIVER_HOOK_OBJ=$(ROOT)frida_mode/build/frida_hook.so
- AFLPP_QEMU_DRIVER_HOOK_OBJ=$(ROOT)frida_mode/build/qemu_hook.so
-
--CFLAGS+=-O3 \
-- -funroll-loops \
-+CFLAGS+= -funroll-loops \
- -g \
-- -fPIC \
-- -funroll-loops \
-+ -fPIC
-
- LDFLAGS+=-shared \
-
---- a/utils/aflpp_driver/GNUmakefile
-+++ b/utils/aflpp_driver/GNUmakefile
-@@ -7,7 +7,7 @@ ifneq "" "$(LLVM_BINDIR)"
- LLVM_BINDIR := $(LLVM_BINDIR)/
- endif
-
--CFLAGS := -O3 -funroll-loops -g -fPIC
-+CFLAGS ?= -O3 -funroll-loops -g -fPIC
-
- all: libAFLDriver.a libAFLQemuDriver.a aflpp_qemu_driver_hook.so
-
diff --git a/app-forensics/aflplusplus/files/aflplusplus-4.00c-no-ignore-errors-makefile.patch b/app-forensics/aflplusplus/files/aflplusplus-4.02c-no-ignore-errors-makefile.patch
index 50d9268ac9bb..8a2cccbcff8f 100644
--- a/app-forensics/aflplusplus/files/aflplusplus-4.00c-no-ignore-errors-makefile.patch
+++ b/app-forensics/aflplusplus/files/aflplusplus-4.02c-no-ignore-errors-makefile.patch
@@ -1,13 +1,19 @@
https://bugs.gentoo.org/800941
+(also don't override jobs for sub-makes)
--- a/GNUmakefile
+++ b/GNUmakefile
-@@ -310,13 +310,13 @@ all: test_x86 test_shm test_python ready $(PROGS) afl-as llvm gcc_plugin test_bu
+@@ -308,17 +308,17 @@ endif
+
+ .PHONY: all
+ all: test_x86 test_shm test_python ready $(PROGS) afl-as llvm gcc_plugin test_build all_done
+- -$(MAKE) -C utils/aflpp_driver
++ $(MAKE) -C utils/aflpp_driver
.PHONY: llvm
llvm:
-- -$(MAKE) -j4 -f GNUmakefile.llvm
-+ $(MAKE) -j4 -f GNUmakefile.llvm
+- -$(MAKE) -j$(nproc) -f GNUmakefile.llvm
++ $(MAKE) -f GNUmakefile.llvm
@test -e afl-cc || { echo "[-] Compiling afl-cc failed. You seem not to have a working compiler." ; exit 1; }
.PHONY: gcc_plugin
@@ -18,19 +24,15 @@ https://bugs.gentoo.org/800941
endif
.PHONY: man
-@@ -565,19 +565,19 @@ all_done: test_build
+@@ -571,19 +571,19 @@ all_done: test_build
.PHONY: clean
clean:
- rm -rf $(PROGS) afl-fuzz-document afl-as as afl-g++ afl-clang afl-clang++ *.o src/*.o *~ a.out core core.[1-9][0-9]* *.stackdump .test .test1 .test2 test-instr .test-instr0 .test-instr1 afl-cs-proxy afl-qemu-trace afl-gcc-fast afl-g++-fast ld *.so *.8 test/unittests/*.o test/unittests/unit_maybe_alloc test/unittests/preallocable .afl-* afl-gcc afl-g++ afl-clang afl-clang++ test/unittests/unit_hash test/unittests/unit_rand *.dSYM
+ rm -rf $(PROGS) afl-fuzz-document afl-as as afl-g++ afl-clang afl-clang++ *.o src/*.o *~ a.out core core.[1-9][0-9]* *.stackdump .test .test1 .test2 test-instr .test-instr0 .test-instr1 afl-cs-proxy afl-qemu-trace afl-gcc-fast afl-g++-fast ld *.so *.8 test/unittests/*.o test/unittests/unit_maybe_alloc test/unittests/preallocable .afl-* afl-gcc afl-g++ afl-clang afl-clang++ test/unittests/unit_hash test/unittests/unit_rand *.dSYM lib*.a
- -$(MAKE) -f GNUmakefile.llvm clean
- -$(MAKE) -f GNUmakefile.gcc_plugin clean
- -$(MAKE) -C utils/libdislocator clean
- -$(MAKE) -C utils/libtokencap clean
-+ $(MAKE) -f GNUmakefile.llvm clean
-+ $(MAKE) -f GNUmakefile.gcc_plugin clean
-+ $(MAKE) -C utils/libdislocator clean
-+ $(MAKE) -C utils/libtokencap clean
- $(MAKE) -C utils/aflpp_driver clean
+- -$(MAKE) -C utils/aflpp_driver clean
- -$(MAKE) -C utils/afl_network_proxy clean
- -$(MAKE) -C utils/socket_fuzzing clean
- -$(MAKE) -C utils/argv_fuzzing clean
@@ -39,6 +41,11 @@ https://bugs.gentoo.org/800941
- -$(MAKE) -C qemu_mode/libcompcov clean
- -$(MAKE) -C qemu_mode/libqasan clean
- -$(MAKE) -C frida_mode clean
++ $(MAKE) -f GNUmakefile.llvm clean
++ $(MAKE) -f GNUmakefile.gcc_plugin clean
++ $(MAKE) -C utils/libdislocator clean
++ $(MAKE) -C utils/libtokencap clean
++ $(MAKE) -C utils/aflpp_driver clean
+ $(MAKE) -C utils/afl_network_proxy clean
+ $(MAKE) -C utils/socket_fuzzing clean
+ $(MAKE) -C utils/argv_fuzzing clean
@@ -50,54 +57,85 @@ https://bugs.gentoo.org/800941
rm -rf nyx_mode/packer/linux_initramfs/init.cpio.gz nyx_mode/libnyx/libnyx/target/release/* nyx_mode/QEMU-Nyx/x86_64-softmmu/qemu-system-x86_64
ifeq "$(IN_REPO)" "1"
-test -e coresight_mode/coresight-trace/Makefile && $(MAKE) -C coresight_mode/coresight-trace clean || true
-@@ -607,20 +607,20 @@ endif
+@@ -613,21 +613,21 @@ endif
.PHONY: distrib
distrib: all
-- -$(MAKE) -j4 -f GNUmakefile.llvm
-+ $(MAKE) -j4 -f GNUmakefile.llvm
+- -$(MAKE) -j$(nproc) -f GNUmakefile.llvm
++ $(MAKE) -f GNUmakefile.llvm
ifneq "$(SYS)" "Darwin"
- -$(MAKE) -f GNUmakefile.gcc_plugin
+-endif
+- -$(MAKE) -C utils/libdislocator
+- -$(MAKE) -C utils/libtokencap
+- -$(MAKE) -C utils/afl_network_proxy
+- -$(MAKE) -C utils/socket_fuzzing
+- -$(MAKE) -C utils/argv_fuzzing
+- # -$(MAKE) -C utils/plot_ui
+- -$(MAKE) -C frida_mode
+ $(MAKE) -f GNUmakefile.gcc_plugin
++endif
++ $(MAKE) -C utils/libdislocator
++ $(MAKE) -C utils/libtokencap
++ $(MAKE) -C utils/afl_network_proxy
++ $(MAKE) -C utils/socket_fuzzing
++ $(MAKE) -C utils/argv_fuzzing
++ # $(MAKE) -C utils/plot_ui
++ $(MAKE) -C frida_mode
+ ifneq "$(SYS)" "Darwin"
+ ifeq "$(ARCH)" "aarch64"
+ ifndef NO_CORESIGHT
+- -$(MAKE) -C coresight_mode
++ $(MAKE) -C coresight_mode
+ endif
endif
+ ifeq "$(SYS)" "Linux"
+@@ -647,17 +647,17 @@ endif
+
+ .PHONY: binary-only
+ binary-only: test_shm test_python ready $(PROGS)
- -$(MAKE) -C utils/libdislocator
- -$(MAKE) -C utils/libtokencap
- -$(MAKE) -C utils/afl_network_proxy
- -$(MAKE) -C utils/socket_fuzzing
- -$(MAKE) -C utils/argv_fuzzing
+- # -$(MAKE) -C utils/plot_ui
+- -$(MAKE) -C frida_mode
+ $(MAKE) -C utils/libdislocator
+ $(MAKE) -C utils/libtokencap
+ $(MAKE) -C utils/afl_network_proxy
+ $(MAKE) -C utils/socket_fuzzing
+ $(MAKE) -C utils/argv_fuzzing
- # -$(MAKE) -C utils/plot_ui
-- -$(MAKE) -C frida_mode
++ # $(MAKE) -C utils/plot_ui
+ $(MAKE) -C frida_mode
ifneq "$(SYS)" "Darwin"
ifeq "$(ARCH)" "aarch64"
+ ifndef NO_CORESIGHT
- -$(MAKE) -C coresight_mode
+ $(MAKE) -C coresight_mode
+ endif
endif
ifeq "$(SYS)" "Linux"
- -cd nyx_mode && ./build_nyx_support.sh
-@@ -651,12 +651,12 @@ endif
+@@ -677,13 +677,13 @@ endif
.PHONY: source-only
source-only: all
-- -$(MAKE) -j4 -f GNUmakefile.llvm
-+ $(MAKE) -j4 -f GNUmakefile.llvm
+- -$(MAKE) -j$(nproc) -f GNUmakefile.llvm
++ $(MAKE) -f GNUmakefile.llvm
ifneq "$(SYS)" "Darwin"
- -$(MAKE) -f GNUmakefile.gcc_plugin
+ $(MAKE) -f GNUmakefile.gcc_plugin
endif
- -$(MAKE) -C utils/libdislocator
- -$(MAKE) -C utils/libtokencap
+- # -$(MAKE) -C utils/plot_ui
+ $(MAKE) -C utils/libdislocator
+ $(MAKE) -C utils/libtokencap
- # -$(MAKE) -C utils/plot_ui
++ # $(MAKE) -C utils/plot_ui
ifeq "$(SYS)" "Linux"
+ ifndef NO_NYX
-cd nyx_mode && ./build_nyx_support.sh
-@@ -702,9 +702,9 @@ install: all $(MANPAGES)
+@@ -731,9 +731,9 @@ install: all $(MANPAGES)
@if [ -f utils/afl_network_proxy/afl-network-server ]; then $(MAKE) -C utils/afl_network_proxy install; fi
@if [ -f utils/aflpp_driver/libAFLDriver.a ]; then set -e; install -m 644 utils/aflpp_driver/libAFLDriver.a $${DESTDIR}$(HELPER_PATH); fi
@if [ -f utils/aflpp_driver/libAFLQemuDriver.a ]; then set -e; install -m 644 utils/aflpp_driver/libAFLQemuDriver.a $${DESTDIR}$(HELPER_PATH); fi
@@ -109,13 +147,3 @@ https://bugs.gentoo.org/800941
endif
ln -sf afl-cc $${DESTDIR}$(BIN_PATH)/afl-gcc
ln -sf afl-cc $${DESTDIR}$(BIN_PATH)/afl-g++
---- a/GNUmakefile.llvm
-+++ b/GNUmakefile.llvm
-@@ -457,6 +457,7 @@ document:
- test_build: $(PROGS)
- @echo "[*] Testing the CC wrapper and instrumentation output..."
- unset AFL_USE_ASAN AFL_USE_MSAN AFL_INST_RATIO; ASAN_OPTIONS=detect_leaks=0 AFL_QUIET=1 AFL_PATH=. AFL_LLVM_LAF_ALL=1 ./afl-cc $(CFLAGS) $(CPPFLAGS) ./test-instr.c -o test-instr $(LDFLAGS)
-+ @test -e test-instr || { echo "[-] Testing CC wrapper failed. You seem not to have a working compiler." ; exit 1; }
- ASAN_OPTIONS=detect_leaks=0 ./afl-showmap -m none -q -o .test-instr0 ./test-instr < /dev/null
- echo 1 | ASAN_OPTIONS=detect_leaks=0 ./afl-showmap -m none -q -o .test-instr1 ./test-instr
- @rm -f test-instr
diff --git a/app-forensics/aflplusplus/files/aflplusplus-4.02c-respect-flags.patch b/app-forensics/aflplusplus/files/aflplusplus-4.02c-respect-flags.patch
new file mode 100644
index 000000000000..65748a51c723
--- /dev/null
+++ b/app-forensics/aflplusplus/files/aflplusplus-4.02c-respect-flags.patch
@@ -0,0 +1,200 @@
+* Respect AR, CC, CFLAGS, CPPFLAGS, LDFLAGS everywhere when building.
+* Ignore build flags then when testing the CC wrappers (could contain
+ incompatible flags).
+* Disable LTO for runtime objects, these shouldn't contain IR.
+
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -426,7 +426,7 @@ afl-as: src/afl-as.c include/afl-as.h $(COMM_HDR) | test_x86
+ @ln -sf afl-as as
+
+ src/afl-performance.o : $(COMM_HDR) src/afl-performance.c include/hash.h
+- $(CC) $(CFLAGS) $(CFLAGS_OPT) -Iinclude -c src/afl-performance.c -o src/afl-performance.o
++ $(CC) $(CFLAGS) -Iinclude -c src/afl-performance.c -o src/afl-performance.o
+
+ src/afl-common.o : $(COMM_HDR) src/afl-common.c include/common.h
+ $(CC) $(CFLAGS) $(CFLAGS_FLTO) -c src/afl-common.c -o src/afl-common.o
+@@ -534,7 +534,7 @@ code-format:
+ ifndef AFL_NO_X86
+ test_build: afl-cc afl-gcc afl-as afl-showmap
+ @echo "[*] Testing the CC wrapper afl-cc and its instrumentation output..."
+- @unset AFL_MAP_SIZE AFL_USE_UBSAN AFL_USE_CFISAN AFL_USE_LSAN AFL_USE_ASAN AFL_USE_MSAN; ASAN_OPTIONS=detect_leaks=0 AFL_INST_RATIO=100 AFL_PATH=. ./afl-cc test-instr.c $(LDFLAGS) -o test-instr 2>&1 || (echo "Oops, afl-cc failed"; exit 1 )
++ @unset AFL_MAP_SIZE AFL_USE_UBSAN AFL_USE_CFISAN AFL_USE_LSAN AFL_USE_ASAN AFL_USE_MSAN; ASAN_OPTIONS=detect_leaks=0 AFL_INST_RATIO=100 AFL_PATH=. ./afl-cc test-instr.c -o test-instr 2>&1 || (echo "Oops, afl-cc failed"; exit 1 )
+ ASAN_OPTIONS=detect_leaks=0 ./afl-showmap -m none -q -o .test-instr0 ./test-instr < /dev/null
+ echo 1 | ASAN_OPTIONS=detect_leaks=0 ./afl-showmap -m none -q -o .test-instr1 ./test-instr
+ @rm -f test-instr
+--- a/GNUmakefile.gcc_plugin
++++ b/GNUmakefile.gcc_plugin
+@@ -133,20 +133,20 @@ afl-common.o: ./src/afl-common.c
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@ $(LDFLAGS)
+
+ ./afl-compiler-rt.o: instrumentation/afl-compiler-rt.o.c
+- $(CC) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -fPIC -c $< -o $@
++ $(CC) $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -fPIC -fno-lto -c $< -o $@
+
+ ./afl-compiler-rt-32.o: instrumentation/afl-compiler-rt.o.c
+ @printf "[*] Building 32-bit variant of the runtime (-m32)... "
+- @$(CC) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -m32 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
++ @$(CC) $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -m32 -fPIC -fno-lto -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
+
+ ./afl-compiler-rt-64.o: instrumentation/afl-compiler-rt.o.c
+ @printf "[*] Building 64-bit variant of the runtime (-m64)... "
+- @$(CC) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -m64 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
++ @$(CC) $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -m64 -fPIC -fno-lto -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
+
+ $(PASSES): instrumentation/afl-gcc-common.h
+
+ ./afl-gcc-pass.so: instrumentation/afl-gcc-pass.so.cc | test_deps
+- $(CXX) $(CXXEFLAGS) $(PLUGIN_FLAGS) -shared $< -o $@
++ $(CXX) $(CXXEFLAGS) $(PLUGIN_FLAGS) -shared $< -o $@ $(LDFLAGS)
+ ln -sf afl-cc afl-gcc-fast
+ ln -sf afl-cc afl-g++-fast
+ ln -sf afl-cc.8 afl-gcc-fast.8
+--- a/GNUmakefile.llvm
++++ b/GNUmakefile.llvm
+@@ -410,7 +410,7 @@ endif
+
+ ./afl-ld-lto: src/afl-ld-lto.c
+ ifeq "$(LLVM_LTO)" "1"
+- $(CC) $(CFLAGS) $(CPPFLAGS) $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $< -o $@
+ endif
+
+ ./SanitizerCoverageLTO.so: instrumentation/SanitizerCoverageLTO.so.cc instrumentation/afl-llvm-common.o
+@@ -444,25 +444,25 @@ afl-llvm-dict2file.so: instrumentation/afl-llvm-dict2file.so.cc instrumentation/
+
+ .PHONY: document
+ document:
+- $(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -O3 -Wno-unused-result -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt.o
+- @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -O3 -Wno-unused-result -m32 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-32.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
+- @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -O3 -Wno-unused-result -m64 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-64.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
++ $(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -Wno-unused-result -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt.o
++ @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -Wno-unused-result -m32 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-32.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
++ @$(CLANG_BIN) -D_AFL_DOCUMENT_MUTATIONS $(CFLAGS) $(CFLAGS_SAFE) $(CPPFLAGS) $(CLANG_CFL) -Wno-unused-result -m64 -fPIC -c instrumentation/afl-compiler-rt.o.c -o ./afl-compiler-rt-64.o 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
+
+ ./afl-compiler-rt.o: instrumentation/afl-compiler-rt.o.c
+- $(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -fPIC -c $< -o $@
++ $(CC) $(CFLAGS) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -fPIC -fno-lto -c $< -o $@
+
+ ./afl-compiler-rt-32.o: instrumentation/afl-compiler-rt.o.c
+ @printf "[*] Building 32-bit variant of the runtime (-m32)... "
+- @$(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -m32 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
++ @$(CC) $(CFLAGS) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -m32 -fPIC -fno-lto -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
+
+ ./afl-compiler-rt-64.o: instrumentation/afl-compiler-rt.o.c
+ @printf "[*] Building 64-bit variant of the runtime (-m64)... "
+- @$(CC) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -O3 -Wno-unused-result -m64 -fPIC -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
++ @$(CC) $(CFLAGS) $(CLANG_CFL) $(CFLAGS_SAFE) $(CPPFLAGS) -Wno-unused-result -m64 -fPIC -fno-lto -c $< -o $@ 2>/dev/null; if [ "$$?" = "0" ]; then echo "success!"; else echo "failed (that's fine)"; fi
+
+ .PHONY: test_build
+ test_build: $(PROGS)
+ @echo "[*] Testing the CC wrapper and instrumentation output..."
+- unset AFL_USE_ASAN AFL_USE_MSAN AFL_INST_RATIO; ASAN_OPTIONS=detect_leaks=0 AFL_QUIET=1 AFL_PATH=. AFL_LLVM_LAF_ALL=1 ./afl-cc $(CFLAGS) $(CPPFLAGS) ./test-instr.c -o test-instr $(LDFLAGS)
++ unset AFL_USE_ASAN AFL_USE_MSAN AFL_INST_RATIO; ASAN_OPTIONS=detect_leaks=0 AFL_QUIET=1 AFL_PATH=. AFL_LLVM_LAF_ALL=1 ./afl-cc ./test-instr.c -o test-instr
+ ASAN_OPTIONS=detect_leaks=0 ./afl-showmap -m none -q -o .test-instr0 ./test-instr < /dev/null
+ echo 1 | ASAN_OPTIONS=detect_leaks=0 ./afl-showmap -m none -q -o .test-instr1 ./test-instr
+ @rm -f test-instr
+--- a/custom_mutators/honggfuzz/Makefile
++++ b/custom_mutators/honggfuzz/Makefile
+@@ -1,5 +1,6 @@
+
+-CFLAGS = -O3 -funroll-loops -fPIC -Wl,-Bsymbolic
++CFLAGS ?= -O3
++CFLAGS += -funroll-loops -fPIC -Wl,-Bsymbolic
+
+ all: honggfuzz-mutator.so
+
+--- a/custom_mutators/libfuzzer/Makefile
++++ b/custom_mutators/libfuzzer/Makefile
+@@ -1,6 +1,6 @@
+
+-CFLAGS = -g -O3 -funroll-loops -fPIC -fpermissive -std=c++11
+-#CFLAGS = -g -O0 -fPIC -fpermissive -std=c++11
++CFLAGS ?= -g -O3
++CFLAGS += -funroll-loops -fpermissive -std=c++11 -fPIC
+ CXX ?= clang++
+
+ ifdef INTROSPECTION
+--- a/frida_mode/GNUmakefile
++++ b/frida_mode/GNUmakefile
+@@ -27,7 +27,6 @@ CFLAGS+=-fPIC \
+ -D_GNU_SOURCE \
+ -D_FORTIFY_SOURCE=2 \
+ -g \
+- -O3 \
+ -funroll-loops \
+ -ffunction-sections \
+
+--- a/frida_mode/test/png/persistent/hook/GNUmakefile
++++ b/frida_mode/test/png/persistent/hook/GNUmakefile
+@@ -5,11 +5,9 @@ BUILD_DIR:=$(PWD)build/
+ AFLPP_FRIDA_DRIVER_HOOK_OBJ=$(ROOT)frida_mode/build/frida_hook.so
+ AFLPP_QEMU_DRIVER_HOOK_OBJ=$(ROOT)frida_mode/build/qemu_hook.so
+
+-CFLAGS+=-O3 \
+- -funroll-loops \
++CFLAGS+= -funroll-loops \
+ -g \
+- -fPIC \
+- -funroll-loops \
++ -fPIC
+
+ LDFLAGS+=-shared \
+
+--- a/utils/aflpp_driver/GNUmakefile
++++ b/utils/aflpp_driver/GNUmakefile
+@@ -13,40 +13,42 @@ ifneq "" "$(LLVM_BINDIR)"
+ LLVM_BINDIR := $(LLVM_BINDIR)/
+ endif
+
+-CFLAGS := -O3 -funroll-loops -g -fPIC
++AR ?= ar
++CFLAGS ?= -O3 -funroll-loops -g
++CFLAGS += -fPIC -fno-lto
+
+ all: libAFLDriver.a libAFLQemuDriver.a aflpp_qemu_driver_hook.so
+
+ aflpp_driver.o: aflpp_driver.c
+- -$(LLVM_BINDIR)clang -I. -I../../include $(CFLAGS) -c aflpp_driver.c
++ $(CC) $(CPPFLAGS) -I. -I../../include $(CFLAGS) -c aflpp_driver.c
+
+ libAFLDriver.a: aflpp_driver.o
+- @ar rc libAFLDriver.a aflpp_driver.o
++ $(AR) rc libAFLDriver.a aflpp_driver.o
+ @cp -vf libAFLDriver.a ../../
+
+ debug:
+- $(LLVM_BINDIR)clang -Wno-deprecated -I../../include $(CFLAGS) -D_DEBUG=\"1\" -c -o afl-performance.o ../../src/afl-performance.c
+- $(LLVM_BINDIR)clang -I../../include -D_DEBUG=\"1\" -g -funroll-loops -c aflpp_driver.c
++ $(CC) $(CPPFLAGS) -Wno-deprecated -I../../include $(CFLAGS) -D_DEBUG=\"1\" -c -o afl-performance.o ../../src/afl-performance.c
++ $(CC) $(CPPFLAGS) -I../../include -D_DEBUG=\"1\" $(CFLAGS) -g -funroll-loops -c aflpp_driver.c
+ #$(LLVM_BINDIR)clang -S -emit-llvm -Wno-deprecated -I../../include $(CFLAGS) -D_DEBUG=\"1\" -c -o afl-performance.ll ../../src/afl-performance.c
+ #$(LLVM_BINDIR)clang -S -emit-llvm -I../../include -D_DEBUG=\"1\" -g -funroll-loops -c aflpp_driver.c
+- ar rc libAFLDriver.a afl-performance.o aflpp_driver.o
++ $(AR) rc libAFLDriver.a afl-performance.o aflpp_driver.o
+
+ aflpp_qemu_driver.o: aflpp_qemu_driver.c
+- -$(LLVM_BINDIR)clang $(CFLAGS) -O0 -funroll-loops -c aflpp_qemu_driver.c
++ $(CC) $(CPPFLAGS) $(CFLAGS) -O0 -funroll-loops -c aflpp_qemu_driver.c
+
+ libAFLQemuDriver.a: aflpp_qemu_driver.o
+- @-ar rc libAFLQemuDriver.a aflpp_qemu_driver.o
+- @-cp -vf libAFLQemuDriver.a ../../
++ $(AR) rc libAFLQemuDriver.a aflpp_qemu_driver.o
++ @cp -vf libAFLQemuDriver.a ../../
+
+ aflpp_qemu_driver_hook.so: aflpp_qemu_driver_hook.o
+- @-test -e aflpp_qemu_driver_hook.o && $(LLVM_BINDIR)clang $(LDFLAGS) -shared aflpp_qemu_driver_hook.o -o aflpp_qemu_driver_hook.so || echo "Note: Optional aflpp_qemu_driver_hook.so not built."
++ @test -e aflpp_qemu_driver_hook.o && $(CC) $(LDFLAGS) -shared aflpp_qemu_driver_hook.o -o aflpp_qemu_driver_hook.so || echo "Note: Optional aflpp_qemu_driver_hook.so not built."
+
+ aflpp_qemu_driver_hook.o: aflpp_qemu_driver_hook.c
+- @-test -e ../../qemu_mode/qemuafl/qemuafl/api.h && $(LLVM_BINDIR)clang $(CFLAGS) -funroll-loops -c aflpp_qemu_driver_hook.c || echo "Note: Optional aflpp_qemu_driver_hook.o not built."
++ @test -e ../../qemu_mode/qemuafl/qemuafl/api.h && $(CC) $(CPPFLAGS) $(CFLAGS) -funroll-loops -c aflpp_qemu_driver_hook.c || echo "Note: Optional aflpp_qemu_driver_hook.o not built."
+
+ test: debug
+ #clang -S -emit-llvm -D_DEBUG=\"1\" -I../../include -Wl,--allow-multiple-definition -funroll-loops -o aflpp_driver_test.ll aflpp_driver_test.c
+- afl-clang-fast -D_DEBUG=\"1\" -I../../include -Wl,--allow-multiple-definition -funroll-loops -o aflpp_driver_test aflpp_driver_test.c libAFLDriver.a afl-performance.o
++ ../../afl-clang-fast -D_DEBUG=\"1\" -I../../include -Wl,--allow-multiple-definition -funroll-loops -o aflpp_driver_test aflpp_driver_test.c libAFLDriver.a afl-performance.o
+
+ clean:
+ rm -f *.o libAFLDriver*.a libAFLQemuDriver.a aflpp_qemu_driver_hook.so *~ core aflpp_driver_test