summaryrefslogtreecommitdiff
path: root/app-forensics/foremost/foremost-1.5.7-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /app-forensics/foremost/foremost-1.5.7-r3.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'app-forensics/foremost/foremost-1.5.7-r3.ebuild')
-rw-r--r--app-forensics/foremost/foremost-1.5.7-r3.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/app-forensics/foremost/foremost-1.5.7-r3.ebuild b/app-forensics/foremost/foremost-1.5.7-r3.ebuild
index 56cdeee6ed5d..c3742c315533 100644
--- a/app-forensics/foremost/foremost-1.5.7-r3.ebuild
+++ b/app-forensics/foremost/foremost-1.5.7-r3.ebuild
@@ -1,32 +1,38 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
-DESCRIPTION="A console program to recover files based on their headers and footers"
+DESCRIPTION="Console program to recover files based on their headers and footers"
HOMEPAGE="http://foremost.sourceforge.net/"
#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
# starting to hate sf.net ...
SRC_URI="http://foremost.sourceforge.net/pkg/${P}.tar.gz"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
LICENSE="public-domain"
SLOT="0"
-PATCHES=("${FILESDIR}/${PN}-1.4-config-location.patch"
- "${FILESDIR}/${PN}-1.5.7-format-security.patch"
- "${FILESDIR}/${PN}-1.5.7-set-but-unused.patch")
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4-config-location.patch"
+ "${FILESDIR}/${PN}-1.5.7-format-security.patch" # bug 521038
+ "${FILESDIR}/${PN}-1.5.7-set-but-unused.patch" # bug 706886
+ "${FILESDIR}/${PN}-1.5.7-fno-common.patch" # bug 722196
+)
src_compile() {
- emake RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
+ emake \
+ RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" \
+ RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
CONF=/etc
}
src_install() {
dobin foremost
- gunzip foremost.8.gz
+ gunzip foremost.8.gz || die
doman foremost.8
insinto /etc
doins foremost.conf