summaryrefslogtreecommitdiff
path: root/app-forensics/honggfuzz/honggfuzz-2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-forensics/honggfuzz/honggfuzz-2.5.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-forensics/honggfuzz/honggfuzz-2.5.ebuild')
-rw-r--r--app-forensics/honggfuzz/honggfuzz-2.5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-forensics/honggfuzz/honggfuzz-2.5.ebuild b/app-forensics/honggfuzz/honggfuzz-2.5.ebuild
new file mode 100644
index 000000000000..db12e6d64274
--- /dev/null
+++ b/app-forensics/honggfuzz/honggfuzz-2.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A general purpose fuzzer with feedback support"
+HOMEPAGE="https://honggfuzz.dev/"
+SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="clang"
+
+RDEPEND="
+ >=sys-libs/binutils-libs-2.29:=
+ sys-libs/libunwind:=
+ app-arch/xz-utils
+ clang? ( sys-libs/blocksruntime )
+"
+
+DEPEND="${RDEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )"
+
+DOCS=(
+ CHANGELOG
+ COPYING
+ CONTRIBUTING.md
+ README.md
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-no-werror.patch
+)
+
+pkg_pretend() {
+ if tc-is-clang; then
+ use clang || die "${P}: to use clang enable USE=clang for ${P} (bug #729256)."
+ fi
+}
+
+src_prepare() {
+ default
+ tc-export AR CC
+ export CFLAGS
+ export LDFLAGS
+}
+
+src_install() {
+ dobin ${PN}
+ dobin hfuzz_cc/hfuzz-cc
+
+ einstalldocs
+}