summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-anthy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-anthy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-anthy')
-rw-r--r--app-i18n/fcitx-anthy/Manifest4
-rw-r--r--app-i18n/fcitx-anthy/fcitx-anthy-0.2.3.ebuild41
-rw-r--r--app-i18n/fcitx-anthy/fcitx-anthy-4.9999.ebuild41
-rw-r--r--app-i18n/fcitx-anthy/metadata.xml15
4 files changed, 101 insertions, 0 deletions
diff --git a/app-i18n/fcitx-anthy/Manifest b/app-i18n/fcitx-anthy/Manifest
new file mode 100644
index 000000000000..98b9aa35aecb
--- /dev/null
+++ b/app-i18n/fcitx-anthy/Manifest
@@ -0,0 +1,4 @@
+DIST fcitx-anthy-0.2.3.tar.xz 78020 BLAKE2B ae054f753dd7d10a0dafd80d67413c29806b6c3b08de9eac3d7eae1d540f01b7bafd22bd9c722a7fc517f1752d90c1c3d82e75aaf58a807daa60b7e9a047d152 SHA512 2769871059053fb370ba84af7cdf0c461d64724a240d58a5a8889cfd9bfb5d145998f79ed2d06a1ae1ab907f9db04fc122bfaf6957ef572fc833e400ffefc642
+EBUILD fcitx-anthy-0.2.3.ebuild 798 BLAKE2B 805bbb10e45fbd7369062b3eabe60b243e8756cc20ce32a2bc5ecd93ac032a0730391c3ef5a6f988661f816874034129d594c147150fb8d516f537049dd19314 SHA512 fcebed91625aa1384004afa91bdc9e3eff7f6f0a45ba242173d2405b89456efb43ce369b30df5f83c7300fa009ccb99501ed95df88b4eebf93cde1666ee6f394
+EBUILD fcitx-anthy-4.9999.ebuild 779 BLAKE2B 2b3f742f2c2de37be44351048092c61b01a872fff280e573838e6e5d710d0cb3fd0f557d9d1528704d9da8bcbad5418af06fc1c9edcb909e43df13e0d24049ff SHA512 b1a4fe8f93736658012905e027ddb665f4e6602bc4638333fa9af283b50b73a6f7b3b9a9a4a26dda2113131b712c818964b1d1a1ae45adaf94f91baea7b0a04a
+MISC metadata.xml 450 BLAKE2B f1d48fdccecc3112eceb62a5c60305b894fdc1ed0856fc176178ff3dbd2ca5a5125a9449cd51947a6e4478b5dd6cf817786824b5cc1841c1cd40f5bf9262e695 SHA512 2a104c976ff4336b60a5c14f49b56f634c808c5c73f8fad195028e2cc71c03e68384d315fb44e993c6ae22489e400759e3a0c11ab04f8e96d3d445a9beb97204
diff --git a/app-i18n/fcitx-anthy/fcitx-anthy-0.2.3.ebuild b/app-i18n/fcitx-anthy/fcitx-anthy-0.2.3.ebuild
new file mode 100644
index 000000000000..7f2661d3e6b3
--- /dev/null
+++ b/app-i18n/fcitx-anthy/fcitx-anthy-0.2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-anthy.git"
+fi
+
+DESCRIPTION="Japanese Anthy input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-anthy"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4[X,xml]
+ app-i18n/anthy:=
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-anthy/fcitx-anthy-4.9999.ebuild b/app-i18n/fcitx-anthy/fcitx-anthy-4.9999.ebuild
new file mode 100644
index 000000000000..a0729a41bd38
--- /dev/null
+++ b/app-i18n/fcitx-anthy/fcitx-anthy-4.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-anthy.git"
+fi
+
+DESCRIPTION="Japanese Anthy input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-anthy"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4[X,xml]
+ app-i18n/anthy:=
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/fcitx-anthy/metadata.xml b/app-i18n/fcitx-anthy/metadata.xml
new file mode 100644
index 000000000000..c29ae3fb402f
--- /dev/null
+++ b/app-i18n/fcitx-anthy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">fcitx/fcitx-anthy</remote-id>
+ </upstream>
+</pkgmetadata>