summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-chinese-addons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-11 04:04:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-11 04:04:15 +0100
commit61af1efe96cf1037982d2fc90af0749b5ec5a0c6 (patch)
treefd4966f3b19ef9b18ed5024d7e2f48ef73eb2fee /app-i18n/fcitx-chinese-addons
parent3aae425b3c39d02e2dc917db0fae8c225c158ca1 (diff)
gentoo auto-resync : 11:10:2024 - 04:04:14
Diffstat (limited to 'app-i18n/fcitx-chinese-addons')
-rw-r--r--app-i18n/fcitx-chinese-addons/Manifest2
-rw-r--r--app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.7.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chinese-addons/Manifest b/app-i18n/fcitx-chinese-addons/Manifest
index c7552cef607a..555172292d03 100644
--- a/app-i18n/fcitx-chinese-addons/Manifest
+++ b/app-i18n/fcitx-chinese-addons/Manifest
@@ -1,3 +1,5 @@
DIST fcitx5-chinese-addons-5.1.6_dict.tar.zst 1005756 BLAKE2B c3b3c12c3b269c71c7136ba140fa833fb28d4ff2698213aa47bdb3fe50ee65830a99c9591180ae0bfd2873c7d84013f26df895f2574372a64cdea9ea887cb052 SHA512 f130f4492977662916a1591048832a37ec306f3664a2c5bc5225ba220ea5ffebc3ef78022b2b6d2d8475b556285a0d45508eaf00473f5b636d2e56a7c73d2f38
+DIST fcitx5-chinese-addons-5.1.7_dict.tar.zst 1014942 BLAKE2B fb386dad971b2a8751202733ef593b72d35f9ab8a266f13e6839ea25010cf54e45c287e10d285a02d268f16b5b8f7a3dc6f6f20ffcc79759d8c1ef1136a29cb5 SHA512 fe04699672f034bde328049a19f23b9dbea75a980e706fcaf95138294b8aaaee54eb9ec5c696c343d5e4ce4788216821ad3eb45cd669d94d2f3b67551ae7360f
EBUILD fcitx-chinese-addons-5.1.6.ebuild 1495 BLAKE2B f94692ab04cdc2708e43dae50e9147aa5e44b271d44c352eaa7a367565b6b5bd6fef8a019c0f836d733fa678c1132c5c0fae60ca235ccd2064ae6e1026cb7c0a SHA512 93dde8f1f7acf8b0fcf89d235ce6022d1cc5d65aff2dd9b242a14e0aa4179ed06523150c93e536c6b867614859ab91317b08bb62721549524bd070e852ac571a
+EBUILD fcitx-chinese-addons-5.1.7.ebuild 1498 BLAKE2B a5b3d3d15e256df339b99719e0fb88cd3d670058af06adc9b8959d60bfeba8dd7dc9ed6da4c9f75a955d07002c449c1c4af369f4be4a0637117e038e4fb36752 SHA512 596360761de30e3b9a994f97d6d40a2c1007aad9cae9be19a198038e75b401fb1246b4f97497771f342235b631c2d3bbbcb83266901478a2a964e23063095455
MISC metadata.xml 993 BLAKE2B 034a9f1ca3966a67fb884f3e0ce6baeb83c3ccfb2b7d7d99d41e54ef30087c94d5a0c9729902e08eb8b781deeb71daf57b27f3d238beebf6e356e690aae7723b SHA512 05140cdf9695922cf2ddad40744d51d197fc3beab99ca7ba5d19b38a7c22762195f2e3a3c2e2ded46f253e1efeab06259429725830328c5f2001fe0752cd2b26
diff --git a/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.7.ebuild b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.7.ebuild
new file mode 100644
index 000000000000..35568fd1a173
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-chinese-addons"
+
+inherit cmake unpacker xdg
+
+DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
+HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}_dict.tar.zst"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+data +gui webengine +cloudpinyin +qt5 qt6 lua +opencc test"
+REQUIRED_USE="
+ webengine? ( gui )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.11:5
+ >=app-i18n/libime-1.1.7:5[data?]
+ >=dev-libs/boost-1.61:=
+ cloudpinyin? ( net-misc/curl )
+ lua? ( app-i18n/fcitx-lua:5 )
+ opencc? ( app-i18n/opencc:= )
+ gui? (
+ qt5? (
+ dev-qt/qtconcurrent:5
+ app-i18n/fcitx-qt:5[qt5,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ qt6? (
+ dev-qt/qtbase:6[concurrent]
+ app-i18n/fcitx-qt:5[qt6,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:6[widgets] )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BROWSER=$(usex webengine)
+ -DENABLE_CLOUDPINYIN=$(usex cloudpinyin)
+ -DENABLE_DATA=$(usex data)
+ -DENABLE_GUI=$(usex gui)
+ -DENABLE_OPENCC=$(usex opencc)
+ -DENABLE_TEST=$(usex test)
+ -DUSE_WEBKIT=no
+ -DUSE_QT6=$(usex qt6)
+ )
+ cmake_src_configure
+}