summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild')
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
new file mode 100644
index 000000000000..33805e7cbebd
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-configtool.git"
+fi
+
+DESCRIPTION="GTK+ GUI configuration tool for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-configtool"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="4"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GTK2=OFF
+ -DENABLE_GTK3=ON
+ )
+
+ cmake-utils_src_configure
+}