summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild')
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild b/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
index 273db4b0c27a..18b40399bbf0 100644
--- a/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
+++ b/app-i18n/fcitx-rime/fcitx-rime-0.3.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 2012-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
inherit git-r3
@@ -24,12 +24,13 @@ SLOT="4"
KEYWORDS="amd64 ppc ppc64 x86"
IUSE=""
-RDEPEND=">=app-i18n/fcitx-4.2.9:4
+BDEPEND=">=app-i18n/fcitx-4.2.9:4
+ virtual/pkgconfig"
+DEPEND=">=app-i18n/fcitx-4.2.9:4
>=app-i18n/librime-1.0.0:=
- app-i18n/rime-data
virtual/libintl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="${DEPEND}
+ app-i18n/rime-data"
DOCS=()
@@ -38,7 +39,7 @@ src_configure() {
-DRIME_DATA_DIR="${EPREFIX}/usr/share/rime-data"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {