summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-11 13:07:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-11 13:07:07 +0000
commiteb72a69c0109ff53b8c18b2f6c3b160489376e2e (patch)
tree6b1a11b63d1fa5f16537a183ee1800b8f0682d1b /app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild
parentafa7f3d7b9d6af29760049c9711a24821c77c8ec (diff)
gentoo auto-resync : 11:01:2024 - 13:07:07
Diffstat (limited to 'app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild')
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild b/app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild
new file mode 100644
index 000000000000..9285cd4196a8
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+MY_PN="fcitx5-rime"
+DESCRIPTION="Chinese RIME input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-rime"
+SRC_URI="https://download.fcitx-im.org/fcitx5/fcitx5-rime/fcitx5-rime-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=app-i18n/fcitx-5.1.2:5
+ app-i18n/librime
+ app-i18n/rime-data
+ virtual/libintl
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"