summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-unikey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-09 00:12:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-09 00:12:01 +0000
commitb95a6fd4a7b591baa7cfc689f8ce5643592d07be (patch)
tree6a7c4722b40bdb6c409879ce253d8b42817fec14 /app-i18n/fcitx-unikey
parent8b3c41ecef8a1cdd270ce3aabcfdfb991839699c (diff)
gentoo auto-resync : 09:02:2025 - 00:12:00
Diffstat (limited to 'app-i18n/fcitx-unikey')
-rw-r--r--app-i18n/fcitx-unikey/Manifest2
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-5.1.6.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/app-i18n/fcitx-unikey/Manifest b/app-i18n/fcitx-unikey/Manifest
index da51a5879660..c270bd1c8cba 100644
--- a/app-i18n/fcitx-unikey/Manifest
+++ b/app-i18n/fcitx-unikey/Manifest
@@ -1,3 +1,5 @@
DIST fcitx5-unikey-5.1.4.tar.zst 114482 BLAKE2B daa7cb04f2047e7495f4699c4b7abe711b96553f8339b6ed41f84e934239e935ba55110076fd177fe14a8a5f01b65090fb2bf517acef9d085af018879b10b75a SHA512 d8918222c37609c078bdf6d73a5acaa5ebaf23b4b49d253850c737ac659cee94956ee8782b3ac2ea6eaa5cfdb8fccec6a62e86d6b0a1b4f5b03c4a6e395ca3f0
+DIST fcitx5-unikey-5.1.6.tar.zst 114937 BLAKE2B 96c832dbea695f8d90910ae4a1d07c69a05fce5a2bc982f47dd4b2b4e0566607e76a9b8afbd769bf51317c080ab276feef4285b918f7e0e82375f09b0b97007f SHA512 05e13eb63fedc4dd6852c0fa42efd89ceba1f6d90a9d8d1c04547d0bc3877f46ebce4cfb0a495331d911401a070b10cc42d5d5af818cc9ba6c8923a87254e89c
EBUILD fcitx-unikey-5.1.4.ebuild 988 BLAKE2B 23f09dcbb0747b80ae7027f41e74a46b95e87b23ed85b9ce4153bb43cfbe54717c605861aa0b39660394586fdee39482f50cbfd6bde7ca4b6d8758ec80dcb448 SHA512 022d6d31c01c745db211ea535aa043a35550f0216e1949313cb4cb31dfc9eb891f10cd383e13260463400abec81d3674d9371925a643de7bd7ba2dbe5364a477
+EBUILD fcitx-unikey-5.1.6.ebuild 993 BLAKE2B ff6488a97cd6e1b5e43074c15a4eba849e8495c260cc82108e2b9e5de128b73dfcc9dd82999e1a3839c24ac78e0e47b1bfc70400811421997520a94b01a797c2 SHA512 927ace6c1c423a06707f7f82a2f4c652a6261948472795145e42db85b6af2e9d9ade58f3d8242a093a9860069be74b7c697d3e59bc8672ae9971a082acefd812
MISC metadata.xml 578 BLAKE2B 9f9b8caae9b94cd5a0324bd2a5f1cf67b5d6be173d5a0b10e30119cfbcf0f7416a7aa018049cb9abd392b416f5765b49fa555c1e5ebaf5ab8bcafa3ca0135db2 SHA512 691eb90302e2ad201015fa7f206ae551618fc531ef756c45ebd1792c635d1a483ff890dca0a9a9d84c2b2de8752bc9adc5facc8942c75394ebe5ce9e26862e85
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-5.1.6.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-5.1.6.ebuild
new file mode 100644
index 000000000000..6536fa939b23
--- /dev/null
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-5.1.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-unikey"
+
+inherit cmake unpacker xdg
+
+DESCRIPTION="Unikey (Vietnamese Input Method) engine support for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-unikey"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.zst"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gui +qt5 qt6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.12:5
+ >=app-i18n/fcitx-qt-5.0.12[qt5?,qt6?,-onlyplugin]
+ gui? (
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ )
+ qt6? (
+ dev-qt/qtbase:6[dbus,gui,widgets]
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=( )
+ if use gui; then
+ mycmakeargs+=(
+ -DENABLE_QT=ON
+ -DUSE_QT6=$(usex qt6)
+ )
+ fi
+ cmake_src_configure
+}