summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild')
-rw-r--r--app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild b/app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild
new file mode 100644
index 000000000000..f7446f6ad8ae
--- /dev/null
+++ b/app-i18n/ibus-cangjie/ibus-cangjie-2.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit gnome2-utils python-r1
+
+DESCRIPTION="Chinese Cangjie and Quick engines for IBus"
+HOMEPAGE="http://cangjians.github.io/"
+SRC_URI="https://github.com/Cangjians/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ app-i18n/libcangjie
+ dev-python/cangjie[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ python_foreach_impl default
+}
+
+src_compile() {
+ python_foreach_impl default
+}
+
+src_install() {
+ python_foreach_impl default
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}