summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-typing-booster
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/ibus-typing-booster
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest5
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-1.5.38.ebuild32
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild32
-rw-r--r--app-i18n/ibus-typing-booster/metadata.xml11
4 files changed, 80 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
new file mode 100644
index 000000000000..9d60cf325bdb
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -0,0 +1,5 @@
+DIST ibus-typing-booster-1.5.38.tar.gz 6408096 BLAKE2B a4559044a4cd06c5dcf69d77d5ec3d8163d564702ff88d3ed11b8c073f5272e2cfab446de548a29887b74767f4318db98fb898dc4d15488fd4c9963cea151009 SHA512 67b81a47501ae4e885d2a79b122799b78dcdd044ad8e36a140d4c6587a23072d08e3e025f755c191cee82c3ab81ea1a974a5a0f6438e7203ba2d63d7e1cd4eff
+DIST ibus-typing-booster-2.0.0.tar.gz 5689495 BLAKE2B a3ee39faf206c4681d10989d4e438cffc0b78d9339973523af61310482b3ec13c7935e9e49403a3359e0f32d087b72afb27ae7975dcd3abd427b9a0f5f0ba581 SHA512 140044be13b47590a0835bb4b8da7311cdb92e8134a88a7b999ea6f530298950c4f8ce9ff3462394e4b52de0c56e3072671da85c99b448a91f442fdc460c608b
+EBUILD ibus-typing-booster-1.5.38.ebuild 860 BLAKE2B 7b813a51e80a378e694d3b9d6c3268e7d32d497d9fd62fa78f5239dbe1025dc79ccbfa958d2fdfc7e73be9dbe8bbb75efa29e4a12e41ec679b2efafd94a8e065 SHA512 fa03b6fb55e7505dd13e4aaf830444ea8f25c19089901528c4646611193f8002a0e860f09ba0bc5ca44c5e5cacbde1c3002220ee7e323239ca7c580c5216be2e
+EBUILD ibus-typing-booster-2.0.0.ebuild 860 BLAKE2B 7b813a51e80a378e694d3b9d6c3268e7d32d497d9fd62fa78f5239dbe1025dc79ccbfa958d2fdfc7e73be9dbe8bbb75efa29e4a12e41ec679b2efafd94a8e065 SHA512 fa03b6fb55e7505dd13e4aaf830444ea8f25c19089901528c4646611193f8002a0e860f09ba0bc5ca44c5e5cacbde1c3002220ee7e323239ca7c580c5216be2e
+MISC metadata.xml 331 BLAKE2B 85b93b548e9cbef93b09e59ebf23c10b1cb4c392bcb6aeeab697cdaa775afa06874b5a6965ab09ffd8c937a0842699cdb27ad70c6146d5c37b516d82a92c80b2 SHA512 e0524c2ebad138f51a5d79d639e809196029a83f46dc331c2bd21d94417d5adf8d059f15694b484f4fcb107dff2aba7d3ad4c87a19accaccf75429bfa2c92b63
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-1.5.38.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-1.5.38.ebuild
new file mode 100644
index 000000000000..b4bb8048b30d
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-1.5.38.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-libs/m17n-lib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild
new file mode 100644
index 000000000000..b4bb8048b30d
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-libs/m17n-lib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
diff --git a/app-i18n/ibus-typing-booster/metadata.xml b/app-i18n/ibus-typing-booster/metadata.xml
new file mode 100644
index 000000000000..bd6b0e5b1eb3
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <longdescription lang="en">
+ A completion input method for IBus.
+ </longdescription>
+</pkgmetadata>