summaryrefslogtreecommitdiff
path: root/app-i18n/libchewing/libchewing-0.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /app-i18n/libchewing/libchewing-0.5.1.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'app-i18n/libchewing/libchewing-0.5.1.ebuild')
-rw-r--r--app-i18n/libchewing/libchewing-0.5.1.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/app-i18n/libchewing/libchewing-0.5.1.ebuild b/app-i18n/libchewing/libchewing-0.5.1.ebuild
index 4a2f116c20e0..1c78e61d60e1 100644
--- a/app-i18n/libchewing/libchewing-0.5.1.ebuild
+++ b/app-i18n/libchewing/libchewing-0.5.1.ebuild
@@ -3,8 +3,11 @@
EAPI="7"
+inherit autotools
+
if [[ "${PV}" == "9999" ]]; then
- inherit autotools git-r3
+# inherit autotools git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/chewing/libchewing"
fi
@@ -27,12 +30,17 @@ RDEPEND="dev-db/sqlite:3"
DEPEND="${RDEPEND}
test? ( sys-libs/ncurses[unicode] )"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.5.1-autoconf-archive-2019.01.06.patch"
+)
+
src_prepare() {
default
+ eautoreconf
- if [[ "${PV}" == "9999" ]]; then
- eautoreconf
- fi
+# if [[ "${PV}" == "9999" ]]; then
+# eautoreconf
+# fi
}
src_configure() {
@@ -48,6 +56,8 @@ src_test() {
src_install() {
default
- find "${D}" -name "*.la" -delete || die
- use static-libs || find "${D}" -name "*.a" -delete || die
+ find "${D}" -name "*.la" -type f -delete || die
+ if ! use static-libs; then
+ find "${D}" -name "*.a" -type f -delete || die
+ fi
}