summaryrefslogtreecommitdiff
path: root/app-i18n/libhangul/libhangul-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /app-i18n/libhangul/libhangul-0.1.0.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'app-i18n/libhangul/libhangul-0.1.0.ebuild')
-rw-r--r--app-i18n/libhangul/libhangul-0.1.0.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/app-i18n/libhangul/libhangul-0.1.0.ebuild b/app-i18n/libhangul/libhangul-0.1.0.ebuild
index ec22b8af6eca..f8ec424da315 100644
--- a/app-i18n/libhangul/libhangul-0.1.0.ebuild
+++ b/app-i18n/libhangul/libhangul-0.1.0.ebuild
@@ -1,24 +1,25 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI="6"
-DESCRIPTION="libhangul is a generalized and portable library for processing hangul"
-HOMEPAGE="https://code.google.com/p/libhangul/"
+DESCRIPTION="Library for hangul input method logic, hanja dictionary"
+HOMEPAGE="https://github.com/choehwanjin/libhangul"
SRC_URI="https://libhangul.googlecode.com/files/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
+LICENSE="LGPL-2.1+"
+SLOT="0/1"
KEYWORDS="amd64 ppc ppc64 x86"
IUSE="nls static-libs test"
-RDEPEND="nls? ( virtual/libintl )"
+RDEPEND="virtual/libiconv
+ nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )
test? ( dev-libs/check )"
-DOCS="AUTHORS ChangeLog NEWS README"
+DOCS=(AUTHORS ChangeLog NEWS)
src_configure() {
econf \
@@ -26,7 +27,11 @@ src_configure() {
$(use_enable static-libs static)
}
+src_test() {
+ emake -C test check
+}
+
src_install() {
default
- rm -f "${ED}"/usr/lib*/libhangul.la
+ find "${D}" -name "*.la" -delete || die
}