summaryrefslogtreecommitdiff
path: root/app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild')
-rw-r--r--app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild b/app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild
new file mode 100644
index 000000000000..ef7e788c0ad6
--- /dev/null
+++ b/app-i18n/man-pages-pl/man-pages-pl-0.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PKG=manpages-pl-${PV}
+
+DESCRIPTION="A collection of Polish translations of Linux manual pages"
+HOMEPAGE="https://sourceforge.net/projects/manpages-pl/"
+SRC_URI="mirror://sourceforge/manpages-pl/${MY_PKG}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+
+DOCS=( AUTHORS README )
+
+S="${WORKDIR}/${MY_PKG}"
+
+src_prepare() {
+ default
+
+ #mans provided by other packages
+ rm generated/man1/{free,groups,uptime}.1 \
+ po/man1/{free,groups,uptime}.1.po \
+ || die "Failed to clean up duplicates from build directory!"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" COMPRESSOR=:
+}