summaryrefslogtreecommitdiff
path: root/app-i18n/opencc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/opencc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/opencc')
-rw-r--r--app-i18n/opencc/Manifest5
-rw-r--r--app-i18n/opencc/files/opencc-test.patch11
-rw-r--r--app-i18n/opencc/metadata.xml15
-rw-r--r--app-i18n/opencc/opencc-1.0.5.ebuild44
-rw-r--r--app-i18n/opencc/opencc-9999.ebuild44
5 files changed, 119 insertions, 0 deletions
diff --git a/app-i18n/opencc/Manifest b/app-i18n/opencc/Manifest
new file mode 100644
index 000000000000..1cac514ef514
--- /dev/null
+++ b/app-i18n/opencc/Manifest
@@ -0,0 +1,5 @@
+AUX opencc-test.patch 202 BLAKE2B 1dd3bc35c1f8644cd4f27ce8a5b5dea3b0ef2750612f112d7dc6de658634ad5151972b80c7b2ede9f41ea98ac7a2d29eaeb961132c862f66dd160dc2dd522a6d SHA512 5318058587b41fb7021ffce64d4b999b1beed294ce4c00137fb4b0396dd2cb471af789bceb8a8076b1d4ec2226d3c3fdf8b3d3d6a1f5d80936cf2407b8bdd3ec
+DIST opencc-1.0.5.tar.gz 1598354 BLAKE2B a66b32b96dab543d8401960ff0548a4e3f9414606513941426eacf105bca0755a7b364c68b7eb996ef82444e52f849d2f8151353a14fb97a358ad1463fbea2d3 SHA512 3fbefbafe5c3c2491032158577ab97b5a3edf6ea98a03a7250deba082b72c3112ad4a3396d1a469936ec32e1d141f0a2236001c2891ac9c793add2b082596cc1
+EBUILD opencc-1.0.5.ebuild 951 BLAKE2B 5754abcfea97a56100601ae189e2274542976063ab0ee943f227c67e98381dde4bfe1e153f6d9474eb79be2edbc8c73b220826589489f5c612751feb9314b240 SHA512 065cf96608de11939d91a30c5d1c6358c64066cd3a3c858d2c4ecc4aef2a4b77a83554e072e0f05234331818b7a4662dd32dfe114735023dd6ff0f44686aba8c
+EBUILD opencc-9999.ebuild 927 BLAKE2B 00d77822d6157ce7f0c29c6db267b76571a49c7ee80c8cbce464df499b23b42e99fb2e92795895cef2cb7485be3a9ec96c8db3d2148a7f19cefcb3e338913364 SHA512 868b831de1cc47afe1b471848df50eb036c8f29701839a3ca3767aba8e42b10a227dd9dc33ee726331a890ef3938ef71af444582f1f2d16c785158f7b36e5eb6
+MISC metadata.xml 491 BLAKE2B ec523a795afb6ae99cc5835e3df9fe07916aac4bf8552254f3bacbb9e1764a3ba5a79eddcabd8f34417544709a10a0bd34e6133a01b9b7a15156a9d282316d86 SHA512 303cf35b932c5d5a1fdd1a25b2c71a65a4aab761fe3c66d72439d691255a5edd1b943287afe8b4c53ab62531a012dafb5f416471a172f5b487557684dc6655df
diff --git a/app-i18n/opencc/files/opencc-test.patch b/app-i18n/opencc/files/opencc-test.patch
new file mode 100644
index 000000000000..dd6e91b984d2
--- /dev/null
+++ b/app-i18n/opencc/files/opencc-test.patch
@@ -0,0 +1,11 @@
+--- a/src/PhraseExtractTest.cpp
++++ b/src/PhraseExtractTest.cpp
+@@ -16,6 +16,8 @@
+ * limitations under the License.
+ */
+
++#include <cmath>
++
+ #include "PhraseExtract.hpp"
+ #include "TestUtils.hpp"
+
diff --git a/app-i18n/opencc/metadata.xml b/app-i18n/opencc/metadata.xml
new file mode 100644
index 000000000000..377bdc587a2d
--- /dev/null
+++ b/app-i18n/opencc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <longdescription lang="en">
+ OpenCC is a library for converting characters and phrases between
+ Traditional Chinese and Simplified Chinese.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">BYVoid/OpenCC</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-i18n/opencc/opencc-1.0.5.ebuild b/app-i18n/opencc/opencc-1.0.5.ebuild
new file mode 100644
index 000000000000..ba948e2bf80d
--- /dev/null
+++ b/app-i18n/opencc/opencc-1.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/BYVoid/OpenCC"
+else
+ inherit vcs-snapshot
+
+ SRC_URI="https://github.com/BYVoid/${PN^^[oc]}/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Libraries for conversion between Traditional and Simplified Chinese"
+HOMEPAGE="https://github.com/BYVoid/OpenCC"
+
+LICENSE="Apache-2.0"
+SLOT="0/2"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+IUSE="doc test"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS *.md"
+PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+
+src_prepare() {
+ sed -i "s|\${DIR_SHARE_OPENCC}/doc|share/doc/${PF}|" doc/CMakeLists.txt
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_SHARED_LIBS=ON
+ -DENABLE_GTEST=$(usex test)
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-i18n/opencc/opencc-9999.ebuild b/app-i18n/opencc/opencc-9999.ebuild
new file mode 100644
index 000000000000..9ec1cbd5d8b7
--- /dev/null
+++ b/app-i18n/opencc/opencc-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/BYVoid/OpenCC"
+else
+ inherit vcs-snapshot
+
+ SRC_URI="https://github.com/BYVoid/${PN^^[oc]}/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Libraries for conversion between Traditional and Simplified Chinese"
+HOMEPAGE="https://github.com/BYVoid/OpenCC"
+
+LICENSE="Apache-2.0"
+SLOT="0/2"
+KEYWORDS=""
+IUSE="doc test"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS *.md"
+PATCHES=( "${FILESDIR}"/${PN}-test.patch )
+
+src_prepare() {
+ sed -i "s|\${DIR_SHARE_OPENCC}/doc|share/doc/${PF}|" doc/CMakeLists.txt
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_SHARED_LIBS=ON
+ -DENABLE_GTEST=$(usex test)
+ )
+ cmake-utils_src_configure
+}