summaryrefslogtreecommitdiff
path: root/app-i18n/pyzy/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-i18n/pyzy/files
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/pyzy/files')
-rw-r--r--app-i18n/pyzy/files/pyzy-boost.patch15
-rw-r--r--app-i18n/pyzy/files/pyzy-db.patch17
-rw-r--r--app-i18n/pyzy/files/pyzy-opencc-1.0.0.patch56
3 files changed, 0 insertions, 88 deletions
diff --git a/app-i18n/pyzy/files/pyzy-boost.patch b/app-i18n/pyzy/files/pyzy-boost.patch
deleted file mode 100644
index 34acacfbc9ba..000000000000
--- a/app-i18n/pyzy/files/pyzy-boost.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -143,9 +143,9 @@
- )
- if test x"$enable_boost" = x"yes"; then
- # check boost
-- BOOST_REQUIRE([1.39])
-- BOOST_FIND_HEADER([boost/bind.hpp])
-- BOOST_FIND_HEADER([boost/signals2.hpp])
-+ AX_BOOST_BASE([1.39])
-+ AC_CHECK_HEADERS([boost/bind.hpp])
-+ AC_CHECK_HEADERS([boost/signals2.hpp])
- fi
- AM_CONDITIONAL(HAVE_BOOST, test x"$enable_boost" = x"yes")
-
diff --git a/app-i18n/pyzy/files/pyzy-db.patch b/app-i18n/pyzy/files/pyzy-db.patch
deleted file mode 100644
index 44d0ac6bf456..000000000000
--- a/app-i18n/pyzy/files/pyzy-db.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/data/db/open-phrase/Makefile.am
-+++ b/data/db/open-phrase/Makefile.am
-@@ -30,13 +30,10 @@
- DBTAR = pyzy-database-$(DBVER).tar.bz2
-
- $(DBTAR):
-- $(AM_V_GEN) \
-- wget http://pyzy.googlecode.com/files/$(DBTAR) || \
-- ( $(RM) $@; exit 1)
-+ touch $@
-
- stamp-db: $(DBTAR)
- $(AM_V_GEN) \
-- tar jxfm $(DBTAR); \
- mv db/main.db db/$(db_file); \
- touch $@
-
diff --git a/app-i18n/pyzy/files/pyzy-opencc-1.0.0.patch b/app-i18n/pyzy/files/pyzy-opencc-1.0.0.patch
deleted file mode 100644
index 1e23e8b6e5db..000000000000
--- a/app-i18n/pyzy/files/pyzy-opencc-1.0.0.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-https://github.com/pyzy/pyzy/pull/1
-
-Author: Hillwood Yang <hillwood@opensuse.org>
-
---- a/src/SimpTradConverter.cc
-+++ b/src/SimpTradConverter.cc
-@@ -4,6 +4,7 @@
- *
- * Copyright (c) 2008-2010 Peng Huang <shawn.p.huang@gmail.com>
- * Copyright (c) 2010 BYVoid <byvoid1@gmail.com>
-+ * Copyright (c) 2015 Hillwood Yang <hillwood@opensuse.org>
- *
- * This library is free software; you can redistribute it and/or
- * modify it under the terms of the GNU Lesser General Public
-@@ -40,7 +41,6 @@ namespace PyZy {
- #ifdef HAVE_OPENCC
-
- class opencc {
-- static const int BUFFER_SIZE = 64;
- public:
- opencc (void)
- {
-@@ -55,29 +55,13 @@ public:
-
- void convert (const char *in, String &out)
- {
-- long n_char;
-- unichar *in_ucs4 = g_utf8_to_ucs4_fast (in, -1, &n_char);
--
-- ucs4_t *pinbuf = (ucs4_t *)in_ucs4;
-- size_t inbuf_left = n_char;
-- while (inbuf_left != 0) {
-- ucs4_t *poutbuf = (ucs4_t *)m_buffer;
-- size_t outbuf_left = BUFFER_SIZE;
-- size_t retval = opencc_convert(m_od, &pinbuf, &inbuf_left, &poutbuf, &outbuf_left);
-- if (retval == (size_t) -1) {
-- /* append left chars in pinbuf */
-- g_warning ("opencc_convert return failed");
-- out << (unichar *) pinbuf;
-- break;
-- }
-- *poutbuf = L'\0';
-- out << m_buffer;
-- }
-- g_free (in_ucs4);
-+ char * converted = opencc_convert_utf8 (m_od, in, -1);
-+ g_assert (converted != NULL);
-+ out = converted;
-+ opencc_convert_utf8_free (converted);
- }
- private:
- opencc_t m_od;
-- unichar m_buffer[BUFFER_SIZE + 1];
- };
-
- void