summaryrefslogtreecommitdiff
path: root/app-i18n/scim-pinyin/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-i18n/scim-pinyin/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-i18n/scim-pinyin/files')
-rw-r--r--app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-fixconfigure.patch33
-rw-r--r--app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gbk.patch62
-rw-r--r--app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gcc43.patch44
-rw-r--r--app-i18n/scim-pinyin/files/scim-pinyin-qt335.patch25
4 files changed, 164 insertions, 0 deletions
diff --git a/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-fixconfigure.patch b/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-fixconfigure.patch
new file mode 100644
index 000000000000..e91b084f3211
--- /dev/null
+++ b/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-fixconfigure.patch
@@ -0,0 +1,33 @@
+Index: scim-pinyin-0.5.91/configure.ac
+===================================================================
+--- scim-pinyin-0.5.91.orig/configure.ac
++++ scim-pinyin-0.5.91/configure.ac
+@@ -73,11 +73,7 @@ AC_ARG_ENABLE(debug,
+ enable_debug=no)
+
+ AC_ARG_ENABLE(skim-support,
+- [ --disable-skim-support Enable skim Setup UI],
+- skim_support=no,
+- skim_support=yes)
+-
+-AM_CONDITIONAL(SCIM_BUILD_SKIM_SETUP, [test "$skim_support" = "yes"])
++ [ --disable-skim-support Enable skim Setup UI])
+
+ if test "$enable_debug" = "yes"; then
+ AC_DEFINE(ENABLE_DEBUG,1,[Define this to enable the debug facility in libscim])
+@@ -126,7 +122,7 @@ AC_CONFIG_FILES([Makefile
+ po/Makefile.in
+ scim-pinyin.spec])
+
+-if test "$skim_support" = "yes"; then
++if test "x$enable_skim_support" != "xno"; then
+ REQUIRED_SKIM_VERSION=1.2.1
+ dnl skim probably has been installed under prefix=$KDEDIR, so add it to search path of pkgconfig
+ kde_libsuffix=`kde-config --libsuffix`
+@@ -155,5 +151,6 @@ PKG_CHECK_MODULES(SCIM_KDEUTILS,[scim_kd
+ fi
+
+ AM_CONDITIONAL(SCIM_PINYIN_ENABLE_SKIM_SUPPORT, [test "$HAS_KDEUTILS" = "yes"])
++AM_CONDITIONAL(SCIM_BUILD_SKIM_SETUP, [test "$HAS_SKIM" = "yes"])
+ AC_SUBST(SCIM_PINYIN_ENABLE_SKIM_SUPPORT)
+ AC_OUTPUT
diff --git a/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gbk.patch b/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gbk.patch
new file mode 100644
index 000000000000..bc6a228fb0cc
--- /dev/null
+++ b/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gbk.patch
@@ -0,0 +1,62 @@
+diff -Nru scim-pinyin-0.5.91.orig/src/scim_pinyin_imengine.cpp scim-pinyin-0.5.91/src/scim_pinyin_imengine.cpp
+--- scim-pinyin-0.5.91.orig/src/scim_pinyin_imengine.cpp 2005-08-06 23:31:08.000000000 +0800
++++ scim-pinyin-0.5.91/src/scim_pinyin_imengine.cpp 2009-02-18 00:06:34.000000000 +0800
+@@ -706,8 +706,12 @@
+ m_sys_phrase_lib = m_pinyin_global->get_sys_phrase_lib ();
+ m_user_phrase_lib = m_pinyin_global->get_user_phrase_lib ();
+ }
+-
+- if (encoding == "GBK" || encoding == "GB2312") {
++
++ if (encoding == "GBK") {
++ m_simplified = true;
++ m_traditional = true;
++ m_chinese_iconv.set_encoding ("GBK");
++ } else if (encoding == "GB2312") {
+ m_simplified = true;
+ m_traditional = false;
+ m_chinese_iconv.set_encoding ("GB2312");
+@@ -930,10 +934,39 @@
+
+ m_iconv.set_encoding (encoding);
+
+- if (encoding == "GBK" || encoding == "GB2312") {
+- m_simplified = true;
+- m_traditional = false;
+- m_chinese_iconv.set_encoding ("GB2312");
++ if (encoding == "GBK") {
++ if (m_simplified == false) {
++ if(m_traditional == true){
++ ; //Big5. Big5togbk is not implemented. Set to next available.
++ m_simplified = true;
++ m_chinese_iconv.set_encoding ("GBK");
++ }else{ // nochinese mode. Should not happen.
++ m_forward = true;
++ m_chinese_iconv.set_encoding ("");
++ }
++ }else{
++ if( m_traditional == false) //GB2312
++ m_chinese_iconv.set_encoding("GB2312");
++ else m_chinese_iconv.set_encoding ("GBK"); //ALL
++ }
++ } else if (encoding == "GB2312") {
++ if ( m_simplified == false ) {
++ if(m_traditional == true) {
++ ; //partly map big5 to gb2312 is not done. Set to next.
++ m_forward = true;
++ m_chinese_iconv.set_encoding ("");
++ }else{//Should not happen.
++ m_forward = true;
++ m_chinese_iconv.set_encoding("");
++ }
++ }else{
++ if (m_traditional == true) { //Should not happen.
++ m_forward = true;
++ m_chinese_iconv.set_encoding ("");
++ }else{
++ m_chinese_iconv.set_encoding ("GB2312");
++ }
++ }
+ } else if (encoding == "BIG5" || encoding == "BIG5-HKSCS") {
+ m_simplified = false;
+ m_traditional = true;
diff --git a/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gcc43.patch b/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gcc43.patch
new file mode 100644
index 000000000000..6f9bd3879eb0
--- /dev/null
+++ b/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gcc43.patch
@@ -0,0 +1,44 @@
+diff -Naur scim-pinyin-0.5.91.orig/src/scim_phrase.cpp scim-pinyin-0.5.91/src/scim_phrase.cpp
+--- scim-pinyin-0.5.91.orig/src/scim_phrase.cpp 2005-01-06 22:30:58.000000000 +0900
++++ scim-pinyin-0.5.91/src/scim_phrase.cpp 2008-06-21 13:16:32.000000000 +0900
+@@ -27,6 +27,7 @@
+
+ #define SCIM_PHRASE_MAX_RELATION 1000
+
++#include <cstring>
+ #include <scim.h>
+ #include "scim_pinyin_private.h"
+ #include "scim_phrase.h"
+diff -Naur scim-pinyin-0.5.91.orig/src/scim_pinyin.cpp scim-pinyin-0.5.91/src/scim_pinyin.cpp
+--- scim-pinyin-0.5.91.orig/src/scim_pinyin.cpp 2005-08-08 15:11:16.000000000 +0900
++++ scim-pinyin-0.5.91/src/scim_pinyin.cpp 2008-06-21 13:16:30.000000000 +0900
+@@ -28,6 +28,7 @@
+ #define Uses_SCIM_CONFIG_PATH
+ #define Uses_SCIM_LOOKUP_TABLE
+
++#include <cstring>
+ #include <scim.h>
+ #include "scim_pinyin.h"
+
+diff -Naur scim-pinyin-0.5.91.orig/src/scim_pinyin_phrase.cpp scim-pinyin-0.5.91/src/scim_pinyin_phrase.cpp
+--- scim-pinyin-0.5.91.orig/src/scim_pinyin_phrase.cpp 2005-08-06 21:06:49.000000000 +0900
++++ scim-pinyin-0.5.91/src/scim_pinyin_phrase.cpp 2008-06-21 13:21:13.000000000 +0900
+@@ -26,6 +26,7 @@
+ #define Uses_SCIM_CONFIG_PATH
+ #define Uses_SCIM_LOOKUP_TABLE
+
++#include <cstring>
+ #include <scim.h>
+ #include "scim_pinyin_private.h"
+ #include "scim_phrase.h"
+diff -Naur scim-pinyin-0.5.91.orig/src/scim_special_table.cpp scim-pinyin-0.5.91/src/scim_special_table.cpp
+--- scim-pinyin-0.5.91.orig/src/scim_special_table.cpp 2005-01-06 22:31:02.000000000 +0900
++++ scim-pinyin-0.5.91/src/scim_special_table.cpp 2008-06-21 13:25:25.000000000 +0900
+@@ -20,6 +20,7 @@
+ #define Uses_STL_IOMANIP
+ #define Uscs_C_STRING
+
++#include <cstring>
+ #include <time.h>
+ #include <scim.h>
+ #include "scim_pinyin_private.h"
diff --git a/app-i18n/scim-pinyin/files/scim-pinyin-qt335.patch b/app-i18n/scim-pinyin/files/scim-pinyin-qt335.patch
new file mode 100644
index 000000000000..c7c0c595c0d1
--- /dev/null
+++ b/app-i18n/scim-pinyin/files/scim-pinyin-qt335.patch
@@ -0,0 +1,25 @@
+Index: scim-pinyin-0.5.91/skim/setupui/smartpinyinui.ui
+===================================================================
+--- scim-pinyin-0.5.91.orig/skim/setupui/smartpinyinui.ui
++++ scim-pinyin-0.5.91/skim/setupui/smartpinyinui.ui
+@@ -863,20 +863,4 @@
+ <tabstop>kcfg__IMEngine_Pinyin_DisablePhraseKey</tabstop>
+ </tabstops>
+ <layoutdefaults spacing="6" margin="11"/>
+-<includehints>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+-</includehints>
+ </UI>