summaryrefslogtreecommitdiff
path: root/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild')
-rw-r--r--app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild b/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..8b9fe22e0718
--- /dev/null
+++ b/app-i18n/scim-uim/scim-uim-0.2.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An input module for Smart Common Input Method (SCIM) which uses uim as backend"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=app-i18n/uim-1.5.0
+ >=app-i18n/scim-1.4.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-uim-1.5.patch
+)
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # plugin module, no point in .la files
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog
+}