summaryrefslogtreecommitdiff
path: root/app-i18n/translate-shell/translate-shell-0.9.6.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-i18n/translate-shell/translate-shell-0.9.6.11.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-i18n/translate-shell/translate-shell-0.9.6.11.ebuild')
-rw-r--r--app-i18n/translate-shell/translate-shell-0.9.6.11.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/translate-shell/translate-shell-0.9.6.11.ebuild b/app-i18n/translate-shell/translate-shell-0.9.6.11.ebuild
new file mode 100644
index 000000000000..833f76cb661d
--- /dev/null
+++ b/app-i18n/translate-shell/translate-shell-0.9.6.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Online command-line translator"
+HOMEPAGE="https://www.soimort.org/translate-shell/"
+SRC_URI="https://github.com/soimort/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/gawk"
+DEPEND="${RDEPEND}
+ test? (
+ app-editors/emacs
+ app-misc/rlwrap
+ )"
+
+src_test() {
+ emake NETWORK_ACCESS=no test
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+}
+
+pkg_postinst() {
+ elog "You may need to install the following optional packages for full functionality:"
+ optfeature "Support all built-in translators (e.g. Apertium, Yandex)" net-misc/curl[ssl]
+ optfeature "Display text in right-to-left scripts" dev-libs/fribidi
+ optfeature "Text-to-speech functionality" media-sound/mpg123 app-accessibility/espeak media-video/mpv media-video/mplayer
+ optfeature "Interactive translation (REPL)" app-editors/emacs app-misc/rlwrap
+ optfeature "Spell checking" app-text/aspell app-text/hunspell
+}